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1. Generació d'imatge de síntesi en 3D

Les produccions professionals 3D poden arribar a ser realment complexes, per

la qual cosa és habitual trobar equips de treball molt amplis i compostos per

diversos perfils molt especialitzats. Entre l'equip humà involucrat en un pro-

jecte 3D, hi poden haver persones relacionades amb la producció i d'altres que

desenvolupen funcions alienes a l'àrea de producció 3D. En el departament

3D hi ha dos tipus de perfils:

• Especialitzat en les diferents àrees del procés de creació de projectes 3D, tals

com modelatge, creació de materials i texturitzat, animació, il·luminació,

etc. Aquests són els tipus de perfils que es troben en produccions profes-

sionals, tant en el camp audiovisual com en el desenvolupament de vide-

ojocs.

• Generalista 3D: personal que pot desenvolupar projectes 3D en qualsevol

de les àrees relacionades però que no en tenen un coneixement profund.

Aquest perfil és habitual en petites produccions.

Al seu torn, els perfils o àrees de producció d'un departament 3D poden estar

compostos pels àmbits següents:

• Modelatge: el personal d'aquesta àrea s'encarrega de generar els objectes

en un espai tridimensional.

• Creació de materials i texturitzat: aquesta part del departament s'encarrega

d'aplicar i editar les propietats relacionades amb l'aparença física dels ma-

terials (color, reflex, transparència, etc.), així com de crear i aplicar les tex-

tures necessàries per a simular l'aspecte dels objectes, com ara textures de

pedra, de fulles, de fusta, etc.

• Character setup i rigging: aquí s'encarreguen de crear i configurar un esquelet

virtual i els seus controls als objectes que sigui necessari; sol ser més propi

de personatges humans o humanoides, animals, etc.

• Animació: en aquesta àrea es desenvolupa l'animació dels personatges o

els objectes a partir dels models que tenen ja aplicat el rigging.

• Il·luminació i render: els membres d'aquesta àrea són els responsables

d'estructurar un set d'il·luminació d'acord amb l'escena i de configurar els

paràmetres adequats per a obtenir una imatge final.
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• Efectes: s'encarreguen de fer els efectes visuals i les dinàmiques, com ara

fluids, fum, etc.

• Recerca i desenvolupament: és l'equip encarregat de desenvolupar les eines

necessàries per a complir amb els requisits de l'equip creatiu.

Procés de creació d'una producció 3D

1.1. Visualització 3D

En primer lloc, hem de tenir en compte que estem projectant imatges en tres

dimensions en un plànol en dues dimensions, la pantalla. Aquest procés re-

quereix un gran processament de càlcul i, per tant, calen programaris i equips

capaços de processar els càlculs necessaris per a generar aquest tipus d'imatges.

Per aquest motiu, si volem tenir un rendiment òptim, és imprescindible que

el nostre equip compleixi uns requeriments tècnics mínims abans d'instal·lar-

hi el programari 3D.

La creació d'imatges 3D s'utilitza per a desenvolupar objectes o escenaris que

no existeixen en la realitat o que tindran animacions especials, per a crear

prototips, per a crear escenaris en els quals s'integra imatge real, etc. Els pro-

jectes 3D s'apliquen especialment en sectors com l'arquitectura, l'enginyeria,

els productes audiovisuals i els videojocs. A continuació, descrivim diversos

aspectes destacables de la visualització en 3D.
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1.1.1. Vistes

Autodesk Maya ens ofereix la possibilitat de poder visualitzar els objectes que

estem modelant des de diferents punts de vista; això facilita el procés de cre-

ació tant des del punt de vista tècnic com creatiu.

Els tipus de vistes que podem trobar són els següents:

1)�Ortogràfiques: representen els objectes i elements de l'escena en un plànol

a través d'una projecció ortogonal. Aquest tipus de projeccions són el que co-

neixem com a planta, alçat i perfil; per tant, són vistes en dues dimensions.

Planta, alçat, perfil i perspectiva

2)�Perspectiva: referent a les càmeres virtuals. És una representació en 3D dins

de la vista 2D, de manera que les línies que formen els objectes van variant

a mesura que es modifica el punt de fuga. Tenir una vista en perspectiva ens

permet fer operacions com translacions, rotacions i zoom dins de l'espai de

l'escena.

Quant a les vistes ortogràfiques, a Maya trobem les projeccions següents:

• La vista top -Y, que equival a la planta de l'objecte.

• La vista front -Z, que equival a l'alçat de l'objecte.

• La vista side -X, que equival al perfil de l'objecte.
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Vista ortogràfica d'un con a Autodesk Maya

D'altra banda, tenim la vista perspectiva, que és una càmera virtual que es

pot moure en les tres dimensions. Per defecte, Maya s'inicia amb una càmera

virtual denominada persp, però cal tenir en compte que podem crear tantes

càmeres virtuals com vulguem.

1.1.2. Grid

El grid és la reixeta horitzontal quadriculada que apareix en la vista persp. El grid

ens ajuda a situar-nos en l'espai o fins i tot a tenir una referència de grandàries.

El grid es pot mostrar o ocultar a Display > Grid.

Tips

És un error recurrent intentar
rotar en una vista ortogràfica;
es tracta d'una acció impossi-
ble, ja que, com hem dit, són
vistes en 2D i, per tant, no te-
nen profunditat.

Grid d'Autodesk Maya
Tips

En les opcions del grid podem
configurar la grandària, les
subdivisions de la reixeta, el
color, etc.
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1.1.3. Coordenades

Per facilitar la creació i el moviment d'elements dins de l'espai hi ha l'eix de co-

ordenades. Per tant, cada element té unes coordenades en l'espai. Per a conèi-

xer les coordenades en què està situat l'objecte cal accedir a Windows > Gene-

ral Editors > Channel Box/Layer Editor i seleccionar l'objecte.

Els eixos de coordenades estan codificats en diferents colors per poder visu-

alitzar més fàcilment l'eix que estem treballant. El codi de color que utilitza

Maya és vermell per a l'eix X, verd per a l'eix Y i blau per a l'eix Z.

Eixos de coordenades d'objecte

1.2. Flux de treball a Autodesk Maya

El flux de treball a Maya té les seves particularitats respecte d'altres programaris

genèrics, tot i que és molt similar a d'altres d'àmbit professional en què es

realitzen projectes de producció 3D i fins i tot audiovisual. A continuació,

analitzem com es creen i gestionen projectes, quins formats hi ha, etc.

1.2.1. Formats dels projectes

En guardar un projecte en Maya podem crear dos tipus de formats diferents.

• Maya Binari (.mb): és el format natiu.

• Maya ASCII (.ma): és un format editable i, per tant, s'hi pot afegir infor-

mació.

Els projectes es guarden per defecte en el format natiu .mb; si volem guardar

el projecte en un format diferent, haurem d'anar a File > Scene as i seleccionar

format .ma.

Tips

• Es pot modificar l'eix verti-
cal (altura) a través de Win-
dows > Settings/Preferen-
ces > Preferences > World
Coordinate System. De ve-
gades aquesta operació
és necessària perquè hi ha
programaris en els quals la
nomenclatura d'aquest eix
varia.

• Es poden variar les unitats
en què es mesuren aques-
tes coordenades a través
de Windows > Settings/Pre-
ferences > Preferences >
Working Units > Linear.

Tips

El format .mb té un pes me-
nor que .ma, però aquest úl-
tim permet obrir projectes en
diferents versions de Maya.
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1.2.2. Creació i configuració de projectes

En primer lloc, cal tenir en compte que els projectes de Maya no es limiten sim-

plement als arxius .ma i .mb; de fet, l'única informació que contenen aquests

arxius són les escenes. Realment, quan creem un projecte de Maya apareixen

una sèrie de carpetes que contenen tot el material necessari per a desenvolu-

par correctament un projecte. La manera de crear una carpeta de projecte és

a través de File > Project Window.

Gestió de projectes (Project Window)

La finestra Project Window proporciona tota la informació de les carpetes que

componen el projecte. A més, és necessari afegir un nom al projecte (Current

Project) i una ubicació (Location). Com veiem, es pot editar el nom de cadascuna

d'aquestes carpetes de projecte; per exemple, trobem les carpeta escenes (.ma

i .mb), arxius d'àudio, imatges i textures, clips de vídeo, temporals, seqüències

d'imatges renderitzades, etc.

Posteriorment, veurem com es prepara i configura el producte final, el render.

Si el nostre projecte està creat i encaminat (Set project) correctament, aquestes

imatges resultants sempre aniran a la mateixa carpeta del Project Window,

images.

1.2.3. Nomenclatura

El desenvolupament de projectes 3D de certa envergadura pot arribar a generar

una gran quantitat d'arxius, ja que hem de tenir en compte escenes, textures,

models, animacions, preses, etc. Per aquest motiu, és crucial establir un sistema

de nomenclatura de tota aquesta quantitat d'arxius.

Tips

Si obrim una escena hem de
configurar en quin projecte
volem treballar; per a això se-
leccionem File > Set Project;
d'aquesta manera, tots els
temporals i les imatges rende-
ritzades aniran per defecte a la
carpeta corresponent del pro-
jecte.



© FUOC • PID_00270544 13 Gràfics 3D

Senyalització d'autovies

Quant a la quantitat d'arxius resultants, cal tenir en compte que Maya rende-

ritza les seqüències en imatges independents; per tant, si creem una seqüència

de 10 segons, no crearà un .mov o un .avi d'aquesta durada, sinó que serà una

seqüència de 250 imatges (tenint en compte que treballem a 25 fotogrames

per segon). Per tant, es crearan una gran quantitat d'arxius i és necessari tenir

una estructura molt organitzada amb noms descriptius.

En relació amb la nomenclatura dels arxius es recomana el següent:

• Anomenar la versió de l'arxiu en la qual s'està treballant. Per exemple:

escena_bosc_03.mb.

• No deixar espais en el nom dels arxius, utilitzar guions baixos o po-

sar la segona paraula en majúscula. Per exemple: escena_bosc_03.mb,

escenaBosc03.mb.

• Per a les versions modificades o definitives, no repetir l'última lletra en

les versions, com per exemple clip_booooooooo.jpg, ni la paraula OK re-

petida clip_boOKOKOKOKOK.jpg. Per tant, la nomenclatura hauria de ser

clip_bo_01.jpg, clip_bo_02.jpg, clip_bo_03.jpg, clip_bo_04.jpg, etc.

• Estandarditzar la nomenclatura per a tots els possibles tipus d'elements

que s'utilitzaran i fer una taula amb les abreviatures de la nomenclatura.

Per exemple:

Objectes obj

Textures tx

Preses presa

Versió ver

…. ….
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Exemples de nomenclatura

1) nomCognom_temaX_ejerciciX_versioX

Exemple: davidgarcia_tema01_ej01_ver01.mb

2) nomCognom_temaX_projecteX_presaX_planolX_versioX.

Exemple: davidgarcia_tema01_curtgripau_presa01_planol01_ver01.mb

Per tant, és imprescindible la coordinació tècnica dels recursos necessaris i

resultants, així com una fase de verificació i control de qualitat de les imatges

per a validar el procés.

1.3. Interface Autodesk Maya

1.3.1. Vistes

Ja hem analitzat els tipus de vistes que hi ha a Maya. Ara veurem com es navega

per l'espai de l'escena.

En primer lloc, hem de mantenir premuda la tecla ALT i amb els tres botons

del ratolí podem fer el següent:

• ALT+botó esquerre: rotació.

• ALT+botó central: paneo, translació horitzontal o vertical.

• ALT+botó dret: zoom in o zoom out.

1.3.2. Parts de l'interface

Parts en què es divideix la interface d'Autodesk Maya

Tips

• Tingueu en compte que en
les vistes ortogràfiques no
es pot rotar, atès que són
vistes en dues dimensions.

• Recordeu que mantenint
premuda la tecla espai, la
vista que tinguem selecci-
onada passarà a ocupar to-
ta la pantalla, i si tornem a
prémer-la passarem a la vis-
ta anterior.

• Recordeu que a través del
menú View Panell > Show
de cada vista podem filtrar
els elements que volem vi-
sualitzar.
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1)�Menús

Correspon a la part superior i ofereix l'opció de canviar el tipus de secció en

la qual volem treballar o fins i tot personalitzar-la a través del Menu Set. Les

opcions que apareixen en aquest menú es poden dividir en les que varien,

depenent el Menu Set que se selecciona, i les que apareixen sempre, amb in-

dependència de la selecció del Menu Set.

Menús

D'altra banda, en desplegar-se cadascun dels menús, apareix en la part superior

una línia puntejada; si hi fem clic i arrosseguem aquesta finestra es converteix

en flotant. Aquesta acció és realment útil quan cal utilitzar diverses opcions

o eines d'aquest menú.

Finestra flotant

2)�Menu�Set

Ofereix la possibilitat de variar entre les diferents categories del programa:

Modeling, Rigging, Animation, FX i Rendering. Fins i tot permet la possibilitat

de personalitzar les categories existents.
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Menu Sets

3)�Status�line

A la dreta del Menu Set trobem una sèrie d'icones que representen diverses

de les eines i accions més utilitzades. Mitjançant la línia vertical que apareix

entre cada grup d'eines es pot expandir o comprimir el submenú.

Status line

4)�Shelf

Hi ha diverses pestanyes que contenen icones amb les eines que el programari

considera més comunes. Aquestes pestanyes es poden personalitzar i fins i tot

se'n poden crear de noves amb les eines que vulguem. Aquesta és una manera

ràpida de poder accedir a les eines més utilitzades.

Shelf Poly Modeling

Shelf Polygons
Tips

Es pot crear un nou shelf per-
sonalitzat fent clic a la icona de
l'engranatge > New Shelf. Es
genera una pestanya nova bui-
da si es prem Ctrl + Shift + clic
en l'eina que vulguem afegir al
shelf.
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Nou shelf

5)�Selector�Workspace

Permet poder seleccionar l'espai de treball que més s'adapti a les nostres ne-

cessitats.

Workspace

6)�Slider�icons

Aquestes icones donen accés directe a una sèrie d'eines agrupades que són

molt utilitzades en diferents moments de la creació de projectes 3D. Estan

compostes per:

• Modelling Toolkit

• HumanIK

• Attribute Editor

• Tool Settings

• Channel Box/Layer Editor
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Slider icons

7)�Channel�box

Aquesta és una de les pestanyes que també apareixen en l'Slider icons anteri-

orment explicat. En aquesta secció s'ofereix a l'usuari la possibilitat d'editar

certs valors dels objectes seleccionats.

Channel Box

8)�Layer�editor

Hi ha dos tipus de finestres de capes, les d'animació i les de visualització. En el

nostre cas, la més interessant és la pestanya Display, ja que permet crear capes

dels objectes que vulguem, agrupar-los, ocultar-los, etc.

• V: fa la capa visible, si es desactiva oculta la capa.

• P: tots els elements de la capa visible en play.

• R: referència. Els elements de la capa no poden ser seleccionats.

• T: template. Els elements de la capa es mostren en mode filferro (wireframe)

i no poden ser seleccionats.

• A més, tots els elements que pertanyen a una capa també es poden orga-

nitzar per colors.

Tips

És interessant utilitzar-lo per-
què permet editar els paràme-
tres de manera aïllada i a tra-
vés d'un control numèric, per
la qual cosa permet fer modifi-
cacions més precises i contro-
lades.
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Layer Editor

9)�View�panell

Es troba a la part superior de cadascuna de les vistes (top, side, front, persp).

Presenta un menú amb icones d'accés ràpid i menús desplegables amb nom-

broses opcions de visualització.

Eines i opcions del View Panell

10)�Tool�box

Conté les eines utilitzades per a seleccionar i transformar objectes de l'escena.

Tips

És molt útil per a filtrar els ob-
jectes que es volen visualitzar a
través de Show. Permet selec-
cionar els modes de visualitza-
ció, a wireframe, shaded, amb
textura o amb llums. També
serveix per a poder veure les
àrees de retall del format final
de l'arxiu. Fins i tot es pot se-
leccionar qualsevol vista orto-
gràfica, o de perspectiva, i per-
met crear noves càmeres, tot
això a través de Panels.
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11)�Botons�Quick�layout/Outliner

És un accés ràpid als diferents tipus de visualització de l'escena. Per tant, es

poden seleccionar les vistes en perspectiva (totes les càmeres que vulguem),

les vistes ortogràfiques (front, side, top) o es pot mostrar l'Outliner.

Tips

És recomanable utilitzar els ac-
cessos directes:
• Q: Select, selecció de

l'element.
• W: Move, translació de

l'element.
• E: Rotate, rotació de

l'element.
• R: Scale, escalat de

l'element.
• T: accés directe als ele-

ments de transformació.

L'Outliner és una finestra que conté tots els elements que hi ha a l'escena.

Ofereix informació sobre la jerarquia dels elements; es pot filtrar la informació

que apareix a través de la pestanya Show perquè apareguin solament les llums,

les geometries, les càmeres, etc.

L'Outliner també es pot trobar a la barra principal de menú, a Windows >

Outliner, i al panell, a Panels > Panel > Outliner.

L'Outliner mostra els objectes per defecte de l'escena (càmeres de les vistes

ortogràfiques i persp), els objectes que hàgim creat (geometries, llums, càmeres,

etc.).

Tips

Prement la tecla d'espai una
sola vegada la vista selecciona-
da passa a ocupar tota la pan-
talla; si tornem a prémer, torna
a la configuració anterior.
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Outliner

12)�Time�Slider

És la línia de temps amb tots els frames que contenen l'animació. Les línies

vermelles defineixen on hi ha un keyframe.

Time Slider

13)�Range�Slider

Aquesta opció permet establir el frame d'inici i final de l'animació en l'escena.

Al seu torn, es pot definir un rang de reproducció de l'animació, ja que hi

ha vegades que interessa reproduir solament alguna part de l'animació per a

matisar certs aspectes del moviment.

Range Slider

14)�Controls�Playback

Són els controls de reproducció, de manera que es pot veure l'animació cap

endavant, cap enrere, anar frame a frame o fins i tot desplaçar-se de keyframe

a keyframe.

Tips

Si tenim premut el botó cen-
tral seleccionant un objecte
i el desplacem cap a un altre
objecte (mantenint premut
el botó central), crearem un
parentiu entre objectes, tal
com podem veure en la imat-
ge: Cap i Cames pertanyen a
Cos. D'aquesta manera, po-
dem anar creant una jerarquia
entre els elements de l'escena.
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Playback controls

15)�Menús�Anim/Character

Proporcionen accés a característiques avançades d'animació, com el Character

Set i l'Anim Layer.

Anim Layer

16)�Opcions�Playback

Control de les opcions de reproducció. A: fotogrames per segon. B: reproducció

(Bucle). C: keyframes automàtics. D: accés a les preferències.

Opcions Playback

17)�Command�Line

És l'àrea on es pot introduir codi, en aquest cas en llenguatge MEL o Python,

per a fer operacions. A través de la icona Show Script Editor, es pot obrir la

finestra per veure totes les operacions que es van fent en format codi.

Command Line

18)�Help�Line

A la part inferior hi ha una caixa on apareix informació descriptiva rellevant

sobre on és el punter i també sobre com es poden completar accions.
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Help Line

1.3.3. Attribute Editor

És una finestra que ens permet accedir a diferents atributs de l'objecte selecci-

onat. És semblant a una vista expandida i molt més gràfica que el Channel

Box. Es pot accedir a l'Attribute Editor des de les opcions següents:

• Select Windows > General Editors > Attribute Editor

• Select Windows > UI Elements > Attribute Editor

• Select Key > Attribute Editor

• Des de l'accés directe de l'Slider Icons

Accés des de l'Slider icons

A la part superior es pot accedir a tots els nodes que pertanyen a l'objecte

seleccionat.
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1.3.4. Opcions eines/operacions

Al costat de les eines apareix la icona d'un quadrat; si hi fem clic s'obren les

opcions d'aquesta eina.

Quadrat d'opcions

1.3.5. Dreceres de teclat (shortcuts)

Les dreceres de teclat són fonamentals per a agilitar l'operació de qualsevol

programari; a continuació es presenta un resum de les més utilitzats.

Resum de dreceres de teclat

1.3.6. Hotbox

A més dels menús i les icones per a l'accés ràpid, hi ha una altra manera de

seleccionar eines i opcions. Prement la tecla espai (pulsació mantinguda) apa-

reixen totes les opcions i menús; si es prem de manera mantinguda en qual-

sevol de les seccions, es despleguen els submenús corresponents.

Tips

Si seleccionem l'opció Apply
s'apliquen les modificacions
(si n'hem fet) i la finestra se-
gueix oberta. No obstant ai-
xò, si premem el botó de
l'esquerra (que sol tenir el nom
de l'acció de l'eina; per exem-
ple, Create, Bake pivot, etc.),
s'executa l'eina i es tanca la fi-
nestra, i queden desats els va-
lors per a la següent vegada
que s'executi l'eina.

Tips

Es poden personalitzar les dre-
ceres de teclat a Windows >
Settings/Preferences > Hotkey
Editor.
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Menú Hotbox

1.4. Creació de primitives

Les primitives són els objectes geomètrics més bàsics que estima Maya a partir

dels quals es poden crear formes més complexes. Els paràmetres més habituals

en crear primitives són la grandària o el nombre de cares (faces). En la imatge

següent es pot apreciar, a l'esquerra, una esfera amb poques cares, i per tant

molt poligonal, i a la dreta, una altra amb més cares, més suavitzada.

Esferes amb diferents nombres de cares (faces)

1.4.1. Creació de primitives

Hi ha primitives poligonals, NURBS i Volume; més endavant analitzarem les

diferències entre cadascuna d'elles. Cadascun dels grups de primitives a Maya

estan compostes per:

Tips

Les opcions de Hotbox es po-
den personalitzar a través del
botó que hi ha a la dreta: Hot-
box controls. En mantenir pre-
mut aquest botó, es poden
configurar les opcions de visu-
alització.
Prement en el botó Maya (pul-
sació mantinguda) es pot con-
figurar qualsevol vista (ortogrà-
fiques o perspectives) en la vis-
ta en la qual es treballa.
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Tipus de primitives a Maya

Diferents tipus de primitives a Maya

1.4.2. Crear primitives i canviar característiques

Les primitives es poden crear a partir de les opcions següents:

• Create > Nurbs Primitives

• Create > Polygon Primitives

• Create > Volume Primitives

A l'Attribute Editor es poden variar de manera més visual (amb sliders) les ca-

racterístiques de l'objecte. A més, al Channel Box també les podem variar nu-

mèricament.
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Paràmetres de l'Attribute Editor

1.4.3. Interactive Creation

S'activa l'opció a Create > Polygon Primitives > Interactive Creation.

Amb aquesta opció activada podem crear primitives de manera interactiva fent

clic, i arrossegant i seguint les instruccions que apareixen en la pantalla.

Interactive Creation

Tips

Mitjançant Hotbox també te-
nim accés a les opcions de
Create.
A Channel Box > Inputs es pot
trobar la configuració de la pri-
mitiva.
Prement la tecla T s'accedeix
a les característiques de
l'objecte.
La visualització pot variar a tra-
vés de les dreceres de teclat se-
güents: 4 per a wireframe, 5
per a shaded, 6 per a textured i
7 per a lights.
L'objecte es pot modificar amb
les dreceres de teclat W (mou-
re), E (escalar), R (rotar), Q (se-
leccionar).
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1.5. Càmeres 3D, llums i render a Autodesk Maya

1.5.1. Càmeres 3D

Ja hem vist que qualsevol projecte de Maya comença amb quatre càmeres, les

tres ortogràfiques (side, front i top) i una en perspectiva (persp), o sigui, en 3D.

Les vistes pertanyents a càmeres 3D poden moure's en totes les direccions, tal

com vam veure, prement la tecla ALT+ qualsevol dels tres botons del ratolí.

Càmera 3D

També es poden crear més càmeres 3D a partir de Create > Cameras > i selec-

cionant un tipus de càmera. Podem seleccionar la càmera nova o qualsevol

d'elles en el menú del View Panel, Panels > Perspective > selecció de la càmera

que vulguem.

View Panell

Per a poder identificar les càmeres haurem d'anomenar-les amb noms descrip-

tius quan les creem. A més, també es podran anomenar a través de l'Outliner

o de l'Attribute Editor posteriorment.
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1.5.2. Llums

A Maya es poden crear tantes llums com necessitem per a il·luminar correc-

tament la nostra escena. Les llums es poden configurar en intensitat, color,

direccionalitat, decaïment, etc. Les llums genèriques de Maya es poden crear

a Create > Lights > seleccionar la llum que vulguem.

Llums a Maya

1.5.3. Render

El render és la interpretació que fa el programari dels valors que hem introduït,

tals com llums, textures, materials, càmeres, geometries, etc. Depenent del

motor de càlcul, de render, que utilitzem el resultat serà diferent. Per exemple,

a Maya podem trobar instal·lats motors de render com Maya Software, Maya

Hardware 2.0, Mental Ray o Arnold.

A més, també es configuren els frames que es volen renderitzar, la ruta en què

es deixen els arxius, el format, si tenen canal alfa o no, la qualitat (antialiasing),

etc. Per a accedir a la configuració del render es pot fer clic directament a la

icona d'una claqueta amb un engranatge que apareix a Status Line o seleccio-

nar Rendering en el Menu Set i després en el menú Render > Render Settings.
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2. Modelatge 3D en Autodesk Maya

En el punt anterior hem vist com es creen primitives i hem comprovat que la

distribució dels seus polígons segueix certa simetria, però què succeeix quan

modelem objectes més complexos? En la imatge següent podem percebre que

la distribució de la malla geomètrica de tots dos cranis és diferent.

Topologia 3D

La topologia és una expressió matemàtica; en el nostre cas, ens hi referirem

en termes de distribució de la geometria per l'objecte. Quan modelem hem de

tenir molt en compte quins objectes estem modelant, com seria la seva millor

topologia quant a les seves propietats, als seus possibles moviments, etc. En la

imatge següent podem veure que s'han buscat dues solucions diferents per a

la distribució geomètrica de la part parietal del cap.

Diferents topologies 3D
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En la imatge següent també veiem com l'anàlisi de la fisiologia de l'ull i el seu

contorn ens ajuda a trobar la millor solució per a crear una topologia efectiva

que no trenqui el flow dels polígons confrontants.

Exemple topologia

Font: www.gauldesign.com

Breus consells per a modelatge

• Modela el que puguis i sàpigues visualitzar.

• Divideix els petits problemes i reptes en models simples per a poder aplicar-los al con-
junt final. Modela del general a l'específic. Pots utilitzar diverses peces per a desen-
volupar un model, i has de fer-ho.

• Utilitza referències sempre que puguis.

• Modela amb quads (4 costats per polígon) sempre que sigui possible.

• Evita utilitzar polígons amb forma de triangles o pentàgons.

• Distribueix equitativament els polígons de l'objecte.

• Tingues en compte les parts que s'animen per a afegir seccions allí on sigui necessari.

• Evita automatitzacions (booleans, etc.), ja que produeixen topologies descontrolades
que donen molts problemes.

• Recorda que tots els objectes tenen un petit bisell. És difícil trobar angles rectes en la
naturalesa. Aquest petit detall aportarà gran qualitat a les teves imatges finals.

2.1. Components de les geometries en 3D

Què és una component? Són les diferents parts en què es pot subdividir un

objecte.

Tips

En moltes ocasions, sobretot
quan es treballa per a video-
jocs, és necessari fer una re-
topologia de l'objecte. Com
més polígons conté un objec-
te, més processador cal utilit-
zar per a calcular-ho. Les com-
putadores mouen els objec-
tes d'un videojoc en temps
real, per la qual cosa és im-
prescindible crear objectes
amb el menor nombre de po-
lígons possible sense perdre
gaire qualitat. Per aquest mo-
tiu, es fa una retopologia re-
duint la càrrega poligonal i res-
situant-la, a més d'aplicar ma-
pes de desplaçament i textures
que compensin aquesta pèr-
dua de detall.

http://www.gauldesign.com/
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2.1.1. Selecció de components

Depenent del tipus d'objecte que sigui, polígon, NURBS o corbes, apareixen

diferents components. En seleccionar un objecte i posar-nos damunt seu po-

dem prémer Botó dret > Seleccionar component. Per exemple, en la imatge

següent veiem els components que formen un objecte poligonal.

Selecció de components d'un element poligonal

Tipus�de�selecció

Hi ha diversos tipus de selecció:

• Object mode: en què se selecciona un objecte complet. El color de l'objecte

és verd.

• Component mode: selecció exclusiva d'algun dels components de l'objecte

seleccionat. El color de l'objecte passa a blau.

• Soft Selection mode: es fa una selecció gradual en el contorn del punt selec-

cionat. El color és un degradat que varia amb la configuració que tinguem

en la selecció.

Tipus de selecció

Font: www.autodesk.com

https://www.autodesk.com/
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Per exemple, si se seleccionen components d'un objecte poligonal, el color

canviarà depenent del component que seleccionem.

Tipus de components

Font: www.autodesk.com

2.1.2. Eixos

Un altre aspecte que cal tenir en compte és la posició dels eixos de l'objecte. Per

exemple, si premem dues vegades sobre la icona de translació, entrarem en el

Tool Settings; aquí podem configurar com volem moure l'objecte en Axis Ori-

entation, sobre els eixos de l'escena (world) o sobre els eixos interns de l'objecte

mateix. Depenent de les operacions que busquem fer, ens interessarà una cosa

o una altra.

Tool Settings

Tips

Si editem components, per
exemple en translació, podem
tenir un problema si canviem
els paràmetres (weight, height,
subdivisions) de l'objecte des
de l'Attribute Editor després de
fer aquesta modificació, ja que
farà una aberració en la topo-
logia.

https://www.autodesk.com/
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Eixos

2.1.3. Moure l'eix de coordenades (Pivot Point)

És molt important entendre des de quin punt ens interessa que es modifiqui

el nostre objecte. Es pot modificar aquest punt (Pivot Point) prement la tecla

Insert o la tecla D.

Pivot Point

2.1.4. Center Pivot

Aquesta operació modifica el centre de l'objecte. És molt útil perquè pot ser

que, per exemple, en fusionar dos objectes el centre de l'objecte no se situï on

ens interessa. S'aplica a Modify > Center Pivot.

Tips

Per exemple, si escalem el qua-
drat de la imatge anterior, la
modificació es farà cap al cen-
tre de l'objecte, però pot ser
que ens interessi que l'escalat
es faci des del terra, o sigui,
des de la base del quadrat.



© FUOC • PID_00270544 35 Gràfics 3D

Center Pivot

2.1.5. Reset Transformations / Freeze Transformations

Modificació dels valors de rotació, translació i escalat de l'objecte. N'hi ha de

dos tipus:

• Modify > Freeze Transformations: modifica els valors de les coordenades

a (0,0,0)

• Modify > Reset Transformations: mou els valors a les coordenades (0,0,0)

2.1.6. Select Tool

És l'eina de selecció i pot ser:

• Marquee: fent clic. Seleccionant Camera-based selection solament selecci-

ona els objectes/components vistos per càmera.

• Drag: arrossega la selecció.

• Soft selection: opcions de fer una selecció suavitzada. Ho veurem més àm-

pliament en el Modelling Toolkit.

• Symmetry selection: es poden seleccionar components o objectes des d'un

eix de simetria.

Select Tool
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2.1.7. Emparentar (avançat)

Es poden crear relacions entre objectes utilitzant els mètodes següents:

• Parent: selecció de l'objecte que es vol que sigui fill + selecció del pare +

prémer tecla P. També a través d'Edit > Parent. I per a desfer, Edit > Unpa-

rent.

• Group: també es pot fer un simple grup d'objectes seleccionant-los i pre-

ment ctrl+G. També a través d'Edit > Group. I per a desfer, Edit > Ungroup.

2.2. Modelatge poligonal

2.2.1. Components dels polígons

Els polígons estan composts per faces (cares), edges (eixos) i points (vèrtexs).

2.2.2. Importància de la topologia

En la imatge següent podem veure la importància de la topologia d'un objecte.

En la imatge de la dreta es genera una piràmide trapezoidal; no obstant això,

en la imatge de l'esquerra no hi ha prou polígons per fer correctament la in-

terpolació gradual entre la base de la piràmide i la seva part superior.

Tips

Ja veurem que les eines més
utilitzades en el modelatge po-
ligonal són Extrude, Bevel, Ed-
ge loop.
Amb la tecla G apliquem
l'última acció que hem fet.
És molt important tenir el
nombre de polígons contro-
lat; es pot visualitzar amb Dis-
play > Head up display > Poly
count.
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Diferents tipus de topologia

2.3. Modelatge NURBS

NURBS és l'acrònim de Senar-Uniform Rational B-Spline. Són operacions mate-

màtiques per a crear superfícies entre dos punts o més. És similar al que suc-

ceeix en una imatge vectorial d'Adobe Illustrator.

Corba vectorial

Les components més importants són les següents:

• Isoparm: les corbes isoparamètriques que seccionen l'objecte.

• Control vertex: els vèrtexs de les corbes.
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Isoparm

A més, les operacions més utilitzades són:

• Loft: creació d'una superfície entre dues corbes. Surface > Loft.

• Revolve: revolució al voltant d'un eix. Cal anar amb compte amb l'eix de

coordenades i amb l'inici/finalització de la corba. Surface > Resolve.

• Birail: és un Traçat+Recorregut. Cal anar amb compte amb la unió. Surface

> Birail.

• Extrude: extrusió al llarg d'una corba. Surface > Extrude.

• Trim tool: fa una retallada. Surface > Extrude.

• Extend: estén la superfície. Surface > Extend.

Menu�Corbi�Tools

• CV: fa una ponderació entre vèrtexs.
Create > Curve Tools > CV Curve Tool.

• EP: crea vèrtexs en cada clic.

Create > Curve Tools > EP Curve Tool.

• Bezier: premut genera controladors. Create > Curve Tools > Bezier EP Tool.

• Pencil: genera punts on més densitat de corba hi ha.
Create > Curve Tools > Pencil EP Tool.

• Two point circular arc: crea una corba circular a partir de dos punts.
Create > Curve Tools > Two Point Circular Arc.

• Three point circular arc.: crea una corba circular a partir de tres punts.
Create > Curve Tools > Three Point Circular Arc.

Curve Tools
Tips

Tancar corbes: Curves > Open/
Close
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Les parts de la corba editables poden ser les següents:

2.4. Modelatge amb subdivisió de superfícies

És una tècnica algorítmica per a generar superfícies suaus com una seqüència

de malles poligonals refinades successivament.

Exemple de suavitzat de corba inserint punts

Posseeix més continuïtat que les NURBS. A més, és fàcil d'usar, com els polí-

gons, i té la suavitat i continuïtat de les NURBS. En contra, hi poden haver

problemes amb la importació i exportació.
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2.4.1. Subdivisió conservant posició de vèrtexs anteriors

La subdivisió es pot crear conservant els punts inicials, simplement afegint-ne

de nous en les posicions intermèdies.

Subdivisió

2.4.2. Subdivisió movent posició de vèrtexs anteriors

La subdivisió es pot crear modificant els punts inicials, afegint-ne de nous

en les posicions intermèdies que fan que la posició dels inicials variï a través

d'interpolació entre ambdues.
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Subdivisió

2.4.3. Convertir subdivisions

Les subdivisions es poden generar a partir de la simple primitiva d'un cub.

Com veiem en la imatge, en seleccionar-lo i prémer la tecla 2 veiem el cub

subdividit. En l'exemple s'aprecia com s'apliquen diferents nivells de subdivi-

sió, de més poligonal (nivell 1) a més suau (nivell 3).

2.4.4. Afegir edges per endurir vores

A la imatge es pot veure com en afegir edges a les vores de l'objecte la inter-

polació dels eixos és més dura. Com a modeladors hem de jugar amb aquest

aspecte per obtenir resultats realistes.

Tips

Si volem aplicar aquesta subdi-
visió perquè considerem que
ja és definitiva, podem fer-ho
a Modify > Convert > Smooth
mesh preview to polygon.

Tips

Recordeu que pràcticament
no hi ha vores totalment rec-
tes, tot té un petit bisell. Així
s'aconsegueixen resultats més
realistes.
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2.4.5. Comparació afegint edges

A continuació, es pot analitzar el comportament de les subdivisions depenent

on es generin nous eixos.

2.4.6. Ajustar el nivell de subdivisions

Podem ajustar aquest nivell de subdivisions dins de l'Attribute Editor a pOb-

jectShape1 > Smooth mesh > Subdivision modes > Subdivision levels.
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2.4.7. Comparativa polígons, NURBS i subdivisió

Per acabar, a la imatge es mostra que, tot i que els resultats són visualment

iguals en les tres figures, la metodologia de construcció és totalment diferent.

Tips

Hem de tenir en compte que, com més subdivisió hi hagi, més gran serà el nombre de
polígons i, per tant, més pesarà la nostra escena.

Per a accedir a un accés ràpid d'eines es pot prémer Shift+clic amb el botó dret.
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Accés ràpid a eines

2.4.8. Measure Tools

Segons el treball que s'estigui fent, pot ser important conèixer les mesures exac-

tes de tots els elements. Per a això, podem utilitzar regles a Select Create >

Measure Tools > Distance Tool.

A més, es poden configurar les unitats en les quals volem treballar a Windows

> Settings/Preferences > Preferences > Settings.
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2.4.9. Image Plane

Es pot utilitzar una imatge de referència per a anar generant la geometria en

les vistes ortogràfiques. És una forma molt comuna de modelar, com si tin-

guéssim un paper ceba amb el dibuix. Per a importar la imatge s'accedeix al

Menu View Panel de la vista ortogràfica que ens interessi i View > Image pla-

ne > Import image. S'ha de tenir en compte la importància de configurar la

grandària i la posició de les diferents imatges que s'utilitzin de plantilla, ja que

han d'encaixar perfectament en les diferents vistes.

Alineat d'imatges en les vistes de Front i Side

2.5. Eines per a modelatge. Modeling toolkit. Image plane

És un menú que ens facilita el procés de modelatge perquè conté les eines més

utilitzades.

1)�Pestanya�Object

• Show/Hide

• Freeze/unfreeze: bloqueja objecte.

Tips

Cal configurar la grandària i la
posició de les imatges impor-
tades perquè concordin les vis-
tes.
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• XRay: es pot veure darrere de l'objecte.

• Backface: s'oculten les cares que no es veuen.

• Face triangles: triangulat de la geometria.

2)�Pestanya�Components

Icones amb accés directe a les components de l'element seleccionat.

Components

3)�Selection

• Pick/Marquee = se selecciona prement el botó esquerre del ratolí. Shift+clic

(suma a la selecció).

• Drag = selecció arrossegant.

• Tweak/marquee = es pot seleccionar i moure.

4)�Simmetry

• Seleccionar per component.

• Seleccionar per eix.

• Object: no importa que estigui en els valors 0,0,0 de coordenades.

• World: sempre respecte dels valors 0,0,0 de coordenades.

5)�Selection�constraint

• Angle: restricció respecte a l'angle.

• Border: restricció respecte a la vora.

• Edge loop: restricció respecte a l'eix circumdant.

• Shell: encara que hi hagi dos objectes combinats es poden seleccionar in-

dependentment.

6)�Transform�constraint�(no�modifica�la�topologia)

• Edge: es mou pels eixos circumdants.

• Surface: es mou per la superfície.

7)�Soft�selection

• Soft selection: influeix en els components circumdants.

• Tecla B+Botó central: augmenta/disminueix el radi de la selecció.
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2.5.1. Eines per a Mesh

Són les eines més utilitzades. És un resum i es poden trobar també a Menu >

Mesh, Menu > Edith Mesh i Menu > Mesh Tools.

• Combine: uneix dues geometries.

• Smooth: afegeix polígons suavitzant la geometria.

• Separate: separa els objectes del Combine.

• Boolean: té opcions de sumar les superfícies, restar o deixar la intersecció.

2.5.2. Eines per a Components

• Extrude: extruir faces o edges.

• Bevel: genera un bisell en les vores.

• Bridge: per a crear un pont de geometria nova entre dues parts, ha de ser

el mateix objecte. Un truc és crear un Combine.

• Add Divisions: afegeix divisions al face o edge seleccionat.

2.5.3. Altres eines

• Multi-cut: genera nova topologia.
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• Target Weld: uneix vèrtexs.

• Circularize: crea contorn circular (topologia).

• Collapse: recomanat per a col·lapsar edges.

• Connect: recomanat edges i vertex.

• Detach: separa components.

• Merge: uneix (primer Combine).

Exemple merge

2.6. Deformadors i booleans

2.6.1. Deformadors Nonlinear

• Són eines capaces de deformar la geometria.

• La geometria canvia a color morat quan s'aplica el deformador.

• Ubicació: barra Menu > Deform.

• Al Channel Box > Inputs: editem el deformador. També podem fer-ho en

Attribute Editor.

Una vegada tenim seleccionat Modeling (Menu Set) > Deform > Nonlinear

1)�Bend.�Aquest deformador torça qualsevol dels extrems de la geometria.

Deform > Nonlinear > Bend

Tips

• Treure Smooth: Mesh > Re-
dueix.

• Compte amb Boolean: fa
retopologia i pot generar
fallades.

• Extrude: fer-lo cap a les
normals de l'objecte.

• Keep faces together; si es
deshabilita aquesta opció,
es generen extrusions no-
ves, cadascuna en el seu eix
local.
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Controladors del deformador Bend

Font: www.autodesk.com

2)�Flare.�Provoca una curvatura intermèdia editable.

Deform > Nonlinear > Flare

Controladors del deformador Flare

Font: www.autodesk.com

3)�Sine.�Deforma l'objecte com si fos una corba d'una funció sinus.

Deform > Nonlinear > Sine

https://www.autodesk.com/
https://www.autodesk.com/
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Controladors del deformador Sine

Font: www.autodesk.com

4)�Squash.�S'aplica per a comprimir i estirar un objecte mantenint-ne el volum

inicial.

Deform > Nonlinear > Squash

Controladors del deformador Squash

Font: www.autodesk.com

5)�Twist.�Fa una rotació sobre si mateix.

Deform > Nonlinear > Twist

https://www.autodesk.com/
https://www.autodesk.com/
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Controladors del deformador Twist

Font: www.autodesk.com

6)�Wave.�Aplica unes ones que poden ser animables.

Deform > Nonlinear > Wave

Controladors del deformador Wave

Font: www.autodesk.com

2.6.2. Paint nonlinear deformer weights

Aquesta eina s'utilitza quan volem aplicar el deformador a una zona restringida

de l'objecte. El procés és el següent:

• Seleccionar l'objecte deformat

• Shading > Smooth Shade All o tecla 5

• Deform > (Paint Weights) Nonlinear > ??

• Modify > Paint Attributes Tool

• Seleccionar deformador

• Pintar amb mapa blanc/negre

https://www.autodesk.com/
https://www.autodesk.com/
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Paint Weight

Font: www.autodesk.com

2.6.3. Lattice

Aquest deformador és una espècie de matriu o reixeta que configurem amb els

nivells de subdivisions que ens interessen i s'aplica a l'objecte. Aquests punts de

la reixeta afecten proporcionalment l'objecte al qual s'ha aplicat el deformador.

Deform > Lattice

Lattice

Font: www.autodesk.com

Tips

Molt important! El fet d'aplicar
canvis i deformacions va car-
regant la memòria del nostre
equip; així doncs, quan con-
siderem que l'objecte no es
modificarà, haurem d'esborrar
l'historial a través d'Edit > Dele-
te by type > History.

https://www.autodesk.com/
https://www.autodesk.com/
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2.7. Pràctica I: modelatge poligonal de taula

En aquesta pràctica crearem una taula a partir de la modificació de primitives

poligonals.

En primer lloc, creem un nou projecte des de File > Project Window; prement el

botó New podem anomenar-lo a Current Project; li donarem el nom Grafics3D,

també en definirem la ubicació a Location. Aquesta carpeta de projecte serà la

ubicació on treballarem totes les pràctiques de l'assignatura.

Configuració del projecte en el Project Window

A més, en aquest cas, una vegada creat el projecte, guardarem l'escena com

Taula_01.mb; recordem que és recomanable anar guardant versions incremen-

tals de les escenes; d'aquesta manera, si en algun moment es corromp l'arxiu,

podrem continuar treballant en la versió immediatament anterior.

Comencem per analitzar la figura que es mostra en la fotografia per decidir

en quantes peces la subdividim i a partir de quines primitives modelarem. En

aquest cas, subdividim el modelatge en les parts tauler superior, 4 potes i les

4 connexions entre potes.
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Font: Amazon.es

Recordem que podem trobar un accés ràpid a totes les eines que necessitem a

la finestra Modeling Toolkit. A més, veurem la ubicació de cadascuna d'elles

dins del programari.

Accés directe a Modeling Toolkit

1)�Tauler�superior

Partim d'una primitiva cub a Create > Polygon Primitives > Cube.

Posteriorment, hem de crear la motllura que té a la vora. Per a això, hem de

seleccionar la cares (face) a través del Botó dret (damunt de l'objecte) > Face.

https://www.amazon.es/
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Seleccionar Faces

Una vegada seleccionada la cara (face) superior l'extruïm a Edit Mesh > Extrude.

Veiem que hem d'escalar una mica proporcionalment en els tres eixos (quadrat

interior del controlador) i extruir la cara cap amunt.

Escalat i extrusió de la cara superior

Per a aconseguir suavitzar les cantonades hem de seleccionar els edges a través

de Botó dret (damunt de l'objecte) > Edges. Després seleccionem els edges del

contorn prement dues vegades sobre un d'ells o seleccionant d'un en un amb

la tecla shift premuda (per a acumular la selecció d'edges).

Quan estiguin tots seleccionats fem el bisellat mitjançant Edit Mesh > Bevel i

configurem l'arrodoniment de la vora com vulguem.
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Bevel d'Edges

Fem la mateixa operació amb les quatre cantonades de la taula.

Bevel de cantonades de la taula

2)�Potes

També partim d'una primitiva poligonal cub a través de Create > Polygon Pri-

mitives > Cube. Posteriorment, introduïm els valors de l'altura de la pota de la

taula a la finestra Attribute Editor > polyCube > Height.
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Edició de l'altura de les potes de la taula

Ara veurem una altra manera de fer un bisellat a través de la subdivisió de su-

perfícies (subdivision surface). A l'opció Mesh Tools > Insert Edge Tool podem

afegir un eix nou a totes les cares.

Aplicació d'un Insert Edge Loop

Tal com vam explicar en el punt sobre la subdivisió de superfícies, podem

visualitzar la subdivisió de geometria prement les tecles 2 o 3; en la primera

es pot veure també la geometria de què es parteix en wireframe, i en la segona,

únicament l'objecte subdividit. Ja hem vist que, com més a prop estiguin els

nous eixos creats dels que ja hi havia, més dur serà la vora a l'hora de subdividir.
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No hem d'oblidar que aquesta visualització és un previ i que, una vegada esti-

gui bisellada la vora de les potes com volem, hem de convertir-ho a polígons

perquè es pugui visualitzar en el render, Modify > Convert > Smooth Mesh

Preview to Polygons.

Una vegada tinguem modelada una de les potes, podem duplicar-la i moure-la

a la seva posició corresponent amb Edit > Duplicate o prement la tecla ctrl+D.

3)�Peça�entre�potes

Per a modelar aquesta peça, també partim d'una primitiva cub poligonal. Co-

mencem modificant el gruix a l'Attribute Editor > polyCube 1 > Depth. Poste-

riorment, amb Botó dret damunt de l'objecte > Face seleccionem la cara a par-

tir de la qual volem extruir la peça i fem una extrusió de la mateixa peça amb

Edit Mesh > Extrude.

Extrusió face lateral

Per a fer el modelatge de la peça correctament, podem treballar en la vista

Front (frontal). Aquesta decisió es deu al fet que l'objecte que volem modelar

és simètric des de l'eix vertical, de tal manera que en visualitzar-lo des de la

vista Front ens resultarà més senzill crear la peça, ja que podem seleccionar i

moure els components més visualment.

Per a treballar amb la vista Front hem de tenir en compte les opcions de se-

lecció que ofereix el Selection Tool; si premem dues vegades damunt de l'eina

s'obre una finestra flotant, el Tool Settings.
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Selection Tool

Pot ser que es faci solament una selecció dels components vistos i no dels

que estan ocults a la visió de la càmera i, per tant, a la de l'usuari. Per aquest

motiu, accedim a les opcions del Selection Tool, dins del Common Selection

Options; aquí hem de desactivar l'opció Automatic camera-based selection.

Així aconseguim seleccionar també els components que hi ha en la part oculta

de l'objecte.

Tool Settings de l'eina Select Tool

Hem vist que la peça de connexió redueix una mica en la part central; per a

això podem seleccionar els vèrtexs d'un dels costats i moure'ls una mica en

l'eix Y.
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Selecció de Vertex

Anem a la vista Front i seleccionem els Vertex (Botó dret dins de l'objecte >

Vertex) per moure'ls.

Modificació de Vertex

Posteriorment, seleccionem Face de la cara de l'objecte que volem seguir mo-

delant i extruïm. Quan arribem a la part de la peça que volem eixamplar, se-

leccionem els Vertex i els movem en l'eix Y.

Modificació de Vertex

Una vegada tinguem modelada una peça podem duplicar-la i moure-la a la

seva posició corresponent. Edit > Duplicate o prement la tecla ctrl+D.
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Quan tinguem totes les peces duplicades i col·locades al seu lloc, creem un

grup amb totes elles perquè sigui més fàcil seleccionar i moure l'objecte en

bloc. El grup es pot crear seleccionant totes les peces i prement Edit > Group

o ctrl+G.

Taula final modelada i agrupada

2.8. Pràctica II: modelatge d'un pot de refresc utilitzant NURBS

Gairebé sempre que modelem objectes ho fem a partir d'imatges de referència.

En aquest cas, podem fer una fotografia d'un pot de refresc per a utilitzar-lo

com a plantilla de referència. Creem una nova escena i la guardem en el nostre

projecte amb el nom de Llauna_01.mb.

Fotografia de llauna de refresc

Per a importar la imatge de referència anem a la vista Front; dins del View

Panel seleccionem View > Image Plane > Import Image.
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Importar imatges a l'Image Plane

Quan tinguem la imatge importada, veurem que es posiciona de fons perquè

puguem modelar l'objecte a partir seu.

Imatge de referència importada

Si us hi fixeu, una llauna és simètrica, per la qual cosa utilitzarem una tècnica

basada en NURBS. Per a això, crearem solament el perfil de la llauna amb una

corba i, a partir d'aquest perfil, farem una revolució de la corba que generarà

la geometria de la llauna.

Creem el perfil de la llauna amb l'eina de creació de corbes Bezier a Create >

Curve Tools > Bezier Curve Tool.
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Creació de corbes

Perquè el primer punt de la corba s'ajusti directament al grid, activem l'Snap

grid. Després, el desseleccionamos per poder modelar de manera lliure ajus-

tant-nos a la imatge de fons que hem importat a Image Plane.

Activar Snap Grid

És molt important que l'inici i el final de la corba acabin al centre vertical de

coordenades, eix Y, ja que el modelatge rotarà a partir d'aquest eix. També és

important començar l'inici de la corba des de la part de baix cap amunt. Una

vegada hàgim acabat la corba, premem la tecla Enter per a acabar l'operació

de creació.
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Resultat de la corba

Si hem comès algun error traçant la corba, podem editar-la en acabar situ-

ant-nos damunt seu i prement botó dret > Control Vertex. Apareixeran tots

els punts i els controladors de la corba per poder ajustar-la.

Editar corbes amb Control Vertex

Edició de punts de la corba

Una vegada depurada la corba, fem la revolució que generi la geometria a

través de Surface > Revolve.
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Resultat de la revolució de la corba
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3. Generació de materials i texturitzat de models 3D

3.1. Propietats de les superfícies

Les superfícies dels objectes tenen una sèrie de característiques conegudes i

unes altres de no tant conegudes pel seu nom però sí pel seu efecte; en aquest

apartat analitzarem les qüestions més rellevants que hem de tenir en compte.

• Propietats�bàsiques

– Color: color que veiem dels objectes.

– Especularitat: lluentor que tenen els metalls, els vidres, els cristalls i

qualsevol superfície polida.

– Transparència: capacitat que tenen els objectes de deixar passar la

llum.

– Reflex: capacitat de reflectir el seu entorn.

• Propietats�en�materials�PBR� (physically�based�rendering):�PBR és una

tècnica molt utilitzada en videojocs mitjançant la qual s'intenten crear

materials que siguin realistes sense que consumeixin gaires recursos de la

màquina perquè estan pensats per moure'ls en temps real. A continuació

expliquem alguns conceptes que ajudaran a entendre el PBR.

1)�Energia�de�conservació.�Un objecte no pot reflectir més llum de la que

rep. La llum que incideix ha de ser més gran o igual que la suma de les seves

components difusa i especular. En altres paraules, si el material té molta com-

ponent difusa, serà a costa de la component especular, i viceversa. En la imatge

següent es pot apreciar que, com més llum reflecteix (component especular),

menys es veu el color base del material (component difusa).

Energia de conservació

Font: www.marmoset.co

2)�Difusió�i�reflex.�Quan la llum incideix sobre un material es divideix, fona-

mentalment, en dues components: una component difusa i una component

especular (o reflexiva).

https://marmoset.co/
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Font: www.marmoset.co

La component difusa és aquella que s'introdueix en la superfície i finalment

surt reflectida fora del material. Aquesta component de la llum és la que pro-

porcionar el que nosaltres coneixem com a color.

Component difusa

Font: www.unrealengine.com

3)� Especularitat.� La component especular és aquella que no penetra en

l'objecte, és completament reflectida per la superfície. Aquesta component és

la que coneixem com a reflex.

Component especular

Font: www.unrealengine.com

https://marmoset.co/
https://www.unrealengine.com/en-US/
https://www.unrealengine.com/en-US/
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4)�Albedo.�Aquest potser és el concepte més abstracte; defineix el color de

la llum difusa, és el color que emet un objecte sense tenir en compte la

il·luminació.

Albedo

Font: www.marmoset.co

5)�Microsuperfície.�Defineix el nivell de rugositat de la superfície. Com menys

rugós sigui, més puntual serà el reflex que proporcionarà.

Microsuperfície

Font: www.marmoset.co

6)�Transparència.�El material deixa passar la llum. Aquesta propietat presenta

diversos graus i propietats. En vidres purs gairebé no hi ha dispersió de la llum.

https://marmoset.co/
https://marmoset.co/
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Transparència

7)� Translucidesa.�És una projecció d'ombra (penombra) deguda al fet que

l'objecte bloqueja parcialment la llum. Per exemple, la trobem en vidres esme-

rilats i alguns plàstics. Presenta alta difusió i dispersió de la llum.

Translucidesa

8)�Reflexió.�El reflex de l'entorn; veiem que l'especular se suma a aquest pa-

ràmetre.

Reflexió

Font: https://www.arnoldrenderer.com/

https://www.arnoldrenderer.com/
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9)�Fresnel.�La reflectivitat es presenta en un angle determinat. La reflexió de

la llum depèn de l'angle de visió. A les vores (l'angle de visió és de 90º) es

reflecteix el 100% de la llum (per tant, hi ha 0% de component difusa), mentre

que de cara ocorre el contrari. En la imatge següent de l'esfera es pot veure

exemplificat.

IOR

Font: www.marmoset.co

10)�Índex�de�refracció�(IOR).�Determina la rapidesa en què viatja la llum a

través d'un material en relació amb la velocitat de la llum en el buit.

IOR

Bases de dades amb valors
IOR reals

https://www.filmetrics.com/
refractive-index-database
https://pixelandpoly.com/
ior.html

https://marmoset.co/
https://www.filmetrics.com/refractive-index-database
https://www.filmetrics.com/refractive-index-database
https://pixelandpoly.com/ior.html
https://pixelandpoly.com/ior.html
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11)�Subsurface�scattering�(SSS).�SSS depèn de la posició de la font de llum i no

de l'angle de la càmera. No obstant això, com vèiem en l'efecte Fresnel, ocorre

el contrari, afecta la incidència de la llum en relació amb l'angle de visió que

tenim sobre l'objecte.

12)�Dielèctrics.�Reflecteixen la llum del color que emeten. Per exemple, un

plàstic al qual incideix llum blanca reflecteix llum d'aquest color.

13)�Metalls.�En els conductors la llum que es reflecteix té un color diferent

al de la llum incident.
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3.2. Creació i configuració de materials

3.2.1. Materials estàndard

• Lambert: no inclou efectes de lluentor.

• Blinn: sol ser utilitzat per a generar superfícies completament metàl·liques.

• Phong: representa superfícies brillants i polides, com ara marbres o plàs-

tics.

• PhongE: similar a Phong, però amb reflexos especulars més suaus.

• Anisotròpic: pot generar reflexos especulars en direccions no iguals a la

superfície de l'objecte.

3.2.2. Hypershade

És un àrea de treball que funciona a través de la connexió de nodes.

Es pot obrir a Windows > Rendering Editors > Hypershade.

També té una icona amb un accés directe en el menú (vegeu la imatge).
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1)�Connexions

• Input connections: mostra les connexions d'entrada que afecten un ma-

terial.

• Input and output connections: mostra les connexions d'entrada i de sor-

tida que es troben en el material.

• Output connections: mostra les connexions de sortida del material selec-

cionat.

• Work area: mostra els nodes d'un material per a poder editar-los.

• Property editor: modifica els paràmetres i les característiques del material.

• Material viewer: visor previ dels canvis que es van fent.

2)�Eines

• Clear graph: deixa en blanc l'àrea de treball.

• Add selected nodes to graph: permet crear un contenidor per a poder or-

ganitzar.

• Remove selected nodes from graph: elimina els contenidors seleccionats.

• Rearrange graph: organitza visualment els nodes.

• Graph materials on selected objects: desplega totes les connexions de

l'objecte seleccionat.

• Hide attributes: oculta tots els atributs del material.

• Show connected attributes: mostra els atributs bàsics del material.

• Show primary attributes: mostra tots els atributs del material.

• Show attributes: mostra tots els atributs, a més de personalitzar tots els

nodes possibles.

3)�Aplicar�material

• Seleccionem l'objecte.

• Mantenim premut el botó dret.

• Ens apareix una finestra flotant, seleccionem Add New Material.

Tips

Si ja hem creat un material a
l'Hypershade, podem seleccio-
nar Add Existing Material.
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3.2.3. Atributs del Property Editor

Dins de l'Attribute Editor tenim diverses pestanyes a la part superior; si anem

a l'última, serà la del material en qüestió. També podem prémer el botó dret

damunt de l'objecte seleccionat i prémer Material Attributes.

Les propietats de cada material seran numèriques o amb un slider controlador.

A la dreta apareix un quadrat negre i blanc; si premem accedim als nodes.
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Create Render Node

La finestra Nodes està composta per una gran quantitat d'elements, des de

materials fins a efectes, textures procedurals, etc. Quan hem fet la connexió

d'un node, apareix la icona d'un quadrat amb un triangle negre.

Paràmetre connectat

Si volem desconnectar aquest node haurem de prémer amb el botó dret da-

munt de les lletres del paràmetre que volem desconnectar i seleccionar Break

Connection.

Break Connection
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3.3. Materials específics a Arnold

3.3.1. Presets Arnold

El material per defecte d'Arnold és aiStandardSurface; si premem el botó Pre-

sets, accedim a la galeria de materials predefinits d'Arnold.

3.3.2. AI Standard Surface

1) Base color: color de material pròpiament dit.

Base color

Font: www.arnoldrenderer.com

2) Diffuse Roughness: rugositat de la microsuperficie.

https://www.arnoldrenderer.com/
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Diffuse Roughness

Font: www.arnoldrenderer.com

3) Specular: especularitat del material.

Specular

Font: www.arnoldrenderer.com

4) Specular color: color de l'especular. Hem vist que els metalls podien tenir

especulars de colors diferents als de la font lluminosa.

Specular Color

Font: www.arnoldrenderer.com

5) Specular Roughness: rugositat de l'especular.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Specular Roughness

Font: www.arnoldrenderer.com

6) IOR: índex de refracció.

IOR

Font: www.arnoldrenderer.com

7) IOR Specular transmission

IOR

Font: www.arnoldrenderer.com

8) Specular Anisotropy: reflecteix i transmet llum en certes direccions.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/


© FUOC • PID_00270544 79 Gràfics 3D

Specular Anisotropy

Font: www.arnoldrenderer.com

9) Transmission: transmissió de la llum.

Transmission

Font: www.arnoldrenderer.com

10) Transmission depth: profunditat de la llum en la transmissió.

Transmission depth

Font: www.arnoldrenderer.com

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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11) Transmission Scatter: depèn de la densitat del material.

Transmission Scatter

Font: www.arnoldrenderer.com

3.4. Texturitzat amb imatges bitmap

1) Seleccionar el node File.

2) A Image Name, prémer la carpeta i seleccionar la imatge.

https://www.arnoldrenderer.com/
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3) A les pestanyes de dalt en trobem una d'anomenada plau2dTexture. Hi po-

dem repetir la textura les vegades que vulguem en cas que sigui una textura

que ho permeti. Sol utilitzar-se per a sòls, parets, etc.

4) Si volem que aquesta textura tingui una projecció especial, podem aplicar-la

a UV > Planar (per a plànols), UV > Cylindrical (per a ampolles, llaunes, etc.),

UV > Spherical (per a pilotes, envolupants, etc.).

3.5. Textures procedurals

Són textures generades mitjançant algorismes matemàtics. Les genera el ma-

teix Maya; no són arxius externs, per la qual cosa no requereixen consumir

gaire memòria. A més, en ser matemàtiques són infinites, les podem repetir

les vegades que vulguem.

Les podem trobar en la mateixa finestra de nodes i les podem aplicar a gaire-

bé qualsevol paràmetre. En la imatge en podem veure diverses, com Bulge,

Checker, Cloth, Fractal, Grid, Mountain, etc.
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3.6. Generació i edició de textures

1)�Programes�d'edició�d'imatge.�Podem utilitzar qualsevol programa d'edició

d'imatge per a crear les nostres pròpies textures, ja siguin logotips o imatges

d'alguna superfície que volem projectar sobre un objecte com ara fusta, terra,

etc.

2)�Multiplicats.�Per a aportar més realisme, es poden utilitzar diverses textu-

res premultiplicades entre si per a crear certa brutícia i que no semblin tan

sintètiques.



© FUOC • PID_00270544 83 Gràfics 3D

3)�Reloaded.�Quan fem una modificació en les textures, hi ha vegades en què

cal prémer el botó de Reloaded perquè es refresqui en l'objecte.

3.7. Projecció i configuració de mapes UV

3.7.1. Coordenades UV

Són coordenades paramètriques normalitzades en dues dimensions entre els

valors 0 i 1. El seu gran benefici és que es pot modificar la resolució de la

textura sense canviar la projecció. Per optimitzar el rendiment de l'equip és

recomanable que les textures siguin quadrades (128x128, 256x256, 512x512,

1024x1024, 2048x2048, etc.).

Per a entendre en què consisteix, vegem-ne un parell d'exemples:

Com veieu, un cub realment serien sis quadrats projectats en forma de creu.

Un altre exemple més elaborat, però molt didàctic, és el del paper que emboli-

ca una figura de xocolata. Com es pot observar, una superfície en dues dimen-

sions ha estat projectada en un objecte en tres dimensions.
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Textura UV desplegada
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Textura UV projectada

3.7.2. UV Editor

L'UV Editor és l'eina en què es prepara la projecció de la textura. S'hi pot accedir

a través de Windows > Modeling Editors > UV Editors. També en el menú UV.

Menú UV
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UV Editor

En l'UV Editor podem crear projeccions:

Projeccions UV Editor

Una vegada tenim una imatge aplicada, per exemple en color, podem veure

la projecció en l'UV Editor; podem seleccionar faces, vertex, UV, i moure'ls per

veure com es modifiquen en l'objecte 3D. A més, podem desplegar geometri-

es en l'UV Editor, i exportar-les a un altre programari d'edició d'imatge per a

pintar sabent ja quina serà la projecció correcta.

Desplegar una geometria



© FUOC • PID_00270544 87 Gràfics 3D

Tallar faces

Moviment de vèrtexs en UV Editor

Save Snapshot

3.8. Bump map, displacement map i normal map

Generar geometries rugoses com la pell humana seria impossible en un pro-

grama 3D, ja que el consum de processador deixaria col·lapsat l'equip. Per a

solucionar la simulació d'aquest tipus de superfícies rugoses s'utilitzen textu-

res bump map.

Un height map és una textura blanca i negra; com més blanc sigui el color del

píxel, més alt apareixerà.
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Un normal map és una textura RGB, on cada píxel representa la diferència en

direcció de llum de la superfície. Aquestes textures tendeixen a tenir un color

morat-blau, a causa de la manera en què el vector és emmagatzemat en valors

RGB.

Bump map aplicat a textures

3.8.1. Normal

És un vector perpendicular a un polígon (o a un vèrtex) que serveix per a

indicar-nos l'orientació de la cara. En la imatge de dalt es compara com seria

la geometria, i a baix, com funciona el normal map.

Si volem veure com són les normals dels nostres objectes, podem fer-ho a

Display > Polygons > Face Normals.
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Les opcions que ens proporcionen les normals són les següents:

• Average: mitjana.

• Conform: unifica la direcció.

• Set to face: vertex to face direcció.

• Set Vertex Normal: posició vertex normals.

• Harden/Soften edge: endureix la normal i l'aparença.

• Lock/Unlock normals: bloqueja normals.

Normals de la geometria

No obstant això, encara que tinguem una geometria molt poligonal, podem

aplicar-hi un mapa de normal; podem fer-ho en qualsevol material estàndard

de Maya a l'apartat Bump Mapping. Si ho volem aplicar a un material Arnold,

hem d'anar a la secció del material anomenada Geometry > Bump Mapping.

En la imatge veiem, a l'esquerra, la textura del normal map i, a la dreta, aplicat

al cub; el resultat és un cub que té una aparença de pedra gairebé real.

3.9. Pràctica III: materials amb textures bitmap, projeccions i

repeticions

En aquesta pràctica crearem un material amb textura de fusta per a la taula

que hem modelat en la pràctica I.
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En primer lloc, obrim l'escena Taula_01.mb i seleccionem la taula. Haurem de

crear o fotografiar una textura de fusta; la millor opció és buscar imatges tile

en una galeria. Això significa que la imatge es pot repetir sense que es percebi

un salt entre els entroncaments d'una imatge amb una altra. Les peces tenen

formes molt diferents, per la qual cosa haurem d'utilitzar materials diferents

per a cadascuna de les peces, ja que en les quadrades la repetició de la imatge

serà uniforme, i en les allargades es distribuiran més repeticions en un dels

eixos.

Prement el botó dret del ratolí damunt de la taula superior s'obre una finestra

flotant d'opcions; seleccionem Assign New Material per a crear un nou mate-

rial per a la taula. L'anomenem Mat_taulerSuperior.

Aplicar material

En el paràmetre Color connectem el node File i premem la carpeta per a afegir

la textura de fusta que volem.

Nodes
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Per no consumir gaire memòria, les textures solen ser petites, amb possibilitat

de ser repetides com si fossin un patró, però sense que es notin les costures.

Per a editar aquestes repeticions, anem a la textura en el node File i entrem a

la pestanya superior plau2dTexture.

Textura de fusta

Pestanya plau2dTexture

Com veiem en la imatge anterior, s'ha repetit trenta vegades a U i dues vegades

a V, a causa que, si no, es veurien moltes repeticions al cantell del tauler.
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Projecció de la textura sobre el tauler

Per a les potes generem un altre material de la mateixa manera i l'anomenem

Mat_potes. Aquesta vegada les repeticions seran 4 i 30, respectivament.

Projecció de la textura sobre potes

Com hem vist, podem editar paràmetres d'aquesta repetició, com ara la rota-

ció, el soroll, etc. Tot això ajuda a trencar el patró visual, ja que l'ull humà és

capaç de detectar-lo ràpidament i l'interpreta com a irreal.

Ara obrim l'Hypershade per veure com estan connectats els nodes que hem

creat. Seleccionant l'objecte i prement botó dret dins del Work Area > Graph

Materials on Viewport Selection, podem carregar tots els seus nodes en el visor

perquè ens fem una idea de com es connecten i en quin ordre.
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Finestra Hypershade

3.10. Pràctica IV: materials metàl·lics. Aplicació de textures

bitmap

En aquesta pràctica crearem un material amb textura metàl·lica en el qual es

projectarà una textura amb canal alfa.

En primer lloc, obrim l'escena Llauna_01.mb i seleccionem la llauna de refresc.

Prement el botó dret del ratolí damunt de l'objecte s'obre una finestra flotant

d'opcions, hi seleccionem Assign New Material per a crear un nou material per

a la llauna de refresc.

Aplicar un material nou
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Al seu torn, se'ns obre una altra finestra flotant amb tots els materials que

podem aplicar a l'objecte. Volem aplicar-hi un material metàl·lic; així doncs,

seleccionem Arnold > Shader > aiStardardSurface.

Aplicar el material estàndard d'Arnold

Ara utilitzem una configuració per defecte; així doncs, premem Presets i se'ns

desplega una llista d'opcions de materials. Seleccionem Chrome.

Presets de materials Arnold

Si analitzem l'Attribute Editor podem veure que tenim totes les opcions de

configuració del material. Canviem el color per veure com l'afecta.
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Després apliquem una textura a la llauna. Per a això, hem d'aplicar al color un

node de capes anomenat Layered Texture.

Layered Texture

Prement el buit de Layered Texture Attributes creem noves capes. En crearem

una amb un color sòlid i una altra a la qual connectarem una textura; aquesta

última es posarà en el Blend Mode en Add.
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Creació de capes

Per a aplicar una textura en bitmap premem el quadrat blanc i negre del parà-

metre color i hi connectem el node File. Si premem la carpeta podrem impor-

tar la textura que vulguem; si vam crear un text en format PNG amb canal

alfa, podrem superposar-lo al color de fons de la llauna.

Importar imatge
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Ara hem de projectar la textura del logotip que hem importat. Cal tenir en

compte que, per a fer una edició de la projecció, hem de convertir l'objecte

NURBS a Polygon a Modify > Convert > NURBS to Polygons. Després obrim

la finestra d'edició dels paràmetres UV dels objectes a Windows > Modelling

Editors > UV Editor. La llauna té forma de cilindre; per tant, haurem de fer una

projecció amb aquesta forma en la finestra UV Editor, Create > Cylindrical.

Projecció de textura

Per a aplicar el canal alfa de la textura hem d'anar a l'Hypershade. Allí con-

nectarem l'Out Alpha de la textura (logo.png) al canal alfa del node layered-

Texture2.

Nodes de l'Hypershade
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El resultat serà una llauna de color amb el logotip que hàgim creat.

Textura aplicada
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4. Configuració de sistemes d'il·luminació 3D

4.1. Tipus de llums en Autodesk Maya

Cada motor de render ha de tenir les seves pròpies llums, ja que optimitzen el

procés de càlcul i s'obtenen resultats millors. En aquest cas, primer repassarem

les llums estàndard que té Maya per defecte, i després analitzarem les llums

que pertanyen al motor de render Arnold.

4.1.1. Llums estàndard

1) Area Light: són llums rectangulars especials per a simular reflexos rectan-

gulars, com les caixes de llum utilitzades en fotografia. Es recomanen per a

imatges fixes, però no per a animacions.

Area Light

Font: www.autodesk.com

2) Directional Light: s'utilitzen per a simular fonts de llum puntuals que estan

llunyanes, com el Sol, on els rajos de llum són paral·lels entre si.

https://www.autodesk.com/
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Directional Light

Font: www.autodesk.com

3) Spot Light: es projecta un con de llum uniforme i direccional. L'obertura

d'aquest con de llum es pot regular, així com la duresa o suavitat del contorn.

Spot Light

Font: www.autodesk.com

4) Point Light: la llum s'emet uniformement de manera omnidireccional. És

similar a la llum que emet una bombeta.

Point Light

Font: www.autodesk.com

https://www.autodesk.com/
https://www.autodesk.com/
https://www.autodesk.com/
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5) Ambient Light: aquesta llum és ambivalent; d'una banda, es transmet de

manera uniforme en totes les direccions des de la font i, d'una altra, també

des de les superfícies.

Ambient Light

Font: www.autodesk.com

6) Volume Light: il·lumina els elements que hi ha dins la llum. Sol utilitzar-se

per a atenuar ombres.

Volume Light

Font: www.autodesk.com

4.2. Classificació i configuració de llums a Arnold

Les llums d'Arnold són especials per a optimitzar el càlcul de render que fa

Arnold, tot i que es pot utilitzar un altre tipus de llums. Les llums d'Arnold es

poden localitzar a Rendering (Menu Set) > Arnold > Lights.

https://www.autodesk.com/
https://www.autodesk.com/
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Llums d'Arnold

A continuació, es mostra gràficament com afecta cadascun dels tipus de llums

als objectes, a més de com són les icones gràficament en les vistes.

Forma i efecte de les llums Arnold

Font: www.arnoldrenderer.com

Ara descriurem i analitzarem com són i com afecten cadascun del tipus de

llums d'Arnold.

1)Area�Light: és una font de llum que imita la caixa de llum. Se'n pot canviar

la forma, a Light Shape, pot ser rectangular, circular o cilíndrica.

Forma de la llum

Font: www.arnoldrenderer.com

Tips

L'Ambiental Light i Volume
Light de les llums clàssiques de
Maya no són compatibles amb
Arnold render.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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2)Skydome�Light: simula la llum d'exteriors, la llum del cel. És una llum difusa

i suau que proporciona ombres també suaus.

Efecte Skydome Light

Font: www.arnoldrenderer.com

3)Mesh�Light: La mateixa malla es converteix en llum. Pot passar que sigui

necessari pujar les subdivisions per a obtenir més detall en els reflexos. Per a

aplicar-la, primer cal seleccionar la geometria i després seleccionar la llum a

Rendering (Menu Set) > Arnold > Lights > Mesh Light.

Mesh Light

Font: www.arnoldrenderer.com

4)Photometric�Light: són llums que utilitzen patrons establerts com els perfils

IES, que proporcionen informació d'intensitat i difusió. En la imatge següent

es poden veure com funcionen diferents perfils IES.

Tips

Cal tenir en compte que no
funciona amb NURBS.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Efectes d'AES Lights

Font: www.arnoldrenderer.com

5)Light�Portal: aquestes llums se situen en les finestres o en els buits per on

entra la llum. Aquest tipus de llum s'aplica per a reduir el soroll que hi pugui

haver en la imatge.

Light Portal

Font: www.arnoldrenderer.com

4.2.1. Exposure

L'exposició és un valor relacionat amb el nombre de passos de la fotografia (f-

stop). Si puja l'exposició en 1, la quantitat de llum és el doble; per tant, no

té un creixement lineal, sinó exponencial. D'altra banda, cal tenir en compte

que la intensitat de la lluentor es multiplica pel color.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Efecte d'Exposure

Font: www.arnoldrenderer.com

4.2.2. Samples

Els samples controlen la qualitat de la imatge i el render final. En augmentar els

samples es redueix el nivell de soroll en la imatge, especialment en les ombres.

Llum a Arnold

Font: www.arnoldrenderer.com

A continuació, es mostren dos exemples: en el de la dreta hi ha un valor de

Sample d'1 i en el de l'esquerra, de 4. Els materials que estan a la part inferior

tenen aplicada una rugositat creixent en l'especular del material; s'aprecia que,

com més quantitat de Samples, menys soroll.

Exemple amb diferents Samples

Font: www.arnoldrenderer.com

Tips

La fórmula per a calcular és Ex-
posure: color * intensity * 2ex-

posure

Per exemple, intensitat = 1, ex-
posure = 2 és el mateix que in-
tensitat = 4, exposure = 0, ja
que 1*1*22 = 4 i 1*4*20 = 4.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/


© FUOC • PID_00270544 106 Gràfics 3D

4.2.3. Temperatura de color

Determina la dominant de color de la llum i es mesura en graus Kelvin. Segons

la CIE (Commission Internationale de l'Eclairage), els 6.500 K determinen el

blanc neutre; per sota d'aquest valor la llum té una dominant ataronjada, i

per damunt, blavosa.

Temperatura de color

Font: www.arnoldrenderer.com

4.2.4. Decay type

Estableix el decaïment de la llum en relació amb l'espai; concretament, la llei

de la inversa del quadrat. Aquesta llei s'aplica en àmbits com la propagació de

la llum i del so, i fa referència al fet que la intensitat disminueix de manera in-

versament proporcional al quadrat de la distància des de la font fins al subjec-

te. Les llums a Arnold ofereixen l'oportunitat de configurar l'aplicació d'aquest

decaïment, o bé de desactivar-lo i que la propagació de la llum sigui constant.

Decaïment de la llum

Font: www.arnoldrenderer.com

4.2.5. Cast Shadows

Les llums d'Arnold, igual que les llums clàssiques de Maya, permeten aplicar

projectar ombres des de les fonts de llum.

Tips

S'ha de tenir en compte que la
temperatura de color pot vari-
ar el color de tots els elements
de l'escena, així com dels refle-
xos, especulars, etc.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Ombres

Font: www.arnoldrenderer.com

4.2.6. Shadow density

La densitat d'aquestes ombres pot ser configurada, i 1 és el valor per defecte

amb l'ombra totalment opaca.

Densitat de l'ombra

Font: www.arnoldrenderer.com

Tips

D'altra banda, hem de tenir en compte que no podem visualitzar en el render les imatges
il·luminades amb llums Arnold si no està carregat correctament. Per a això, hem d'anar
a Window > Settings/Preferences > Plug-in Manager i confirmar que estan seleccionats
Loaded i Auto loac.

4.3. Tipus d'ombres

• Cast Shadows: són ombres llançades pels objectes en els quals incideix la

llum.

• Shadow Color: defineix el color de l'ombra.

• Shadow Density: correspon a la densitat de l'ombra.

• Volume Samples: és la qualitat de l'ombra; com més gran sigui, més qualitat,

però més temps triga a processar.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/


© FUOC • PID_00270544 108 Gràfics 3D

4.4. Configuració de sets d'il·luminació en interiors i estudi a

Arnold

Quan il·luminem personatges, és necessari tenir almenys tres punts de llum:

• 1 Llum principal.

• 1 Llum d'ompliment, que pot estar a uns 90 graus de la llum principal.

• 1 Llum de contra, que es posa darrere del subjecte.

També és habitual jugar amb diferents temperatures de color per tal de pro-

porcionar més contrast al personatge i fer-lo ressaltar del fons.

Quan són escenes d'interior que tenen finestres per les quals entra llum, cal

recordar situar les mateixes Portal Light per tal d'eliminar el soroll que produ-

eix l'Skydome Light.

Tips

Dues eines molt útils per a visualitzar i configurar totes les llums de l'escena són el Light
Manager d'Arnold, al qual s'accedeix a través de Rendering (Menu Set) > Arnold > Utilities
> Light Manager, i el Light Editor de totes les llums, no importa del motor que siguin, de
Maya a Windows > Rendering Editors > Light Editor.

Light Manager

Light Editor

4.5. Configuració de sets d'il·luminació en exteriors a Arnold

La llum més habitual és Skydome Light, tot i que cal utilitzar llums puntuals

per a focalitzar l'atenció de l'espectador, ja que la llum de l'Skydome Light és

molt difusa i no genera els contrastos necessaris per a enriquir l'escena visu-

alment. Les llums que estan llunyanes tendeixen a aplanar, mentre que les

properes aporten contrast.

Tips

Molt sovint, quan treballem en exteriors, també és necessari que algunes llums solament
afectin certs objectes, ja que si no es fa així es poden sobreexposar. Per a això, és necessari
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utilitzar el Relationship Editor, que es pot trobar a Windows > Relationship Editors >
Light Linking > Light-Centric. En aquesta finestra apareixen les llums a l'esquerra i els
objectes a la dreta; si seleccionem una llum i desseleccionem algun objecte a la dreta,
aquest objecte no es quedarà afectat per aquesta llum.

Relationship Editor

4.6. Configuració avançada de sets d'il·luminació. Efectes

d'il·luminació

4.6.1. Ombres volumètriques

Arnold Render settings > Arnold Renderer > Environment > Atmosphere field.

En aquestes opcions del Render Settings es poden crear llums volumètriques

i boira (fog).
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Atmosphere

4.6.2. Gobo

És un filtre d'il·luminació molt utilitzat en cinema i teatre. Consisteix a

col·locar una textura davant de la font de llum per a projectar un joc de llums

i ombres.

Gobo

Font: www.arnoldrenderer.com

El procés és el següent:

• Crear una Spot Light.

• Accedir a spotLightShape > Arnold > Light Filters …. > Add > Gobo.

• Filter Mode > Mix.

• Density a 1.

• Slide Map connectat a la textura desitjada.

• Rotar i escalar com vulguem.

https://www.arnoldrenderer.com/
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4.7. Pràctica V: il·luminació d'escena amb diversos objectes

Per a fer aquesta pràctica carreguem l'escena de la Taula_01.mb i importem la

de la Llauna.mb a File > Import.

Importar arxius .mb

Pot ser que hi hagi una diferència d'escala entre els objectes de les escenes; si

és el nostre cas, triem l'escala que ens interessi i adaptem la grandària de tots

els objectes. L'objectiu és situar la llauna de refresc damunt de la taula.

Diferents escales entre objectes

Després creem les llums de l'escena; les podem trobar a Arnold > Lights.
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Llums d'Arnold

En primer lloc, posem un Skydome Light d'ompliment i en baixem el valor

d'Intensity. Posteriorment, creem dos Area Lights, una a la part frontal i una

altra darrere. A més, creem una càmera nova per a ajustar l'enquadrament i

així poder moure'ns per treballar la càmera per defecte que té el projecte, Persp.

Elements de l'escena

Per a visualitzar un previ de la imatge i veure com estan actuant les llums,

premem la icona de la claqueta.

Icona claqueta

hem d'anar ajustant el paràmetre Intensity de les llums i la seva posició dins

de l'escena fins a aconseguir el resultat que volem.
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Imatge final 
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5. Tècniques de render 3D

El render és el càlcul final que fa el processador aplicant la configuració de

llums, materials, textures, geometries, sampling, etc. El temps requerit per a

complir aquests processosde render poden variar depenent de multitud de fac-

tors; per aquest motiu, és necessari optimitzar les escenes i utilitzar equips que

compleixin els requisits del programari.

Els motors de render aporten optimització i qualitat a la imatge final; hi ha

motors de render amb els quals no s'obtenen imatges amb gaire qualitat, sinó

que el que es busca són qualitats que, malgrat ser més sintètiques, siguin capa-

ces de fer els càlculs de manera ràpida. No obstant això, hi ha altres motors

de render que el que busquen és aconseguir imatges hiperrealistes sacrificant

els temps de processament.

5.1. Tipus de render a Autodesk Maya

1)�Arnold. És un motor de render creat per la companyia Solid Angle i imple-

mentat a Autodesk Maya. Arnold és un motor fotorrealista molt fàcil d'usar que

consumeix pocs recursos de l'equip; realment aconsegueix resultats esplèndids

en temps curts de processament.

Arnold render

Font: www.solidangle.com

2)�Mental�Ray. Va ser el motor de render que tenia Maya per a crear les imat-

ges de més qualitat; fins l'any 2016 va estar implementat en el programari.

En versions posteriors va ser substituït per Arnold, ja que aquest últim ofereix

millors resultats utilitzant temps de càlcul menors, a més de ser molt més sen-

zill de configurar.

http://www.solidangle.com/
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3)�Maya�Software. És un dels motors de render implementats a Maya. Tot i

que no és capaç de renderitzar amb la qualitat d'Arnold, és molt utilitzat per

a renderitzar sistemes de partícules i Paint Effect.

Paint Effect Maya

4)�Maya�Hardware�2.0. És un altre motor de render integrat a Maya que té

diverses limitacions de qualitat, a més de no permetre el renderitzat parcial de

regions de l'escena, de capes o el canal de profunditat (z-depth).

5)�VRay. És un motor de render d'alta qualitat de la companyia Chaos Group.

Ofereix la possibilitat de crear imatges hiperrealistes, tot i que és necessari

dedicar força temps a la configuració de càmeres i llums, ja que posseeix una

gran quantitat de paràmetres configurables.

Imatge renderitzada amb VRay

Font: www.chaosgroup.com

https://www.chaosgroup.com/es
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5.2. Configuració d'Arnold Render

En primer lloc, cal recordar que hem de configurar Rendering (Menu Set) >

Render > Render Settings > Render Using > Arnold Renderer.

Selecció d'Arnold Render

A la primera pestanya tenim Common; hi trobarem dades com les següents:

• La ruta de sortida dels arxius generats pel render.

• El format dels arxius.

• La grandària de la finestra.

• Els frames que es renderitzaran.

• L'espai de color.

A la pestanya Arnold Renderer tenim:

• Configuració del Sampling.

• Ray Depth: com el seu nom indica, representa la profunditat. No s'han de

configurar valors gaire més grans dels indicats.
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Depth Rays

Font: www.chaosgroup.com

• Atmosphere: per a crear volums en la llum, com fog (boira).

• Motion Blur: genera un desenfocament de moviment en els objectes ani-

mats perquè no parpellegin durant l'animació.

• Lights-Settings: es pot configurar que Arnold ometi l'avaluació dels valors

que estiguin per sota del llindar configurat.

• Textures: per a habilitar el procés de transformació de textures al format

TX, nadiu per a Arnold (millora el rendiment de càlcul).

• A la pestanya AOVs es configuren les capes i canals per a configurar el

render per passes.

5.3. Render sequence i batch render

1)�Render�Sequence: Rendering (Menu Set) > Render > Render Sequence.

Tips

Es recomana no sobrepassar
els valors de sampling Camera
(AA) 4, Diffuse 3, Specular 3,
ja que consumiria massa recur-
sos.

• Render Layer > Create New Layer.

• Dins del nou layer que hem creat: Botó dret > Create Collection.

• S'obren, a la dreta, totes les opcions de Collection.

• Seleccionem en el visor de Maya (o l'outliner) tots els objectes, llums, cà-

meres que volem renderitzar i premem Add a la finestra Collection del

render layer.

• Per a renderitzar: Render > Render Sequence.

2)�Batch�Render: Rendering (Menu Set) > Render > Batch Render

Tips

D'aquesta manera, no apareix
la marca d'aigua d'Arnold en
renderitzar, tot i que cal tenir
en compte que no es podrà
utilitzar l'equip mentre estigui
processant.

https://www.chaosgroup.com/es
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Amb aquest tipus de render donem l'ordre de renderitzar a Maya, però podem

continuar treballant en el projecte. El gran inconvenient succeeix amb Arnold,

ja que si renderitzem d'aquesta manera apareix la marca d'aigua en les imatges

resultants.

5.4. Render layers. Renderitzat per passes

5.4.1. Arbitrary Output Variable (AOV)

AOVs

Font: www.chaosgroup.com

La forma de poder renderitzar per passes separats és a través del Render Settings

> AOVs.

AOVs

https://www.chaosgroup.com/es
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A la finestra AOVs podem seleccionar els passes i afegir-los per fer-los actius (a

la dreta de la finestra); llavors se'ns afegeixen a sota, on podem anomenar-los,

dir quins canals ens interessen, etc. La imatge següent mostra com s'ha ren-

deritzat el passe de diffuse directe i indirecte per després fusionar-los en com-

posició (a la dreta).

AOVs

Font: www.chaosgroup.com

Els passes més habituals són els de color, diffuse, specular, reflection, el de pro-

funditat (z-depth), fins i tot de les llums per separat. Les possibilitats són infi-

nites, tot depèn de les pretensions que tinguem i de la nostra capacitat per a

veure l'aplicació d'aquestes capes per separat.

5.4.2. zdepth

Font: www.chaosgroup.com

5.5. Composició d'imatge en 3D

Tenir tots els arxius per separat (cadascuna de les llums, color, reflex, especular,

profunditat, etc.) proporciona un gran poder al compositor d'imatge, ja que

pot oferir diferents solucions gràfiques al director creatiu. Les propostes de

modificació en gairebé totes les opcions són sobre els arxius ja renderitzats,

la qual cosa redueix dràsticament el temps de producció, i ofereix respostes

visuals ràpides, fet que facilita la presa de decisions.

https://www.chaosgroup.com/es
https://www.chaosgroup.com/es
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Imatges per passes

Composició de capes 3D

Font: www.foundry.com

5.6. Pràctica VI: renderitzat

En aquesta pràctica renderitzarem l'escena que hem creat. En primer lloc,

obrim la finestra de configuració de les opcions de render que hi ha a la icona

representada amb una claqueta amb un engranatge.

http://www.foundry.com/
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Render Settings

A la finestra Render Settings hem d'ajustar la ruta on volem que es deixi l'arxiu,

nom, format, extensió, si volem renderitzar un únic frame o una seqüència, la

càmera de què es farà el procés, el format de pantalla, etc. Tingueu en compte

que si la ruta que apareix a Paths no és correcta, la hi podreu indicar vosaltres

a File > Set Project.



© FUOC • PID_00270544 122 Gràfics 3D

Finestra Render Settings

Per a acabar, renderitzem la imatge que hem configurat dins de les opcions

del Render Settings a Render > Batch Render. El programari començarà a fer

el càlcul d'aquest render, però podrem continuar treballant, no com ocorre en

altres programaris, en què l'aplicació queda bloquejada fent el càlcul.
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Imatge final
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