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1. Generación de imagen de síntesis en 3D

Las producciones profesionales 3D pueden llegar a ser realmente complejas,

por lo que es habitual encontrarse con equipos de trabajo muy amplios y com-

puestos por diversos perfiles muy especializados. Dentro del equipo humano

involucrado en un proyecto 3D, podemos encontrar personas relacionadas

con la producción y otras que desarrollan funciones ajenas al área de produc-

ción 3D. Dentro del departamento 3D existen dos tipos de perfiles:

• Especializado en las distintas áreas del proceso de creación de proyectos

3D, tales como modelado, creación de materiales y texturizado, anima-

ción, iluminación, etc. Este es el tipo de perfiles que se encuentran en pro-

ducciones profesionales, tanto en el campo audiovisual como en el desa-

rrollo de videojuegos.

• Generalista 3D: personal que puede desarrollar proyectos 3D en cualquiera

de sus áreas pero que no tienen un conocimiento profundo de las mismas.

Este perfil es habitual en pequeñas producciones.

A su vez, los perfiles o áreas de producción de un departamento 3D pueden

estar compuestos por:

• Modelado: el personal de esta área se encarga de generar los objetos en un

espacio tridimensional.

• Creación de materiales y texturizado: esta parte del departamento se en-

carga de aplicar y editar las propiedades relacionadas con la apariencia fí-

sica de los materiales (color, reflejo, transparencia, etc.), así como crear y

aplicar las texturas necesarias para simular el aspecto de los objetos, tales

como texturas de piedra, de hojas, de madera, etc.

• Character setup y rigging: en esta parte se encargan de crear y configurar un

esqueleto virtual y sus controles a los objetos que sea necesario; suele ser

más propio de personajes humanos o humanoides, animales, etc.

• Animación: desarrollan la animación de los personajes o los objetos a par-

tir de los modelos que tienen ya aplicado el rigging.

• Iluminación y render: los miembros de esta área son los responsables de

estructurar un set de iluminación acorde con la escena y configurar los

parámetros adecuados para obtener una imagen final.
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• Efectos: realizan los efectos visuales y las dinámicas, como fluidos, humo,

etc.

• Investigación y desarrollo: es el equipo encargado de desarrollar las herra-

mientas necesarias para cumplir con los requisitos del equipo creativo.

Proceso de creación de una producción 3D

1.1. Visualización 3D

En primer lugar, debemos tener en cuenta que estamos proyectando imágenes

en tres dimensiones en un plano en dos dimensiones, la pantalla. Este proce-

so requiere de un gran procesamiento de cálculo y, por lo tanto, se precisan

softwares y equipos capaces de procesar los cálculos necesarios para generar

este tipo de imágenes. Por este motivo, si deseamos tener un rendimiento óp-

timo, será imprescindible cumplir unos requerimientos técnicos mínimos en

nuestro equipo antes de instalar el software 3D.

La creación de imágenes 3D es utilizada para desarrollar objetos o escenarios

que no existen en la realidad o que van tener animaciones especiales, para

crear prototipos, para crear escenarios en los que se integra imagen real, etc.

Los proyectos 3D son aplicados especialmente en sectores como la arquitec-

tura, la ingeniería, los productos audiovisuales y los videojuegos. A continua-

ción, vamos a describir varios aspectos destacables de la visualización en 3D.
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1.1.1. Vistas

Autodesk Maya nos ofrece la posibilidad de poder visualizar los objetos que

estamos modelando desde distintos puntos de vista; esto nos facilita el proceso

de creación tanto desde un punto de vista técnico como creativo.

Los tipos de vistas que nos podemos encontrar son:

1)�Ortográficas: estas vistas representan los objetos y elementos de la escena

en un plano a través de una proyección ortogonal. Este tipo de proyecciones

son lo que conocemos planta, alzado y perfil; por lo tanto, son vistas en dos

dimensiones.

Planta, alzado, perfil y perspectiva

2)�Perspectiva: referente a las cámaras virtuales. Es una representación en 3D

dentro de la vista 2D, de manera que las líneas que forman los objetos van

variando conforme se modifica el punto de fuga. Al tener una vista en pers-

pectiva podremos realizar operaciones como traslaciones, rotaciones y zoom

dentro del espacio de la escena.

En cuanto a las vistas ortográficas, en Maya nos encontramos con las siguientes

proyecciones:

• La vista top -Y, que equivale a la planta del objeto.

• La vista front -Z, que equivale al alzado del objeto.

• La vista side -X, que equivale al perfil del objeto.
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Vista ortográfica de un cono en Autodesk Maya

Por otro lado, tenemos la vista perspectiva, que es una cámara virtual que se

puede mover en las tres dimensiones. Por defecto, Maya se inicia con una

cámara virtual denominada persp, pero hay que tener en cuenta que podemos

crear tantas cámaras virtuales como deseemos.

1.1.2. Grid

El grid es la rejilla horizontal cuadriculada que aparece en la vista persp. El grid

nos ayuda para ubicarnos en el espacio o incluso para tener una referencia de

tamaños. El grid se puede mostrar u ocultar en Display > Grid.

Tips

Es un error recurrente intentar
rotar en una vista ortográfica,
algo que es imposible puesto
que, como hemos dicho, son
vistas en 2D y por tanto no tie-
nen profundidad.

Grid de Autodesk Maya
Tips

En las opciones del grid pode-
mos configurar el tamaño, las
subdivisiones de la rejilla, el
color, etc.
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1.1.3. Coordenadas

Para facilitar la creación y el movimiento de elementos dentro del espacio

existe un eje de coordenadas. Por lo tanto, cada elemento tendrá unas coor-

denadas en el espacio. Para conocer las coordenadas en las que está situado

el objeto hay que acceder a Windows > General Editors > Channel Box/Layer

Editor y seleccionar el objeto.

Los ejes de coordenadas están codificados en distintos colores para poder vi-

sualizar más fácilmente en el eje que estamos trabajando. El código de color

que utiliza Maya es rojo para el eje X, verde para el eje Y y azul para el eje Z.

Ejes de coordenadas de objeto

1.2. Flujo de trabajo en Autodesk Maya

El flujo de trabajo en Maya tiene sus particularidades respecto a otros softwares

genéricos, aunque es muy similar a otros de ámbito profesional en los que se

realizan proyectos de producción 3D e incluso audiovisual. A continuación,

vamos a analizar cómo se crean y gestionan proyectos, qué formatos existen,

etc.

1.2.1. Formatos de los proyectos

Al guardar un proyecto en Maya podemos crear dos tipos de formatos distin-

tos.

• Maya Binario (.mb): es el formato nativo.

• Maya ASCII (.ma): es un formato editable y por tanto se puede añadir in-

formación.

Tips

• Se puede modificar el eje
vertical (altura) a través de
Windows > Settings/Pre-
ferences > Preferences >
World Coordinate System.
Esta operación es necesa-
ria a veces porque hay soft-
wares en los que existe una
variación de nomenclatura
de este eje.

• Se pueden variar las unida-
des en las que se miden es-
tas coordenadas a través de
Windows > Settings/Prefe-
rences > Preferences > Wor-
king Units > Linear.

Tips

El formato .mb tiene un peso
menor que .ma, pero este últi-
mo permite abrir proyectos en
distintas versiones de Maya.
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Los proyectos se guardarán por defecto en el formato nativo .mb; si deseamos

guardar el proyecto en un formato distinto, tendremos que ir a File > Scene

as y seleccionar format .ma.

1.2.2. Creación y configuración de proyectos

En primer lugar, hay que tener en cuenta que los proyectos de Maya no se

limitan simplemente a los archivos .ma y .mb; de hecho, la única informa-

ción que contienen estos archivos son las escenas. Realmente, cuando creamos

un proyecto de Maya aparecen una serie de carpetas que contendrán todo el

material necesario para desarrollar correctamente un proyecto. La manera de

crear una carpeta de proyecto es a través de File > Project Window.

Gestión de proyectos (Project Window)

La ventana Project Window proporciona toda la información de las carpetas

que componen el proyecto. Además, es necesario añadir un nombre al proyec-

to (Current Project) y una ubicación al mismo (Location). Como vemos, se puede

editar el nombre de cada una de estas carpetas de proyecto; por ejemplo, nos

encontramos la carpeta escenas (.ma y .mb), archivos de audio, imágenes y

texturas, clips de vídeo, temporales, secuencias de imágenes renderizadas, etc.

Posteriormente, veremos cómo se prepara y configura el producto final, el ren-

der. Si nuestro proyecto está creado y enrutado (Set project) correctamente, es-

tas imágenes resultantes siempre caerán en la misma carpeta del Project Win-

dow, images.

Tips

Si abrimos una escena debe-
remos configurar en qué pro-
yecto deseamos trabajar; para
ello seleccionaremos File > Set
Project; de esta manera, todos
los temporales y las imágenes
renderizadas irán por defecto a
su carpeta correspondiente del
proyecto.
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1.2.3. Nomenclatura

El desarrollo de proyectos 3D de cierta envergadura puede llegar a generar una

gran cantidad de archivos, ya que debemos tener en cuenta escenas, texturas,

modelos, animaciones, tomas, etc. Por este motivo, es crucial establecer un

sistema de nomenclatura de toda esta cantidad de archivos.

Señalética de autovías

En cuanto a la cantidad de archivos resultantes, hay que tener en cuenta que

Maya renderiza las secuencias en imágenes independientes; por lo tanto, si

creamos una secuencia de 10 segundos, no creará un .mov o un .avi de esa

duración, sino que será una secuencia de 250 imágenes (teniendo en cuenta

que trabajamos a 25 fotogramas por segundo). Por lo tanto, se crearán gran

cantidad de archivos y es necesario tener una estructura muy organizada con

nombres descriptivos.

En relación con la nomenclatura de los archivos se recomienda:

• Nombrar la versión del archivo en la que se está trabajando. Por ejemplo:

escena_bosque_03.mb.

• No dejar espacios en el nombre de los archivos, utilizar guiones bajos o po-

ner la segunda palabra en mayúscula. Por ejemplo: escena_bosque_03.mb,

escenaBosque03.mb.

• Para las versiones modificadas o definitivas, no repetir la última letra en

las versiones, como por ejemplo clip_buenoooooooooo.jpg, ni la palabra

OK repetida clip_buenoOKOKOKOKOK.jpg. Por lo tanto, la nomenclatu-

ra debería ser clip_bueno_01.jpg, clip_bueno_02.jpg, clip_bueno_03.jpg,

clip_bueno_04.jpg, etc.

• Estandarizar la nomenclatura para todos los posibles tipos de elementos

que se van a utilizar y hacer una tabla con las abreviaturas de la nomen-

clatura. Por ejemplo:
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Objetos obj

Texturas tx

Tomas toma

Versión ver

…. ….

Ejemplos de nomenclatura

1) nombreApellido_temaX_ejercicioX_versionX.

Ej: davidGarcia_tema01_ej01_ver01.mb

2) nombreApellido_temaX_proyectoX_tomaX_planoX_versionX.

Ej: davidGarcia_tema01_cortoSapo_toma01_plano01_ver01.mb

Por lo tanto, es imprescindible una coordinación técnica de recursos necesa-

rios y resultantes, así como una fase de verificación y control de calidad de las

imágenes para validar el proceso.

1.3. Interface Autodesk Maya

1.3.1. Vistas

Ya hemos analizado los tipos de vistas que existen en Maya. Ahora vamos a

ver cómo navegar por el espacio de la escena.

En primer lugar, tenemos que mantener pulsada la tecla ALT y utilizando los

tres botones del ratón podemos:

• ALT+Botón izquierdo: rotación.

• ALT+Botón central: paneo, traslación horizontal o vertical.

• ALT+Botón derecho: zoom in o zoom out.

Tips

• Tener en cuenta que en las
vistas ortográficas no se po-
drá rotar puesto que son
vistas en dos dimensiones.

• Recordad que mantenien-
do pulsada la tecla espacio,
la vista que tengamos se-
leccionada pasará a ocupar
toda la pantalla, y si volve-
mos a pulsarla pasaremos a
la vista anterior.

• Recordad que a través del
Menu View Panel > Show
de cada vista podemos
filtrar los elementos que
deseamos visualizar.
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1.3.2. Partes del interface

Partes en las que se divide en interface de Autodesk Maya

1)�Menús

Corresponde a la parte superior y ofrece la opción de cambiar el tipo de sección

en la que deseamos trabajar o incluso personalizarla a través del Menu Set.

Las opciones que aparecen en este menú se pueden dividir en las que varían,

dependiendo el Menu Set que se selecciona y las que aparecen siempre con

independencia de la selección del Menu Set.

Menús

Por otro lado, al desplegarse cada uno de los menús, aparece en la parte supe-

rior una línea punteada; si hacemos clic y arrastramos esta ventana se hace

flotante. Esta acción es realmente útil cuando se necesita utilizar varias opcio-

nes o herramientas de ese menú.
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Ventana flotante

2)�Menu�set

Ofrece la posibilidad de variar entre las distintas categorías del programa: Mo-

deling, Rigging, Animation, FX y Rendering. Incluso nos permite la posibili-

dad de personalizar las categorías existentes.

Menu sets

3)�Status�line

A la derecha del Menu sets podemos encontrar una serie de iconos que repre-

sentan varias de las herramientas y acciones más utilizadas. A través de la línea

vertical que aparece entre cada grupo de herramientas se puede expandir o

comprimir el submenú.

Status line

4)�Shelf
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Existen varias pestañas que contienen iconos con las herramientas que el soft-

ware considera más comunes. Estas pestañas se pueden personalizar e incluso

crear nuevas con las herramientas que deseemos. Esta será una manera rápida

de poder acceder a las herramientas más utilizadas.

Shelf Poly Modeling

Shelf Polygons

Nuevo shelf

5)�Selector�Workspace

Nos permite poder seleccionar el espacio de trabajo que más se adapte a nues-

tras necesidades.

Tips

Se puede crear un nuevo shelf
personalizado haciendo clic en
el icono del engranaje > New
Shelf. Se genera una pestaña
nueva vacía si se pulsa Ctrl +
Shift + clic en la herramienta
que deseemos añadir al shelf.
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Workspace

6)�Slider�icons

Estos iconos nos dan acceso directo a una serie de herramientas agrupadas que

son muy utilizadas en distintos momentos de la creación de proyectos 3D.

Están compuestas por:

• Modelling Toolkit

• HumanIK

• Attribute Editor

• Tool Settings

• Channel Box/Layer Editor

Slider icons

7)�Channel�box

Esta es una de las pestañas que también aparecen en el Slider icons anterior-

mente explicado. En esta sección se ofrece al usuario la posibilidad de editar

ciertos valores de los objetos seleccionados.
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Channel Box

8)�Layer�editor

Existen dos tipos de ventanas de capas, las de animación y las de visualización.

En nuestro caso, la más interesante será la pestaña Display, ya que nos permite

crear capas de los objetos que deseemos, agruparlos, ocultarlos, etc.

• V: hace la capa visible, si se desactiva oculta la capa.

• P: todos los elementos de la capa visible en play.

• R: referencia. Los elementos de la capa no pueden ser seleccionados.

• T: template. Los elementos de la capa se muestran en modo alambre (wire-

frame) y no pueden ser seleccionados.

• Además, también todos los elementos que pertenecen a una capa se pue-

den organizar por colores.

Tips

Es interesante utilizarlo porque
permite editar los parámetros
de forma aislada y a través de
un control numérico, por lo
que permite modificaciones
más precisas y controladas.
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Layer Editor

9)�View�panel

Se encuentra en la parte superior de cada una de las vistas (top, side, front,

persp). Presenta un menú con iconos de acceso rápido y menús desplegables

con numerosas opciones de visualizado.

Herramientas y opciones del View Panel

10)�Tool�box

Contiene las herramientas utilizadas para seleccionar y transformar objetos de

la escena.

Tips

Es muy útil para filtrar los ob-
jetos que se desea visualizar a
través de Show. Seleccionar los
modos de visualización, en wi-
reframe, shaded, con textura o
con luces. También para poder
ver las áreas de recorte del for-
mato final del archivo. Incluso
se puede seleccionar cualquier
vista ortográfica, o de perspec-
tiva, permitiendo crear nuevas
cámaras, todo ello a través de
Panels.
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11)�Botones�Quick�layout/Outliner

Es un acceso rápido a los distintos tipos de visualización de la escena. Por lo

tanto, se pueden seleccionar las vistas en perspectiva (todas las cámaras que

deseemos), las vistas ortográficas (front, side, top) o mostrar el Outliner.

Tips

Es recomendable utilizar los
accesos directos:
• Q: Select, selección del ele-

mento.
• W: Move, traslación del ele-

mento.
• E: Rotate, rotación del ele-

mento.
• R: Scale, escalado del ele-

mento.
• T: mostrar acceso directo a

los elementos de transfor-
mación.

El Outliner es una ventana que contiene todos los elementos que contienen la

escena. Ofrece información sobre la jerarquía de los elementos; se puede filtrar

la información que aparece a través de la pestaña Show para que aparezcan

solo las luces, las geometrías, las cámaras, etc.

El Outliner también se puede encontrar en la barra principal de menú en Win-

dows > Outliner y en el Panel en Panels > Panel > Outliner.

El Outliner nos muestra los objetos por defecto de la escena (cámaras de las

vistas ortográficas y persp), los objetos que hayamos creado (geometrías, luces,

cámaras, etc.).

Tips

Pulsando el espacio una sola
vez la vista seleccionada pa-
sa a ocupar toda la pantalla; si
volvemos a pulsar, vuelve a la
configuración anterior.
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Outliner

12)�Time�Slider

Es la línea de tiempo con todos los frames que contienen la animación. Las

líneas rojas definen dónde existe un keyframe.

Time Slider

13)�Range�Slider

Esta opción permite establecer el frame de inicio y final de la animación en la

escena. A su vez, se puede definir un rango de reproducción de la animación,

ya que hay veces que interesa reproducir solo alguna parte de la animación

para matizar ciertos aspectos del movimiento.

Range Slider

14)�Controles�Playback

Son los controles de reproducción pudiendo ver la animación hacia delante,

hacia atrás, ir frame a frame o incluso desplazarse de keyframe a keyframe.

Playback controls

Tips

Si tenemos pulsado el botón
central seleccionando un obje-
to y lo desplazamos hacia otro
objeto (manteniendo pulsado
el botón central), crearemos
un parentesco entre objetos
tal y como podemos ver en la
imagen: Cabeza y Piernas per-
tenecen a Cuerpo. De esta ma-
nera, podemos ir creando una
jerarquía entre los elementos
de la escena.
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15)�Menús�Anim/Character

Proporciona acceso a características avanzadas de animación como el Charac-

ter Set y el Anim Layer.

Anim Layer

16)�Opciones�Playback

Control de las opciones de reproducción. A: fotogramas por segundo. B: Re-

producción (Bucle). C: Keyframes automáticos. D: Acceso a las preferencias.

Opciones Playback

17)�Command�Line

Es el área donde se puede introducir código, en este caso en lenguaje MEL o

Python, para realizar operaciones. A través del icono Show Script Editor, se

puede abrir la ventana para ver todas las operaciones que se van realizando

en formato código.

Command Line

18)�Help�Line

En la parte inferior existe una caja donde aparece información descriptiva re-

levante sobre dónde se encuentra el puntero y también sobre cómo completar

acciones.
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Help Line

1.3.3. Attribute Editor

Es una ventana que nos permite acceder a distintos atributos del objeto selec-

cionado. Es como una vista expandida y mucho más gráfica que el Channel

Box. Se puede acceder al Attribute Editor desde:

• Select Windows > General Editors > Attribute Editor.

• Select Windows > UI Elements > Attribute Editor.

• Select Key > Attribute Editor.

• Desde el acceso directo del Slider Icons.

Acceso desde el Slider icons

En la parte superior se puede acceder a todos los nodos que pertenecen al

objeto seleccionado.
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1.3.4. Opciones herramientas/operaciones

Al lado de las herramientas aparece el icono de un cuadrado; si pulsamos den-

tro se abren las opciones de esa herramienta.

Cuadrado de opciones

1.3.5. Atajos de teclado (shortcuts)

Los atajos de teclado son fundamentales para agilizar la operación de cualquier

software; a continuación se adjunta un resumen de los más utilizados.

Resumen de atajos de teclado

1.3.6. Hotbox

Además de los menús e iconos para el acceso rápido, existe otro modo de se-

leccionar herramientas y opciones. Pulsando la tecla espacio (pulsación man-

tenida) aparecen todas las opciones y menús; si se pulsa de forma mantenida

en cualquiera de las secciones, se despliegan los submenús correspondientes.

Tips

Si pulsamos en la opción Apply
se aplican las modificaciones
(si la hemos realizado) y la
ventana sigue abierta. Sin em-
bargo, si pulsamos en el bo-
tón de la izquierda (que suele
tener el nombre de la acción
de la herramienta; por ejem-
plo, Create, Bake pivot, etc.),
se ejecuta la herramienta y se
cierra la ventana quedando
guardando los valores para la
siguiente vez que se ejecute la
herramienta.

Tips

Se pueden personalizar los ata-
jos de teclado en Windows >
Settings/Preferences > Hotkey
Editor.
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Menú Hotbox

1.4. Creación de primitivas

Las primitivas son los objetos geométricos más básicos que estima Maya a

partir de los cuales se pueden crear formas más complejas. Los parámetros más

habituales al crear primitivas son el tamaño o el número de caras (faces). En la

siguiente imagen se puede apreciar, a la izquierda, una esfera con pocas caras,

y por tanto muy poligonal, y a la derecha otra con más caras más suavizada.

Esferas con distintos números de caras (faces)

1.4.1. Creación de primitivas

Existen primitivas poligonales, NURBS y Volume; más adelante analizaremos

las diferencias entre cada una de ellas. Cada uno de los grupos de primitivas

en Maya están compuestas por:

Tips

Las opciones del Hotbox se
pueden personalizar a través
del botón que se encuentra a
la derecha: Hotbox controls.
Al mantener pulsado este bo-
tón, se pueden configurar las
opciones de visualización.
Pulsando en el botón Maya
(pulsación mantenida) se pue-
de configurar cualquier vista
(ortográficas o perspectivas)
en la vista en la que se está tra-
bajando.
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Tipos de primitivas en Maya

Diferentes tipos de primitivas en Maya

1.4.2. Crear primitivas y cambiar características

Las primitivas se pueden crear a partir de:

• Create > Nurbs Primitives

• Create > Polygon Primitives

• Create > Volume Primitives

En el Attribute Editor se pueden variar de manera más visual (con sliders) las

características del objeto. Además, en el Channel Box también podemos variar

numéricamente.
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Parámetros del Attribute Editor

1.4.3. Interactive Creation

Se activa la opción en Create > Polygon Primitives > Interactive Creation.

Con esta opción activada podemos crear primitivas de manera interactiva ha-

ciendo clic y arrastrando y siguiendo las instrucciones que aparecen en la pan-

talla.

Interactive Creation

Tips

A través del Hotbox también
tenemos acceso a las opciones
de Create.
En Channel Box > Inputs se
puede encontrar la configura-
ción de la primitiva.
Pulsando la tecla T se accede a
las características del objeto.
La visualización puede variar a
través del atajo de teclado: 4
para wireframe, 5 para shaded,
6 para textured y 7 para lights.
El objeto se puede modificar
con el atajo de teclado W (mo-
ver), E (escalar), R (rotar), Q
(seleccionar).



© FUOC • PID_00270545 29 Gráficos 3D

1.5. Cámaras 3D, luces y render en Autodesk Maya

1.5.1. Cámaras 3D

Ya hemos visto que cualquier proyecto de Maya empieza con cuatro cámaras,

las tres ortográficas (side, front y top) y una en perspectiva (persp), o sea, en 3D.

Las vistas pertenecientes a cámaras 3D podrán moverse en todas las direccio-

nes, tal y como vimos pulsando la tecla ALT+ cualquiera de los tres botones

del ratón.

Cámara 3D

También se pueden crear más cámaras 3D a partir de Create > Cameras > y

seleccionar un tipo de cámara. Podemos seleccionar la cámara nueva o cual-

quiera de ellas en el menú del View Panel, Panels > Perspective > selección de

la cámara que deseemos.

View Panel
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Para poder identificar las cámaras deberemos nombrarlas con nombres des-

criptivos cuando las creemos. Además, también se podrán nombrar a través

del Outliner o del Attribute Editor posteriormente.

1.5.2. Luces

En Maya se pueden crear tantas luces como necesitemos para iluminar correc-

tamente nuestra escena. Las luces se pueden configurar en intensidad, color,

direccionalidad, decaimiento, etc. Las luces genéricas de Maya se pueden crear

en Create > Lights > seleccionar la luz que deseemos.

Luces en Maya

1.5.3. Render

El render será la interpretación que realiza el software a los valores que hemos

introducido tales como luces, texturas, materiales, cámaras, geometrías, etc.

Dependiendo del motor de cálculo, de render, que utilicemos el resultado será

distinto. Por ejemplo, en Maya podemos encontrar instalados motores de ren-

der como Maya Software, Maya Hardware 2.0, Mental Ray o Arnold.

Además, también se configurarán los frames que se desea renderizar, la ruta en

la que se dejan los archivos, el formato, si tienen canal alfa o no, la calidad

(antialiasing), etc. Para acceder a la configuración del render se puede pinchar

directamente en el icono de una claqueta con un engranaje que aparece en

Status Line o seleccionar Rendering en el Menu Set y después en el menú Ren-

der > Render Settings.
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2. Modelado 3D en Autodesk Maya

En el punto anterior hemos visto cómo se crean primitivas y hemos compro-

bado que la distribución de sus polígonos sigue cierta simetría, pero qué suce-

de cuando estamos modelando objetos más complejos. En la siguiente imagen

podemos percibir que la distribución de la malla geométrica de ambos cráneos

es distinta.

Topología 3D

La topología es una expresión matemática; en nuestro caso, vamos a referirnos

en términos de distribución de la geometría por el objeto. Cuando estamos

modelando debemos tener muy en cuenta qué objetos estamos modelando,

cómo sería su mejor topología en cuanto a sus propiedades, a sus posibles mo-

vimientos, etc. Podemos apreciar en la siguiente imagen que se han buscado

dos soluciones distintas para la distribución geométrica de la parte parietal de

la cabeza.
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Distintas topologías 3D

En la siguiente imagen también vemos cómo el análisis fisiología del ojo y su

contorno nos ayuda a encontrar la mejor solución para crear una topología

efectiva que no rompa con el flow de los polígonos colindantes.

Ejemplo topología

Fuente: www.gauldesign.com

Breves consejos para modelado

• Modela lo que puedas y sepas visualizar.

• Divide los pequeños problemas y retos en modelos simples para poder aplicarlos al
conjunto final. Modela de lo general a lo específico. Puedes y debes utilizar varias
piezas para desarrollar un modelo.

• Utiliza referencias siempre que puedas.

• Modela con quads (4 lados por polígono) siempre que sea posible.

• Evita utilizar polígonos con forma de triángulos o pentágonos.

• Distribuye equitativamente los polígonos del objeto.

• Ten en cuenta las partes que se animan para añadir secciones allí donde sea necesario.

Tips

En muchas ocasiones, sobre
todo cuando se trabaja para vi-
deojuegos, es necesario reali-
zar una retopología del objeto.
Cuantos más polígonos contie-
ne un objeto, es necesario utili-
zar más procesador para calcu-
larlo. Las computadoras mue-
ven los objetos de un videojue-
go en tiempo real, por lo que
es imprescindible crear objetos
con el menor número de po-
lígonos posible sin perder de-
masiada calidad. Por este mo-
tivo, se realiza una retopolo-
gía reduciendo la carga poli-
gonal y reubicándola, además
de aplicar mapas de despla-
zamiento y texturas que com-
pensen esa pérdida de detalle.

http://www.gauldesign.com/
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• Evita automatizaciones (booleanos, etc.), ya que producen topologías descontroladas
que producen muchos problemas.

• Recuerda que todos los objetos tienen un pequeño bisel. Es difícil encontrar ángulos
rectos en la naturaleza. Este pequeño detalle aportará gran calidad a tus imágenes
finales.

2.1. Componentes de las geometrías en 3D

¿Qué es una componente? Son las distintas partes en la que se puede subdividir

un objeto.

2.1.1. Selección de componentes

Dependiendo del tipo de objeto que sea, polígono, NURBS o curvas, aparece-

rán distintos componentes. Al seleccionar un objeto y ponernos encima del

mismo podemos pulsar Botón derecho > Seleccionar componente. Por ejem-

plo, en la siguiente imagen vemos los componentes que forman un objeto

poligonal.

Selección de componentes de un elemento poligonal

Tipos�de�selección

Existen diversos tipos de selección:

• Object mode: En el que se selecciona un objeto completo. El color del objeto

es verde.

• Component mode: Selección exclusiva de alguno de los componentes del

objeto seleccionado. El color del objeto pasa a azul.

• Soft Selection mode: Se realiza una selección gradual en el contorno del pun-

to seleccionado. El color es un degradado que varía con la configuración

que tengamos en la selección.
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Tipos de selección

Fuente: www.autodesk.com

Por ejemplo, si se seleccionan componentes de un objeto poligonal, el color

cambiará dependiendo del componente que seleccionemos.

Tipos de componentes

Fuente: www.autodesk.com

2.1.2. Ejes

Otro aspecto a tener en cuenta es la posición de los ejes del objeto. Por ejem-

plo, si pulsamos dos veces sobre el icono de traslación, entraremos en el Tool

Settings; ahí podremos configurar cómo queremos mover el objeto en Axis

Orientation, sobre los ejes de la escena (world) o sobre los ejes internos del

propio objeto. Dependiendo de las operaciones que busquemos realizar, nos

interesará una cosa u otra.

Tips

Si editamos componentes,
por ejemplo en traslación, po-
dremos tener un problema
si cambiamos los parámetros
(weight, height, subdivisions)
del objeto desde el Attribute
Editor después de realizar es-
ta modificación, ya que realiza-
rá una aberración en la topolo-
gía.

https://www.autodesk.com/
https://www.autodesk.com/
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Tool Settings

Ejes

2.1.3. Mover el eje de coordenadas (Pivot Point)

Es muy importante entender desde qué punto nos interesa que se modifique

nuestro objeto. Se puede modificar este punto (Pivot Point) pulsando la tecla

Insert o la tecla D.
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Pivot Point

2.1.4. Center Pivot

Esta operación modifica el centro del objeto. Es muy útil porque puede ser

que, por ejemplo, al fusionar dos objetos el centro del objeto no se sitúe donde

nos interesa. Se aplica en Modify > Center Pivot.

Center Pivot

2.1.5. Reset Transformations / Freeze Transformations

Modificación de los valores de rotación, traslación y escalado del objeto. Exis-

ten dos tipos:

• Modify > Freeze Transformations: Modifica los valores de las coordenadas

a (0,0,0)

• Modify > Reset Transformations: Mueve los valores a las coordenadas

(0,0,0)

2.1.6. Select Tool

Es la herramienta de selección y puede ser:

Tips

Por ejemplo, si escalamos el
cuadrado de la imagen ante-
rior, la modificación se hará
hacia el centro del objeto, pe-
ro puede que nos interese que
el escalado se realice desde el
suelo, o sea, desde la base del
cuadrado.
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• Marquee: Haciendo clic. Seleccionando Camera-based selection solo selec-

ciona los objetos/componentes vistas por cámara.

• Drag: Arrastrada la selección.

• Soft selection: Opciones de realizar una selección suavizada. Lo veremos

más ampliamente en el Modelling Toolkit.

• Symmetry selection: Se pueden seleccionar componentes u objetos desde un

eje de simetría.

Select Tool

2.1.7. Emparentar (avanzado)

Se pueden crear relaciones entre objetos utilizando los siguientes métodos:

• Parent: Selección del objeto que se desea que sea hijo + selección del padre

+ pulsar tecla P. También a través de Edit > Parent. Y para deshacer en Edit

> Unparent.

• Group: También se puede hacer un simple grupo de objeto seleccionándo-

los y pulsando Ctrl+G. También a través de Edit > Group. Y para deshacer

en Edit > Ungroup.
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2.2. Modelado poligonal

2.2.1. Componentes de los polígonos

Los polígonos están compuestos por faces (caras), edges (ejes) y points (vértices).

2.2.2. Importancia de la topología

En la siguiente imagen podemos ver la importancia de la topología de un ob-

jeto. En la imagen de la derecha se genera una pirámide trapezoidal; sin em-

bargo, en la imagen de la izquierda no existen suficientes polígonos para ha-

cer correctamente la interpolación gradual entre la base de la pirámide y su

parte superior.

Distintos tipos de topología

2.3. Modelado NURBS

NURBS es el acrónimo de Non-Uniform Rational B-Spline. Son operaciones ma-

temáticas para crear superficies entre dos o más puntos. Es similar a lo que

sucede en una imagen vectorial de Adobe Illustrator.

Tips

Ya veremos que las herramien-
tas más utilizadas en el mode-
lado poligonal son Extrude,
Bevel, Edge loop.
Con la Tecla G aplicamos la úl-
tima acción que hemos realiza-
do.
Es muy importante tener el nú-
mero de polígonos controla-
do; para ello se puede visuali-
zar a través de Display > Head
up display > Poly count.
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Curva vectorial

Las componentes más importantes son:

• Isoparm: las curvas isoparamétricas que seccionan el objeto.

• Control vertex: los vértices de las curvas.

Isoparm

Además, las operaciones más utilizadas son:

• Loft: Creación de una superficie entre dos curvas. Surface > Loft.

• Revolve: Revolución alrededor de un eje. Hay que tener cuidado con el eje

de coordenadas y con el inicio/finalización de la curva. Surface > Resolve.

• Birail: Es un Trazado+Recorrido. Hay que tener cuidado con la unión. Sur-

face > Birail.

• Extrude: Extrusión a lo largo de una curva. Surface > Extrude.

• Trim tool: Realiza un recorte. Surface > Extrude.

• Extend: Extiende la superficie. Surface > Extend.

Menu�Curve�Tools
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• CV: Realiza una ponderación entre vértices.
Create > Curve Tools > CV Curve Tool.

• EP: Crea vértices en cada clic.

Create > Curve Tools > EP Curve Tool.

• Bezier: Pulsado genera controladores. Create > Curve Tools > Bezier EP

Tool.

• Pencil: Genera puntos donde más densidad de curva hay.
Create > Curve Tools > Pencil EP Tool.

• Two point circular arc: Crea una curva circular a partir de dos puntos.
Create > Curve Tools > Two Point Circular Arc.

• Three point circular arc.: Crea una curva circular a partir de tres puntos.
Create > Curve Tools > Three Point Circular Arc.

Curve Tools

Las partes de la curva editables pueden ser las siguientes:

Tips

Cerrar curvas: Curves > Open/
Close
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2.4. Modelado con subdivisión de superficies

Es una técnica algorítmica para generar superficies suaves como una secuencia

de mallas poligonales refinadas sucesivamente.

Ejemplo de suavizado de curva insertando puntos

Posee más continuidad que las NURBS. Además, es fácil de uso como los polí-

gonos y con la suavidad y continuidad de las NURBS. En contra, pueden existir

problemas con la importación exportación.

2.4.1. Subdivisión conservando posición de vértices anteriores

La subdivisión se puede crear conservando los puntos iniciales, simplemente

añadiendo nuevos en las posiciones intermedias.

Subdivisión
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2.4.2. Subdivisión moviendo posición de vértices anteriores

La subdivisión se puede crear modificando los puntos iniciales, añadiendo

nuevos en las posiciones intermedias que hacen que la posición de los iniciales

varíe a través de interpolación entre ambas.

Subdivisión

2.4.3. Convertir subdivisiones

Para generar subdivisiones se pueden crear a partir de la simple primitiva de

un cubo. Como vemos en la imagen, al seleccionarlo y pulsar la tecla 2 vemos

el cubo subdividido. En el ejemplo se aprecia cómo se aplican distintos niveles

de subdivisión, de más poligonal (nivel 1) a más suave (nivel 3).

Tips

Si queremos aplicar esa subdi-
visión porque consideramos
que ya es definitiva, podemos
hacerlo en Modify > Convert >
Smooth mesh preview to poly-
gon.

Tips

Recordad que prácticamen-
te no existen los bordes total-
mente rectos, todo tiene un
pequeño bisel. Así se lograrán
resultados más realistas.
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2.4.4. Añadir edges para endurecer bordes

En la imagen se puede ver cómo al añadir edges en los bordes del objeto la

interpolación de los ejes es más dura. Como modeladores debemos jugar con

este aspecto para obtener resultados realistas.

2.4.5. Comparación añadiendo edges

A continuación, se puede analizar el comportamiento de las subdivisiones de-

pendiendo dónde se generen nuevos ejes.
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2.4.6. Ajustar el nivel de subdivisiones

Podemos ajustar ese nivel de subdivisiones dentro del Attribute Editor en pOb-

jectShape1 > Smooth mesh > Subdivision modes > Subdivision levels.

2.4.7. Comparativa Polígonos, NURBS y Subdivisión

Para finalizar, en la imagen se muestra que, aunque los resultados son visual-

mente iguales en las tres figuras, la metodología de construcción es totalmente

distinta.

Tips

Debemos tener en cuenta que, a mayor subdivisión, mayor número de polígonos y, por
tanto, más pesará nuestra escena.

Para acceder a un acceso rápido de herramientas se puede pulsar Shift+click derecho.
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Acceso rápido a herramientas

2.4.8. Measure Tools

Según el trabajo que se esté realizando, puede ser importante conocer las me-

didas exactas de todos los elementos. Para ello, podemos utilizar reglas en Se-

lect Create > Measure Tools > Distance Tool.

Además, se pueden configurar las unidades en las que deseamos trabajar en

Windows > Settings/Preferences > Preferences > Settings.
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2.4.9. Image Plane

Se puede utilizar una imagen de referencia para ir generando la geometría en

las vistas ortográficas. Es una forma muy común de modelar, como si tuvié-

semos un papel cebolla con el dibujo. Para importar la imagen se accede al

Menu View Panel de la vista ortográfica que nos interese y View > Image pla-

ne > Import image. Se debe tener en cuenta la importancia de configurar el

tamaño y la posición de las distintas imágenes que se utilicen de plantilla, ya

que deben encajar perfectamente en las distintas vistas.

Alineado de imágenes en las vistas de Front y Side

2.5. Herramientas para modelado. Modeling toolkit. Image plane

Es un menú que nos facilita el proceso de modelado porque contiene las he-

rramientas más utilizadas.

1)�Pestaña�Object

• Show/Hide

• Freeze/unfreeze: bloquea objeto.

Tips

Hay que configurar el tamaño
y la posición de las imágenes
importadas para que concuer-
den las vistas.
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• XRay: Se puede ver detrás del objeto.

• Backface: Se ocultan las caras que no se ven.

• Face triangles: Triangulado de la geometría.

2)�Pestaña�Components

Iconos con acceso directo a las componentes del elemento seleccionado.

Componentes

3)�Selection

• Pick/Marquee = Se selecciona pulsando el botón izquierdo del ratón. Shift

+click (suma a la selección).

• Drag = Selección arrastrando.

• Tweak/marquee = Se puede seleccionar y mover.

4)�Simmetry

• Seleccionar por componente.

• Seleccionar por eje.

• Object: No importa que esté en los valores 0,0,0 de coordenadas.

• World: Siempre respecto a los valores 0,0,0 de coordenadas.

5)�Selection�constraint

• Angle: Restricción respecto al ángulo.

• Border: Restricción respecto al borde.

• Edge loop: Restricción respecto al eje circundante.

• Shell: Aunque haya dos objetos combinados se pueden seleccionar inde-

pendientemente.

6)�Transform�constraint�(no�modifica�topología)

• Edge: Se mueve por los ejes circundantes.

• Surface: Se mueve por la superficie.

7)�Soft�selection

• Soft selection: Influye en los componentes circundantes.

• Tecla B+Botón central: Aumenta/disminuye el radio de la selección.
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2.5.1. Herramientas para Mesh

Son las herramientas más utilizadas. Es un resumen y se pueden encontrar

también en Menu > Mesh, Menu > Edith Mesh y Menu > Mesh Tools.

• Combine: Une dos geometrías.

• Smooth: Añade polígonos suavizando la geometría.

• Separate: Separa los objetos del Combine.

• Boolean: Tiene opciones de sumar las superficies, restar o dejar la intersec-

ción.

2.5.2. Herramientas para Components

• Extrude: Extruir faces o edges.

• Bevel: Genera un bisel en los bordes.

• Bridge: Para crear un puente de geometría nueva entre dos partes, tiene

que ser el mismo objeto. Un truco es crear un Combine.

• Add Divisions: Añade divisiones al face o edge seleccionado.
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2.5.3. Otras herramientas

• Multi-cut: Genera nueva topología.

• Target Weld: Une vértices.

• Circularize: crea contorno circular (topología).

• Collapse: Recomendado para colapsar edges.

• Connect: Recomendado edges y vertex.

• Detach: separa componentes.

• Merge: Unir (primero Combine).

Ejemplo merge

2.6. Deformadores y booleanas

2.6.1. Deformadores Nonlinear

• Son herramientas capaces de deformar la geometría.

• La geometría cambia a color morado cuando se aplica el deformador.

• Ubicación: Barra Menu > Deform.

• En el Channel Box > Inputs: editamos el deformador. También podemos

en el Attribute Editor.

Una vez tenemos seleccionado en el Modeling (Menu Set) > Deform > Non-

linear

1)�Bend.�Este deformador tuerce cualquiera de los extremos de la geometría.

Tips

• Quitar Smooth: Mesh > Re-
duce.

• Cuidado con Boolean. Rea-
liza retopología y puede ge-
nerar fallos.

• Extrude: Realizarlo hacia las
normales del objeto.

• Keep faces together; si se
deshabilita esta opción, se
generan extrusiones nue-
vas, cada una en su eje lo-
cal.



© FUOC • PID_00270545 50 Gráficos 3D

Deform > Nonlinear > Bend

Controladores del deformador Bend

Fuente: www.autodesk.com

2)�Flare.�Provoca una curvatura intermedia editable.

Deform > Nonlinear > Flare

Controladores del deformador Flare

Fuente: www.autodesk.com

3)�Sine.�Deforma el objeto como si fuera una curva de una función seno.

Deform > Nonlinear > Sine

https://www.autodesk.com/
https://www.autodesk.com/
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Controladores del deformador Sine

Fuente: www.autodesk.com

4)�Squash.�Se aplica para comprimir y estirar un objeto manteniendo su vo-

lumen inicial.

Deform > Nonlinear > Squash

Controladores del deformador Squash

Fuente: www.autodesk.com

5)�Twist.�Realiza una rotación sobre sí mismo.

Deform > Nonlinear > Twist

https://www.autodesk.com/
https://www.autodesk.com/
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Controladores del deformador Twist

Fuente: www.autodesk.com

6)�Wave.�Aplica unas ondas que pueden ser animables.

Deform > Nonlinear > Wave

Controladores del deformador Wave

Fuente: www.autodesk.com

2.6.2. Paint nonlinear deformer weights

Esta herramienta se utiliza cuando deseamos aplicar el deformador a una zona

restringida del objeto. El proceso sería:

• Seleccionar objeto deformado.

• Shading > Smooth Shade All o tecla 5

• Deform > (Paint Weights) Nonlinear > ??

• Modify > Paint Attributes Tool

• Seleccionar deformador.

• Pintar con mapa blanco/negro.

https://www.autodesk.com/
https://www.autodesk.com/
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Paint Weight

Fuente: www.autodesk.com

2.6.3. Lattice

Este deformador es una especie de matriz o rejilla que configuramos con los

niveles de subdivisiones que nos interesen y se aplica al objeto. Estos puntos

de la rejilla afectarán proporcionalmente al objeto al que se ha aplicado el

deformador.

Deform > Lattice

Lattice

Fuente: www.autodesk.com

Tips

Muy importante: El aplicar
cambio y deformaciones va
cargando la memoria de nues-
tro equipo, así que cuando
consideremos que el objeto
no se va a modificar, debere-
mos borrar el historial a través
de Edit > Delete by type > His-
tory.

https://www.autodesk.com/
https://www.autodesk.com/
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2.7. Práctica I: Modelado poligonal de mesa

En esta práctica vamos a crear una mesa a partir de la modificación de primi-

tivas poligonales.

En primer lugar, vamos a crear un nuevo proyecto desde File > Project Window;

pulsando el botón New podemos renombrarlo en Current Project; le daremos

el nombre Graficos3D, también definiremos su ubicación en Location. Esta

carpeta de proyecto será la ubicación donde trabajaremos todas las prácticas

de la asignatura.

Configuración del proyecto en el Project Window

Además, en este caso, una vez creado el proyecto, guardaremos la escena como

Mesa_01.mb; recordamos que es recomendable ir guardando versiones incre-

mentales de las escenas; de esta manera, si en algún momento se corrompe el

archivo, podremos seguir trabajando en la versión inmediatamente anterior.

Empezamos por analizar la figura que se muestra en la fotografía para decidir

en cuántas piezas la vamos a subdividir y a partir de qué primitivas vamos a

modelar. En este caso, vamos a subdividir el modelado en las partes tablero

superior, 4 patas y las 4 conexiones entre patas.
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Fuente: Amazon.es

Recordamos que podemos encontrar un acceso rápido a todas las herramien-

tas que necesitamos en la ventana Modeling Toolkit. Además, veremos la ubi-

cación de cada una de ellas dentro del software.

Acceso directo a Modeling Toolkit

1)�Tablero�superior

Partimos de una primitiva cubo en Create > Polygon Primitives > Cube.

Posteriormente, debemos crear la moldura que tiene en el borde. Para ello,

tenemos que seleccionar la caras (face) a través de Botón derecho (encima del

objeto) > Face.

https://www.amazon.es/
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Seleccionar Faces

Una vez seleccionada la cara (face) superior la extruimos en Edit Mesh > Ex-

trude. Vemos que tenemos que escalar un poco proporcionalmente en los tres

ejes (cuadrado interior del controlador) y extruir la cara hacia arriba.

Escalado y extrusión de la cara superior

Para conseguir el suavizado en las esquinas debemos seleccionar los edges a

través de Botón derecho (encima del objeto) > Edges. Después seleccionamos

los edges del contorno pulsando dos veces sobre uno de ellos o seleccionando

de uno en uno teniendo la tecla shift pulsada (para acumular la selección de

edges).

Cuando estén todos seleccionados realizamos el biselado mediante Edit Mesh

> Bevel y configuramos la redondez del borde como deseemos.
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Bevel de Edges

Realizamos la misma operación con las cuatro esquinas de la mesa.

Bevel de esquinas de la mesa

2)�Patas

También partimos de una primitiva poligonal cube a través de Create > Poly-

gon Primitives > Cube. Posteriormente, introducimos los valores de la altura

de la pata de la mesa en la ventana Attribute Editor > polyCube > Height.



© FUOC • PID_00270545 58 Gráficos 3D

Edición de la altura de las patas de la mesa

Ahora vamos a ver otra forma de realizar un biselado a través de la subdivisión

de superficies (subdivision surface). En la opción Mesh Tools > Insert Edge Tool

podemos añadir un eje nuevo a todas las caras.

Aplicación de un Insert Edge Loop

Tal y como se explicó en el punto subdivisión de superficies, podemos visua-

lizar la subdivisión de geometría pulsando las teclas 2 o 3; en la primera se

puede ver también la geometría de la que se parte en wireframe, y en la segunda

únicamente el objeto subdividido. Ya hemos visto que, cuanto más cerca estén

los nuevos ejes creados con los existentes, más duro será el borde al subdividir.
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No debemos olvidar que esta visualización es un previo y que, una vez esté bi-

selado el borde de las patas como deseamos, debemos convertirlo a polígonos

para que se pueda visualizar en el render, Modify > Convert > Smooth Mesh

Preview to Polygons.

Una vez tengamos modelada una de las patas, podemos duplicarla y moverla

a su posición correspondiente con Edit > Duplicate o pulsando la tecla ctrl+D.

3)�Pieza�entre�patas

Para modelar esta pieza, también vamos a partir de una primitiva cubo poligo-

nal. Empezaremos modificando el grosor en el Attribute Editor > polyCube 1 >

Depth. Posteriormente, con Botón derecho encima del objeto > Face seleccio-

namos la cara a partir del cual deseamos que se extruya la pieza y realizamos

una extrusión de la misma con Edit Mesh > Extrude.

Extrusión face lateral

Para realizar el modelado de la pieza correctamente, podemos trabajar en la

vista Front (frontal). Esta decisión se debe a que el objeto que deseamos mo-

delar es simétrico desde el eje vertical, de tal manera que al visualizarlo desde

la vista Front nos resultará más sencillo crear la pieza ya que podemos selec-

cionar y mover los componentes más visualmente.

Para trabajar con la vista Front debemos tener en cuenta las opciones de se-

lección que ofrece el Selection Tool; si pulsamos dos veces encima de la herra-

mienta se abre una ventana flotante, el Tool Settings.
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Selection tool

Puede ser que se realice solamente una selección de los componentes vistos y

no de los que están de los que se encuentran ocultos a la visión de la cámara y,

por tanto, a la del usuario. Por ese motivo, accedemos a las opciones del Selec-

tion Tool, dentro del Common Selection Options; ahí tenemos que desactivar

la opción Automatic camera-based selection. Así conseguiremos seleccionar

también los componentes que están en la parte oculta del objeto.

Tool Settings de la herramienta Select Tool

Hemos visto que la pieza de conexión reduce un poco en la parte central; para

ello podemos seleccionar los vértices de uno de los lados y moverlos un poco

en el eje Y.



© FUOC • PID_00270545 61 Gráficos 3D

Selección de Vertex

Vamos a la vista Front y seleccionamos los Vertex (botón derecho dentro del

objeto > Vertex) para moverlos.

Modificación de Vertex

Posteriormente, seleccionamos Face de la cara del objeto que queremos seguir

modelando y extruimos. Cuando llegamos a la parte de la pieza que queremos

ensanchar, seleccionamos los Vertex y los movemos en el eje Y.

Modificación de Vertex

Una vez tengamos modelada una pieza podemos duplicarla y moverla a su

posición correspondiente. Edit > Duplicate o pulsando la tecla ctrl+D.
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Cuando tengamos todas las piezas duplicadas y colocadas en su lugar, vamos

a crear un grupo con todas ellas para que sea más fácil seleccionar y mover

el objeto en bloque. El grupo se puede crear seleccionando todas las piezas y

pulsar Edit > Group o pulsar ctrl+G.

Mesa final modelada y agrupada

2.8. Práctica II: Modelado de un bote de refresco utilizando

NURBS

Casi siempre que modelamos objetos lo hacemos a partir de imágenes de re-

ferencia. En este caso, podemos realizar una fotografía de un bote de refresco

para utilizarlo como plantilla de referencia. Creamos una nueva escena y la

guardamos en nuestro proyecto con el nombre de Lata_01.mb.

Fotografía de lata de refresco

Para importar la imagen de referencia iremos a la vista Front; dentro del View

Panel seleccionamos View > Image Plane > Import Image.
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Importar imágenes en el Image Plane

Cuando tengamos la imagen importada, veremos que se posiciona de fondo

para que podamos modelar el objeto a partir de ella.

Imagen de referencia importada

Si os fijáis, una lata es simétrica, por lo que utilizaremos una técnica basada

en NURBS. Para ello, crearemos solamente el perfil de la lata con una curva

y, a partir del mismo, haremos una revolución de la curva que generará la

geometría de la lata.

Crearemos el perfil de la lata con la herramienta de creación de curvas bezier

en Create > Curve Tools > Bezier Curve Tool.
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Creación de curvas

Para que el primer punto de la curva se nos ajuste directamente al grid, ac-

tivaremos el Snap grid. Después, lo deseleccionamos para poder modelar de

manera libre ajustándonos a la imagen de fondo que hemos importado en el

Image Plane.

Activar Snap Grid

Es muy importante que el inicio de la curva y el final terminen en el centro

vertical de coordenadas, eje Y, ya que el modelado rotará a partir de ese eje.

También es importante empezar el inicio de la curva desde la parte de abajo

hacia arriba. Una vez hayamos finalizado la curva, pulsamos la tecla Enter para

terminar la operación de creación.
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Resultado de la curva

Si hemos cometido algún error trazando la curva, podemos editarla al finalizar

situándonos encima de ella y pulsando botón derecho > Control Vertex. Apa-

recerán todos los puntos y los controladores de la curva para poder ajustarla.

Editar curvas con Control Vertex

Edición de puntos de la curva

Una vez depurada la curva, vamos a realizar la revolución que genere la geo-

metría a través de Surface > Revolve.
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Resultado de la revolución de la curva
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3. Generación de materiales y texturizado de modelos
3D

3.1. Propiedades de las superficies

Las superficies de los objetos tienen una serie de características conocidas y

otras no tanto por su nombre pero sí por su efecto; en este apartado analiza-

remos las cuestiones más relevantes que tenemos que tener en cuenta:

• Propiedades�básicas:

– Color: El color que vemos de los objetos.

– Especularidad: Es el brillo que tienen los metales, los vidrios, los cris-

tales y cualquier superficie pulida.

– Transparencia: Es la capacidad que tienen los objetos de dejar pasar

la luz.

– Reflejo: La capacidad de reflejar su entorno.

• Propiedades�en�materiales�PBR�(physically�based�rendering):�PBR es una

técnica muy utilizada en videojuegos por la que se intenta crear materiales

que sean realistas sin que consuman muchos recursos de la máquina por-

que está pensado para moverlos en tiempo real. Vamos a pasar a explicar

algunos conceptos que van a ayudar a entender el PBR.

1)�Energía�de�conservación.�Un objeto no puede reflejar más luz de la que re-

cibe. La luz que incide debe ser mayor o igual que la suma de sus componentes

difusa y especular. En otras palabras, si el material tiene mucha componente

difusa, será a costa de la componente especular, y viceversa. En la siguiente

imagen se puede apreciar que, cuanta más luz refleja (componente especular),

menos se ve el color base del material (componente difusa).

Energía de conservación

Fuente: www.marmoset.co

2)�Difusión�y�reflejo.�Cuando la luz incide sobre un material se divide, fun-

damentalmente, en dos componentes: una componente difusa y una compo-

nente especular (o reflexiva).

https://marmoset.co/
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Fuente: www.marmoset.co

La componente difusa es aquella que se introduce en la superficie y finalmente

sale reflejada fuera del material. Esta componente de la luz es la de proporcio-

nar lo que nosotros conocemos como color.

Componente difusa

Fuente: www.unrealengine.com

3)�Especularidad.�La componente especular es aquella que no penetra en el

objeto, es completamente reflejada por la superficie. Esta componente es la

que conocemos como reflejo.

Componente especular

Fuente: www.unrealengine.com

https://marmoset.co/
https://www.unrealengine.com/en-US/
https://www.unrealengine.com/en-US/
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4)�Albedo.�Este quizás sea el concepto más abstracto; define el color de la luz

difusa, es el color que emite un objeto sin tener en cuenta la iluminación.

Albedo

Fuente: www.marmoset.co

5)�Microsuperficie.�Define nivel de rugosidad de la superficie. Cuanto menos

rugoso sea, proporcionará un reflejo más puntual.

Microsuperficie

Fuente: www.marmoset.co

6)�Transparencia.�El material deja pasar la luz. Esta propiedad presenta diver-

sos grados y propiedades. En vidrios puros casi no existe dispersión de la luz.

Transparencia

https://marmoset.co/
https://marmoset.co/
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7)�Traslucidez.�Es una proyección de sombra (penumbra) debida a que el ob-

jeto bloquea parcialmente la luz. Por ejemplo, en vidrios esmerilados y algu-

nos plásticos. Presenta alta difusión y dispersión de la luz.

Traslucidez

8)�Reflexión.�El reflejo del entorno; vemos que el especular se suma a este

parámetro.

Reflexión

Fuente: https://www.arnoldrenderer.com/

9)�Frenel.�La reflectividad se presenta en un ángulo determinado. La reflexión

de la luz depende del ángulo de visión. En los bordes (el ángulo de visión es de

90º) se refleja el 100 % de la luz (por tanto, hay 0 % de componente difusa),

mientras que de frente ocurre lo contrario. En la siguiente imagen de la esfera

se puede ver ejemplificado.

https://www.arnoldrenderer.com/
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IOR

Fuente: www.marmoset.co

10)�Índice�de�refracción�(IOR).�Determina lo rápido que viaja la luz a través

de un material en relación con la velocidad de la luz en el vacío.

IOR

Bases de datos con valores
IOR reales

https://www.filmetrics.com/
refractive-index-database
https://pixelandpoly.com/
ior.html

https://marmoset.co/
https://www.filmetrics.com/refractive-index-database
https://www.filmetrics.com/refractive-index-database
https://pixelandpoly.com/ior.html
https://pixelandpoly.com/ior.html
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11)�Subsurface�scattering�(SSS).�SSS depende de la posición de la fuente de luz

y no del ángulo de la cámara. Sin embargo, como veíamos en el efecto fresnel,

ocurre lo contrario, afecta la incidencia de la luz en relación con el ángulo de

visión que tenemos sobre el objeto.

12)�Dieléctricos.�Reflejan la luz del color que emiten. Por ejemplo, un plástico

al que le incide luz blanca refleja luz de ese color.

13)�Metales.�En los conductores la luz que se refleja tiene un color distinto

al de la luz incidente.

3.2. Creación y configuración de materiales

3.2.1. Materiales estándar

• Lambert: No incluye efectos de brillo.
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• Blinn: Suele ser utilizado para generar superficies completamente metáli-

cas.

• Phong: Representa superficies brillantes y pulidas como mármoles o plás-

ticos.

• PhongE: Similar a Phong, pero con reflejos especulares más suaves.

• Anisotropic: Puede generar reflejos especulares en direcciones no iguales

a la superficie del objeto.

3.2.2. Hypershade

Es un área de trabajo que funciona a través de la conexión de nodos.

Se puede abrir en Windows > Rendering Editors > Hypershade.

También tiene un icono con un acceso directo en el menú (ver imagen).

1)�Conexiones

• Input connections: Muestra las conexiones de entrada que afectan a un

material.

• Input and output connections: Muestra las conexiones de entrada y de

salida que se encuentran en el material.

• Output connections: Muestra las conexiones de salida del material selec-

cionado.

• Work area: Muestra los nodos de un material para poder editarlos.

• Property editor: Modificar los parámetros y características del material.

• Material viewer: Visor previo de los cambios que se van realizando.
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2)�Herramientas

• Clear graph: Deja en blanco el área de trabajo.

• Add selected nodes to graph: Permite crear un contenedor para poder or-

ganizar.

• Remove selected nodes from graph: Elimina los contenedores selecciona-

dos.

• Rearrange graph: Organiza visualmente los nodos.

• Graph materials on selected objects: Despliega todas las conexiones del

objeto seleccionado.

• Hide attributes: Oculta todos los atributos del material.

• Show connected attributes: Muestra los atributos básicos del material.

• Show primary attributes: Muestra todos los atributos del material.

• Show attributes: Muestra todos los atributos, además de personalizar todos

los nodos posibles.

3)�Aplicar�material

• Seleccionamos el objeto.

• Mantenemos pulsado el botón derecho.

• Nos aparece una ventana flotante, seleccionamos Add New Material.

3.2.3. Atributos del Property Editor

Dentro del Attribute Editor tenemos varias pestañas en la parte superior; si nos

vamos a la última, será la del material en cuestión. También podemos pulsar

botón derecho encima del objeto seleccionado y pulsar en Material Attributes.

Tips

Si ya hemos creado un mate-
rial en el Hypershade, pode-
mos seleccionar Add Existing
Material.
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Las propiedades de cada material serán numéricas o con un slider controlador.

A la derecha aparece un cuadrado negro y blanco; si pulsamos accedemos a

los nodos.

Create Render Node
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La ventana nodos está compuesta por gran cantidad de elementos, desde ma-

teriales hasta efectos, texturas procedurales, etc. Cuando hemos realizado la

conexión de un nodo, aparece el icono de un cuadrado con un triángulo negro.

Parámetro conectado

Si queremos desconectar ese nodo tendremos que pulsar con el botón derecho

encima de las letras del parámetro que deseamos desconectar y seleccionar

Break Connection.

Break Connection

3.3. Materiales específicos en Arnold

3.3.1. Presets Arnold

El material por defecto de Arnold es aiStandardSurface; si pulsamos en el botón

Presets, accederemos a la galería de materiales predefinidos de Arnold.

3.3.2. AI Standard Surface

1) Base color: Es el color de material propiamente dicho.
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Base color

Fuente: www.arnoldrenderer.com

2) Diffuse Roughness: La rugosidad de la microsuperficie.

Diffuse Roughness

Fuente: www.arnoldrenderer.com

3) Specular: La especularidad del material.

Specular

Fuente: www.arnoldrenderer.com

4) Specular color: El color del especular. Hemos visto que los metales podían

tener especulares de colores distintos al de la fuente luminosa.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Specular Color

Fuente: www.arnoldrenderer.com

5) Specular Roughness: Rugosidad del especular.

Specular Roughness

Fuente: www.arnoldrenderer.com

6) IOR: Índice de refracción.

IOR

Fuente: www.arnoldrenderer.com

7) IOR Specular transmission

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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IOR

Fuente: www.arnoldrenderer.com

8) Specular Anisotropy: Refleja y transmite luz en ciertas direcciones.

Specular Anisotropy

Fuente: www.arnoldrenderer.com

9) Transmission: Transmisión de la luz.

Transmission

Fuente: www.arnoldrenderer.com

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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10) Transmission depth: Profundidad de la luz en la transmisión.

Transmission depth

Fuente: www.arnoldrenderer.com

11) Transmission Scatter: Depende de la densidad del material.

Transmission Scatter

Fuente: www.arnoldrenderer.com

3.4. Texturizado con imágenes bitmap

1) Seleccionar el nodo File.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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2) En Image Name, pulsar en la carpeta y seleccionar la imagen.

3) En las pestañas de arriba encontramos una llamada place2dTexture. En ella,

podemos repetir la textura las veces que deseemos en caso de que sea una

textura que lo permita. Esto suele utilizarse para suelos, paredes, etc.
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4) Si queremos que esta textura tenga una proyección especial, podemos apli-

carla en UV > Planar (para planos), UV > Cylindrical (para botellas, latas, etc.),

UV > Spherical (para pelotas, envolventes, etc.).

3.5. Texturas procedurales

Son texturas generadas mediante algoritmos matemáticos. Las genera el pro-

pio Maya; no son archivos externos, por lo que no requieren consumir mucha

memoria. Además, al ser matemáticas son infinitas, las podemos repetir las

veces que queramos.

Las podemos encontrar en la propia ventana de nodos y las podemos aplicar a

casi cualquier parámetro. En la imagen podemos ver varias como Bulge, Chec-

ker, Cloth, Fractal, Grid, Mountain, etc.
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3.6. Generación y edición de texturas

1)�Programas�de�edición�de�imagen.�Podemos utilizar cualquier programa

de edición de imagen para crear nuestras propias texturas, ya sean logotipos o

imágenes de alguna superficie que queremos proyectar sobre un objeto como

madera, tierra, etc.

2)�Multiplicados.�Para aportar más realismo, se pueden utilizar varias textu-

ras premultiplicadas entre sí para crear cierta suciedad y que no parezcan tan

sintéticas.
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3)�Reloaded.�Cuando hacemos una modificación en las texturas, hay veces

en las que es necesario pulsar el botón de Reloaded para que se refresque en

el objeto.

3.7. Proyección y configuración de mapas UV

3.7.1. Coordenadas UV

Son coordenadas paramétricas normalizadas en dos dimensiones entre los va-

lores 0 y 1. Su gran beneficio es que se puede modificar la resolución de la

textura sin cambiar la proyección. Para optimizar el rendimiento del equipo es

recomendable que las texturas sean cuadradas (128x128, 256x256, 512x512,

1024x1024, 2048x2048, etc.).

Para entender en qué consiste, vamos a ver un par de ejemplos:

Como veis, un cubo realmente serían seis cuadrados proyectados en forma de

cruz.

Otro ejemplo más elaborado, pero muy didáctico, es el del papel envolvente

de una figura de chocolate. Como se puede observar, una superficie en dos

dimensiones ha sido proyectada en un objeto en tres dimensiones.
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Textura UV desplegada
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Textura UV proyectada

3.7.2. UV Editor

El UV Editor es la herramienta donde se prepara la proyección de la textura. Se

puede acceder a través de Windows > Modeling Editors > UV Editors. También

en el menú UV.

Menú UV
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UV Editor

En el UV editor podemos crear proyecciones:

Proyecciones UV Editor

Una vez tenemos una imagen aplicada, por ejemplo a color, podemos ver la

proyección en el UV Editor; podremos seleccionar faces, vertex, UV, y moverlos

para ver cómo se modifican en el objeto 3D. Además, podremos desplegar

geometrías en el UV Editor, exportarlas a otro software de edición de imagen

para pintar conociendo ya la proyección correcta.

Desplegar una geometría
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Cortar faces

Movimiento de vértices en UV Editor

Save Snapshot

3.8. Bump map, displacement map y normal map

Generar geometrías rugosas como la piel humana sería imposible en un pro-

grama 3D, ya que el consumo de procesador dejaría colapsado el equipo. Para

solucionar la simulación de este tipo de superficies rugosas se utilizan texturas

bump map.

Un height map es una textura blanca y negra; cuanto más blanco sea el color

del píxel, más alto aparecerá.
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Un normal map es una textura RGB, donde cada píxel representa la diferencia

en dirección de luz que la superficie. Estas texturas tienden a tener un color

morado-azul, debido a la manera en que el vector es almacenado en valores

RGB.

Bump map aplicado a texturas

3.8.1. Normal

Son un vector perpendicular a un polígono (o a un vértice) que sirve para

indicarnos la orientación de la cara. En la imagen de arriba se compara cómo

sería la geometría y abajo cómo funciona el normal map.

Si queremos ver cómo son las normales de nuestros objetos, podemos hacerlo

en

Display > Polygons > Face Normals.
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Las opciones que nos proporcionan las normales son:

• Average: Promedio.

• Conform: Unifica la dirección.

• Set to face: Vertex to face dirección.

• Set Vertex Normal: posición vertex normals.

• Harden/Soften edge: endurece la normal y la apariencia.

• Lock/Unlock normals: Bloquea normales.

Normales de la geometría

Sin embargo, aunque tengamos una geometría muy poligonal, podemos apli-

carle un mapa de normale; podemos hacerlo en cualquier material estándar

de Maya en el apartado Bump Mapping. Si lo deseamos aplicar a un material

Arnold, está en la sección del material llamada Geometry > Bump Mapping.

En la imagen vemos a la izquierda la textura del normal map y a la derecha

aplicado al cubo; el resultado es un cubo que tiene una apariencia de piedra

casi real.
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3.9. Práctica III: Materiales con texturas bitmap, proyecciones y

repeticiones

En esta práctica vamos a crear un material con textura de madera para la mesa

que hemos modelado en la práctica I.

En primer lugar, abrimos la escena Mesa_01.mb y seleccionamos la mesa. Ten-

dremos que crear o fotografiar una textura de madera; la mejor opción es bus-

car imágenes tile en una galería. Esto significa que la imagen se puede repetir

sin que se perciba un salto entre los empalmes de una imagen con otra. Las

piezas tienen formas muy distintas, por lo que deberemos utilizar materiales

distintos para cada una de las piezas, ya que en las cuadradas la repetición de

la imagen será uniforme y en las alargadas se distribuirán más repeticiones en

uno de los ejes.

Pulsando el botón derecho del ratón encima de la tabla superior se abre una

ventana flotante de opciones; seleccionamos Assign New Material para crear

un nuevo material para la mesa. Lo llamaremos Mat_tableroSuperior.

Aplicar material
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En el parámetro Color conectaremos el nodo File y pulsaremos en la carpeta

para añadir la textura de madera que deseamos.

Nodos

Para no consumir mucha memoria, las texturas suelen ser pequeñas con po-

sibilidad de ser repetidas como si fuesen un patrón pero sin que se noten las

costuras. Para editar esas repeticiones, vamos a la textura en su nodo File y

entramos en la pestaña superior place2dTexture.

Textura de madera
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Pestaña place2dTexture

Como vemos en la imagen anterior, se ha repetido treinta veces en U y dos

veces en V, debido a que, si no, se verían muchas repeticiones en el canto del

tablero.

Proyección de la textura sobre el tablero

Para las patas generamos otro material de la misma manera y lo llamamos

Mat_patas. Esta vez las repeticiones serán 4 y 30 respectivamente.
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Proyección de la textura sobre patas

Como hemos visto, podemos editar parámetros de esa repetición como la ro-

tación, el ruido, etc. Todo ello ayuda a romper el patrón visual, ya que el ojo

humano es capaz de detectarlo rápidamente y lo interpreta como irreal.

Ahora vamos a abrir el Hypershade para ver cómo están conectados los nodos

que hemos creado. Seleccionando el objeto y pulsando botón derecho dentro

del Work Area > Graph Materials on Viewport Selection, podemos cargar todos

sus nodos en el visor para que nos hagamos una idea de cómo se conectan y

en qué orden.

Ventana Hypershade
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3.10. Práctica IV: Materiales metálicos. Aplicación de texturas

bitmap

En esta práctica vamos a crear un material con textura metálica en el que se

va a proyectar una textura con canal alfa.

En primer lugar, abrimos la escena Lata_01.mb y seleccionamos la lata de re-

fresco. Pulsando el botón derecho del ratón encima del objeto se abre una

ventana flotante de opciones, y seleccionamos Assign New Material para crear

un nuevo material para la lata de refresco.

Aplicar un material nuevo

A su vez, se nos abre otra ventana flotante con todos los materiales que po-

demos aplicar al objeto. Deseamos aplicar un material metálico, así que selec-

cionamos Arnold > Shader > aiStardardSurface.

Aplicar el material estándar de Arnold

Vamos a utilizar una configuración por defecto, así que pulsamos en Presets y

se nos despliega una lista de opciones de materiales. Seleccionamos Chrome.
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Presets de materiales Arnold

Si analizamos el Attribute Editor podemos ver que tenemos todas las opciones

de configuración del material. Cambiaremos el color para ver cómo afecta.

Después vamos a aplicar una textura a la lata. Para ello, debemos aplicar en el

color un nodo de capas llamado Layered Texture.
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Layered Texture

Pulsando en el hueco de Layered Texture Attributes creamos nuevas capas.

Vamos a crear una con un color sólido y otra a la que le conectaremos una

textura; esta última se pondrá en el Blend Mode en Add.

Creación de capas
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Para aplicar una textura en bitmap pulsamos en el cuadrado blanco y negro del

parámetro color y le conectamos el nodo File. Pulsando en la carpeta podremos

importar la textura que queramos; si creamos un texto en formato PNG con

canal alfa, podremos superponerlo al color de fondo de la lata.

Importar imagen

Ahora tenemos que proyectar la textura del logotipo que hemos importado.

Hay que tener en cuenta que, para hacer una edición de la proyección, tene-

mos que convertir el objeto NURBS a Polygon en Modify > Convert > NURBS

to Polygons. Después abrimos la ventana de edición de los parámetros UV de

los objetos en Windows > Modelling Editors > UV Editor. La lata tiene forma

de cilindro; por lo tanto, deberemos realizar una proyección con esa forma en

la ventana UV Editor, Create > Cylindrical.
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Proyección de textura

Para aplicar el canal alfa de la textura iremos al Hypershade. Allí conectaremos

el Out Alpha de la textura (logo.png) al canal alfa del nodo layeredTexture2.

Nodos del Hypershade

El resultado será una lata de color con el logotipo que hayamos creado.
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Textura aplicada
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4. Configuración de sistemas de iluminación 3D

4.1. Tipos de luces en Autodesk Maya

Cada motor de render tendrá sus propias luces, ya que optimizan el proceso de

cálculo obteniendo mejores resultados. En este caso, primero vamos a repasar

primero las luces estándar que tiene Maya por defecto, y después analizaremos

las luces que pertenecen al motor de render Arnold.

4.1.1. Luces estándar

1) Area Light: son luces rectangulares especiales para simular reflejos rectan-

gulares como las cajas de luz utilizadas en fotografía. Son recomendadas para

imágenes fijas, pero no para animaciones.

Area Light

Fuente: www.autodesk.com

2) Directional Light: utilizadas para simular fuentes de luz puntuales que se

encuentran lejanas, como el sol, donde los rayos de luz son paralelos entre sí.

https://www.autodesk.com/
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Directional Light

Fuente: www.autodesk.com

3) Spot Light: se proyecta un cono de luz uniforme y direccional. La apertu-

ra de ese cono de luz puede ser regulada, así como la dureza o suavidad del

contorno del mismo.

Spot Light

Fuente: www.autodesk.com

4) Point Light: la luz se emite uniformemente de manera omnidireccional. Es

similar a la luz que emite una bombilla.

https://www.autodesk.com/
https://www.autodesk.com/
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Point Light

Fuente: www.autodesk.com

5) Ambient Light: esta luz es ambivalente; por un lado, se transmite de manera

uniforme en todas las direcciones desde la fuente y, por otro, también desde

las superficies.

Ambient Light

Fuente: www.autodesk.com

6) Volume Light: ilumina los elementos que se encuentran dentro de la luz.

Suele utilizarse para atenuar sombras.

https://www.autodesk.com/
https://www.autodesk.com/
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Volume Light

Fuente: www.autodesk.com

4.2. Clasificación y configuración de luces en Arnold

Las luces de Arnold son especiales para optimizar el cálculo de render que rea-

liza Arnold, aunque se pueden utilizar otro tipo de luces. Las luces de Arnold

se pueden localizar en Rendering (Menu Set) > Arnold > Lights.

Luces de Arnold

A continuación, se muestra gráficamente cómo afecta cada uno de los tipos de

luces a los objetos, además de cómo son los iconos gráficamente en las vistas.

Tips

La Ambiental Light y Volume
Light de las luces clásicas de
Maya no son compatibles con
Arnold render.

https://www.autodesk.com/
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Forma y efecto de las luces Arnold

Fuente: www.arnoldrenderer.com

Pasamos a describir y analizar cómo son y cómo afectan cada uno del tipo de

luces de Arnold:

1)Area�Light: Es una fuente de luz que imita la caja de luz. Se puede cambiar

la forma, en Light Shape, de rectangular, circular o cilíndrica.

Forma de la luz

Fuente: www.arnoldrenderer.com

2)Skydome�Light: Simula la luz de exteriores, la luz del cielo. Es una luz difusa

y suave que proporciona sombras también suaves.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Efecto Skydome Light

Fuente: www.arnoldrenderer.com

3)Mesh�Light: La propia malla se convierte en luz. Puede que sea necesario

subir las Subdivisions para obtener detalle en los reflejos. Para aplicarla, pri-

mero hay que seleccionar la geometría y después seleccionar la luz en Rende-

ring (Menu Set) > Arnold > Lights > Mesh Light.

Mesh Light

Fuente: www.arnoldrenderer.com

4)Photometric�Light: Son luces que utilizan patrones establecidos como los

perfiles IES que proporcionan información de intensidad y difusión. En la si-

guiente imagen se pueden ver cómo funcionan distintos perfiles IES.

Tips

Hay que tener en cuenta que
no funciona con NURBS.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Efectos de AES Lights

Fuente: www.arnoldrenderer.com

5)Light�Portal: Son luces que se sitúan en las ventanas o en los huecos por

donde entra la luz. Este tipo de luz se aplica para reducir el ruido que pueda

existir en la imagen.

Light Portal

Fuente: www.arnoldrenderer.com

4.2.1. Exposure

La exposición es un valor relacionado con el número de pasos de la fotografía

(f-stop). Si sube la exposición en 1 la cantidad de luz es el doble; por lo tanto,

no tiene un crecimiento lineal sino exponencial. Por otro lado, hay que tener

en cuenta que la intensidad del brillo se multiplica por el color.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Efecto de Exposure

Fuente: www.arnoldrenderer.com

4.2.2. Samples

Los samples controlan la calidad de la imagen y el render final. Al aumentar los

samples se reduce el nivel de ruido en la imagen, especialmente en las sombras.

Luz en Arnold

Fuente: www.arnoldrenderer.com

A continuación, se muestran dos ejemplos: en el de la derecha existe un valor

de Sample de 1 y el de la izquierda de 4. Los materiales que están en la parte

inferior tienen aplicada una rugosidad creciente en el especular del material;

se aprecia que, a mayor cantidad de Samples, menor ruido.

Ejemplo con diferentes Samples

Fuente: www.arnoldrenderer.com

Tips

La fórmula para calcular sería
Exposure: color * intensity *
2exposure

Por ejemplo, intensidad=1, ex-
posure=2 es lo mismo que in-
tensidad=4, exposure=0, ya
que 1*1*22 = 4 y 1*4*20 = 4.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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4.2.3. Temperatura de color

Determina la dominante de color de la luz y se mide en grados Kelvin. Según

la CIE (Commission Internationale de l'Eclairage), los 6.500 K determinan el

blanco neutro; por debajo de ese valor la luz tendrá una dominante anaranjada

y por encima azulada.

Temperatura de color

Fuente: www.arnoldrenderer.com

4.2.4. Decay type

Establece el decaimiento de la luz en relación con el espacio; concretamente,

la ley de la inversa del cuadrado. Esta ley es aplicada en ámbitos como la pro-

pagación de la luz y del sonido y hace referencia a que la intensidad disminu-

ye de forma inversamente proporcional al cuadrado de la distancia desde la

fuente al sujeto. Las luces en Arnold ofrecen la oportunidad de configurar la

aplicación de este decaimiento, o bien de desactivarlo y que la propagación

de la luz sea constante.

Decaimiento de la luz

Fuente: www.arnoldrenderer.com

4.2.5. Cast Shadows

Las luces de Arnold, al igual que las luces clásicas de Maya, permiten aplicar

proyectar sombras desde las fuentes de luz.

Tips

Se debe tener en cuenta que
la temperatura de color puede
variar el color de todos los ele-
mentos de la escena, así como
de reflejos, especulares, etc.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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Sombras

Fuente: www.arnoldrenderer.com

4.2.6. Shadow density

La densidad de estas sombras puede ser configurada, siendo 1 el valor por

defecto con la sombra totalmente opaca.

Densidad de la sombra

Fuente: www.arnoldrenderer.com

Tips

Por otro lado, tenemos que tener en cuenta que no podremos visualizar en el render
las imágenes iluminadas con luces Arnold si no está cargado correctamente. Para ello,
deberemos ir a Window > Settings/Preferences > Plug-in Manager y confirmar que está
seleccionado Loaded y Auto load.

4.3. Tipos de sombras

• Cast Shadows: Son sombras arrojadas por los objetos en los que incide la

luz.

• Shadow Color: Define el color de la sombra.

• Shadow Density: Densidad de la sombra.

• Volume Samples: La calidad de la sombra; cuanto mayor sea, más calidad,

pero más tiempo tarda en procesar.

https://www.arnoldrenderer.com/
https://www.arnoldrenderer.com/
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4.4. Configuración de sets de iluminación en interiores y estudio

en Arnold

Cuando iluminamos personajes, es necesario tener al menos tres puntos de

luz:

• 1 Luz principal.

• 1 Luz de relleno. Puede estar a unos 90 grados de la luz principal.

• 1 Luz de contra, que se pone detrás del sujeto.

También es habitual jugar con diferentes temperaturas de color para propor-

cionar más contraste al personaje y resalte del fondo.

Cuando son escenas de interior que tienen ventanas por las que entra luz,

hay que recordar situar en las mismas Portal Light para eliminar el ruido que

produce el Skydome Light.

Tips

Dos herramientas muy útiles para visualizar y configurar todas las luces de la escena son
el Light Manager de Arnold, al que se accede a través de Rendering (Menu Set) > Arnold
> Utilities > Light Manager. Y el Light Editor de todas las luces, no importa del motor que
sean, de Maya en Windows > Rendering Editors > Light Editor.

Light Manager

Light Editor

4.5. Configuración de sets de iluminación en exteriores en

Arnold

La luz más habitual es Skydome Light, aunque hay que utilizar luces puntuales

para focalizar la atención del espectador, ya que la luz del Skydome Light es

muy difusa y no generará los contrastes necesarios para enriquecer la escena

visualmente. Las luces que están lejanas tienden a aplanar, mientras que las

cercanas aportan contraste.
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Tips

Muchas veces, cuando trabajamos en exteriores, también es necesario que algunas luces
solo afecten a ciertos objetos, ya que si no se pueden sobreexponer. Para ello, es necesario
utilizar el Relationship Editor que se puede encontrar en Windows > Relationship Editors
> Light Linking > Light-Centric. En esta ventana nos aparecen las luces a la izquierda y
los objetos a la derecha; si seleccionamos una luz y deseleccionamos algún objeto a la
derecha, este no se verá afectado por esa luz.

Relationship Editor

4.6. Configuración avanzada de sets de iluminación. Efectos de

iluminación

4.6.1. Sombras volumétricas

Arnold Render settings > Arnold Renderer > Environment > Atmosphere field.

En estas opciones del Render Settings se pueden crear luces volumétricas y

niebla (fog).
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Atmosphere

4.6.2. Gobo

Es un filtro de iluminación muy utilizado en cine y teatro. Consiste en colocar

una textura delante de la fuente de luz para proyectar un juego de luces y

sombras.

Gobo

Fuente: www.arnoldrenderer.com

El proceso consistiría en:

• Crear una Spot Light.

• Acceder al spotLightShape > Arnold > Light Filters …. > Add > Gobo.

• Filter Mode > Mix.

• Density a 1.

• Slide Map conectar a la textura deseada.

• Rotar y escalar como deseemos.

https://www.arnoldrenderer.com/
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4.7. Práctica V: Iluminación de escena con varios objetos

Para hacer esta práctica vamos a cargar la escena de la Mesa_01.mb y vamos

a importar la de la Lata.mb en File > Import.

Importar archivos .mb

Puede que exista una diferencia de escala entre los objetos de las escenas; si

es nuestro caso, elegimos la escala que nos interese y adaptamos el tamaño de

todos los objetos. El objetivo es situar la lata de refresco encima de la mesa.

Diferentes escalas entre objetos

Después vamos a crear las luces de la escena; las podemos encontrar en Arnold

> Lights.
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Luces de Arnold

En primer lugar, pondremos un Skydome Light de relleno y le bajaremos el

valor de Intensity. Posteriormente, crearemos dos Area Lights, una en la parte

frontal y otra detrás. Además, crearemos una cámara nueva para ajustar el

encuadre y así poder movernos para trabajar la cámara por defecto que tiene

el proyecto, Persp.

Elementos de la escena

Para visualizar un previo de la imagen y ver cómo están actuando las luces,

pulsamos en el icono de la claqueta.

Icono claqueta

Iremos ajustando el parámetro Intensity de las luces y su posición dentro de

la escena hasta conseguir el resultado que deseamos.
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Imagen final 
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5. Técnicas de render 3D

El render es el cálculo final que realiza el procesador aplicando la configuración

de luces, materiales, texturas, geometrías, sampling, etc. El tiempo requerido

para cumplir estos procesos de render pueden variar dependiendo de multitud

de factores; por ese motivo, es necesario optimizar las escenas y utilizar equipos

que cumplan los requisitos del software.

Los motores de render aportan la optimización y la calidad a la imagen final;

existen motores de render con los que no se obtienen imágenes con mucha

calidad, sino que lo que se busca son calidades que, aunque sean más sintéti-

cas, sean capaces de realizar los cálculos de manera rápida. Sin embargo, hay

otros motores de render que lo que buscan es conseguir imágenes hiperrealistas

sacrificando los tiempos de procesamiento.

5.1. Tipos de render en Autodesk Maya

1)�Arnold. Es un motor de render creado por la compañía Solid Angle e im-

plementado en Autodesk Maya. Arnold es un motor fotorrealista de muy fácil

uso que consume pocos recursos del equipo; realmente consigue resultados

espléndidos en cortos tiempos de proceso.

Arnold render

Fuente: www.solidangle.com

2)�Mental�Ray. Fue el motor de render que tenía Maya para crear las imágenes

de más calidad; hasta 2016 estuvo implementado en el software. En posterio-

res versiones fue sustituido por Arnold, ya que este último ofrece mejores re-

sultados utilizando menores tiempos de cálculo, además de ser mucho más

sencilla su configuración.

http://www.solidangle.com/
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3)�Maya�Software. Es uno de los motores de render implementados en Maya.

Aunque no es capaz de renderizar con la calidad de Arnold, es muy utilizado

para renderizado de sistemas de partículas y Paint Effect.

Paint Effect Maya

4)�Maya�Hardware�2.0. Es otro motor de render integrado en Maya que tiene

varias limitaciones de calidad, además de no permitir el renderizado parcial de

regiones de la escena, de capas o el canal de profundidad (z-depth).

5)�VRay. Es un motor de render de alta calidad de la compañía Chaos Group.

Ofrece la posibilidad de crear imágenes hiperrealistas, aunque es necesario de-

dicar gran tiempo a la configuración de cámaras y luces, ya que posee una

cantidad enorme de parámetros configurables.

Imagen renderizada con VRay

Fuente: www.chaosgroup.com

https://www.chaosgroup.com/es
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5.2. Configuración de Arnold Render

En primer lugar, hay que recordar que debemos configurar Rendering (Menu

Set) > Render > Render Settings > Render Using > Arnold Renderer.

Selección de Arnold Render

En la primera pestaña tenemos Common; ahí encontraremos datos como:

• La ruta de salida de los archivos generados por el render.

• El formato de los archivos.

• El tamaño de la ventana.

• Los frames que se renderizarán.

• El espacio de color.

En la pestaña Arnold Renderer tenemos:

• Configuración del Sampling.

• Ray Depth; como su nombre indica, representa la profundidad. No se deben

configurar valores demasiado mayores a los indicados.
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Depth Rays

Fuente: www.chaosgroup.com

• Atmosphere: para crear volúmenes en la luz como Fog (niebla).

• Motion Blur: genera un desenfoque de movimiento en los objetos anima-

dos para que no parpadeen durante la animación.

• Lights-Settings: se puede configurar que Arnold omita la evaluación de los

valores que estén por debajo del umbral configurado.

• Textures: para habilitar el proceso de transformación de texturas al forma-

to TX, nativo para Arnold (mejora el rendimiento de cálculo).

• En la pestaña AOVs se configurarán las capas y canales para configurar el

render por passes.

5.3. Render sequence y batch render

1)�Render�Sequence: Rendering (Menu Set) > Render > Render Sequence

Tips

Se recomienda no sobrepasar
los valores de sampling Camera
(AA) 4, Diffuse 3, Specular 3,
ya que consumiría demasiados
recursos.

• Render Layer > Create New Layer.

• Dentro del nuevo layer que hemos creado: Botón derecho > Create Collec-

tion.

• Se nos abre a la derecha todas las opciones de collection.

• Entonces seleccionamos en el visor de Maya (o el outliner) todos los obje-

tos, luces, cámaras que deseamos renderizar y pulsamos Add en la ventana

collection del render layer.

• Para renderizar: Render > Render Sequence.

2)�Batch�Render: Rendering (Menu Set) > Render > Batch Render

Tips

De esta forma, no aparecerá
la marca de agua de Arnold al
renderizar, aunque hay que te-
ner en cuenta que no se podrá
utilizar el equipo mientras esté
procesando.

https://www.chaosgroup.com/es
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Con este tipo de render le damos la orden de renderizar a Maya, pero podemos

seguir trabajando en el proyecto. El gran inconveniente sucede con Arnold, ya

que si renderizamos de esta manera aparecerá la marca de agua en las imágenes

resultantes.

5.4. Render layers. Renderizado por passes

5.4.1. Arbitrary Output Variable (AOV)

AOVs

Fuente: www.chaosgroup.com

La forma de poder renderizar por passes separados es a través del Render Set-

tings > AOVs.

AOVs

https://www.chaosgroup.com/es
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En la ventana AOVs podemos seleccionar los passes y añadirlos para hacerlos

activos (a la derecha de la ventana); entonces se nos añadirán abajo, donde

podremos nombrarlos, decir qué canales nos interesan, etc. En la siguiente

imagen se muestra cómo se ha renderizado el passe de diffuse directo e indirecto

para después fusionarlos en composición (a la derecha).

AOVs

Fuente: www.chaosgroup.com

Los passes más habituales son los de color, diffuse, specular, reflection, el de pro-

fundidad (z-depth), incluso de las luces por separado. Las posibilidades son in-

finitas, todo depende de las pretensiones que tengamos y de nuestra capacidad

para ver la aplicación de esas capas por separado.

5.4.2. zdepth

Fuente: www.chaosgroup.com

5.5. Composición imagen en 3D

El tener todos los archivos por separado (cada una de las luces, color, reflejo,

especular, profundidad, etc.) proporciona un poder tremendo al compositor

de imagen, ya que puede ofrecer diferentes soluciones gráficas al director crea-

tivo. Las propuestas de modificación en casi todas las opciones serían sobre

los archivos ya renderizados, lo que reduciría drásticamente el tiempo de pro-

ducción, ofreciendo respuestas visuales rápidas, lo cual facilita la toma de de-

cisiones.

https://www.chaosgroup.com/es
https://www.chaosgroup.com/es
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Imágenes por passes

Composición de capas 3D

Fuente: www.foundry.com

5.6. Práctica VI: Renderizado

En esta práctica vamos a renderizar la escena que hemos creado. En primer

lugar, abriremos la ventana de configuración de las opciones de render que se

encuentra en el icono representado con una claqueta con un engranaje.

http://www.foundry.com/
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Render Settings

En la ventana Render Settings tenemos que ajustar la ruta donde deseamos

que se deje el archivo, nombre, formato, extensión, si queremos renderizar

un único frame o una secuencia, la cámara de la que se realizará el proceso, el

formato de pantalla, etc. Tened en cuenta que si la ruta que aparece en Paths

no es correcta, se la podréis indicar vosotros en File > Set Project.
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Ventana Render Settings

Para finalizar, renderizamos la imagen que hemos configurado dentro de las

opciones del Render Settings en Render > Batch Render. El software empezará

a hacer el cálculo de ese render, pero podremos seguir trabajando, no como

ocurre en otros softwares en los que la aplicación se queda bloqueada reali-

zando el cálculo.
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Imagen final
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