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Introduction

Unlike Microsoft Office, the OpenOffice.org program has an excellent tool for
creating vector drawings and editing graphics called Open Draw. This program
is halfway between poorer programs like Paint and top-of-the-range applica-
tions like GIMP and Photoshop. Open Draw is easy to use and offers users
several advanced features. In this introductory section, we will describe its key
features, which include:

¢ Creation and formatting of a wide range of objects. Open Draw offers
the possibility of working with and formatting 2D and 3D graphics, lines,
text etc.

¢ Integration with other applications. Open Draw's drawing features and
utilities can also be accessed from Open Writer, Open Calc and Open Im-
press, allowing us to use them directly in any OpenOffice.org document.

¢ Full text formatting. Just as the drawing tools are available in other com-
ponents of OpenOffice.org, most of the features of Open Writer can be
accessed from Open Draw. This means that we can use styles with the ob-

jects, lines and texts that we create.

¢ The FontWork utility We can use this to create stunning text effects, such
as curves and distortion.

e Inserting files, OLE objects and graphics. We can insert a wide range
of file formats in Open Draw, as well as OLE objects such as charts and
spreadsheets.

¢ File formats. Besides being able to import and export many graphics for-
mats, we can also export Open Draw and Open Impress documents to
HTML format. We can also export to the EPS and SVG formats, the latter
being an XML-based scalable vector graphics format.

¢ Creating basic objects If we don't want to complicate matters and just
want to do simple drawing operations, the standard polygons are very easy
to use.

e Special effects. Special effects and filters can be applied to graphics created
with the program.
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¢ Colour. We can control all aspects of colour and apply different conver-
sions, such as greyscale or black and white. Certain colours in an image
can also be swapped for others.

The main aims of this unit are:

1) to familiarise students with the use of the key drawing functions of Open

Draw by creating a sample document, and

2) todescribe the process of creating and formatting the most common draw-
ing objects.
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1. Basic use of the program

Open Draw can be launched from any OpenOffice.org application by selecting

the File -> New -> Drawing menu option.

Tips can be very useful for learning about the different features of the program.
Tips are displayed for each of the labels and buttons on the screen. You can

enable or disable this option using the Help -> Tips menu option.
1.1. The working environment

As with the other applications, if you need help with a dialog box or window,
you can always click on the Help button or press F1.

Figure 1. The Open Draw working environment
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We will now describe the diverse elements in the program's workspace:

¢ The Menu bar contains the various actions that can be carried out globally
across the OpenOffice.org program and those that are specific to Open
Draw.
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¢ The Function bar indicates the full path of the file being edited and pro-
vides a shortcut to the program's global features.

e The Object bar is used to control object attributes. When we work with
different objects, the Object bar will change to display the attributes of
the selected object. For example, if we are using text tools, the Object bar
will display the text formatting tools.

¢ The horizontal and vertical rulers indicate the dimensions of the page
and the objects on it. The units of measurement units of these rulers can

be changed very quickly by right-clicking on them.

¢ The Main toolbar, positioned vertically down the left-hand side of the
document, gives users quick access to the most common functions. It can
be used to create and align objects, insert new objects and much more. To
display all of the features of the buttons on this bar with submenus, hold
down the mouse button as you click on them.

¢ The Options bar can be used for accurate customising of the position of
text, lines and objects in the drawing, as well as some more advanced

options.

¢ The Color bar is used to select the colour of an object as you would with
the Object bar but is more intuitive and much quicker.

e The Status bar, located at the bottom of the screen has a number of func-
tions, which include displaying page numbers, applying page styles (by
right-clicking on Standard), changing the zoompercentage and changing
the default type of text selection.

We have just described the Open Draw workspace but the program has a sec-
ond workspace for working with graphics. In this workspace, the Object bar
can be used to make a number of changes to an image, such as adjusting

colours, converting it to black and white or rotating it.
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Figure 2. The Open Draw working environment for images
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If you click on the magic wand button to the left of the Object bar, you will
access the program filters that can be applied to the image you are editing.
Another very useful Open Draw tool is the eyedropper, which can be used to
replace a colour in an image with another of your choice. To use this feature,
select the Tools -> Eyedropper main menu option.

Figure 3. Eyedropper dialog box
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Once inside the Eyedropper dialog box, click on the Eyedropper button in the
top left of the dialog box, then click on the first colour you wish to replace and
enter the tolerance in this same dialog box. It is best to play it safe by starting
with a tolerance of 10% and working your way up if the results are not to your
satisfaction. In the Replace with field, select the colour you want to replace the
original one with. Finally, click on the Replace button to change the colour.

1.2. Creating a sample drawing

We will now create a sample drawing to discover the basic features of the
program and familiarise ourselves with its workspace. Follow the steps below
closely for this:

1) Launch OpenOffice.org and create a new drawing document by selecting
the File -> New -> Drawing option from the main menu. This will open a new
window with a blank drawing document.

2) In the program's status bar, double-click on the value indicated as the per-
centage of zoom. This will bring up the document scaling settings dialog box.
Enter a Variable scale of 90% here.

Figure 4. Document scaling settings dialog box
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3) Click on the Rectangle button on the Main toolbar and hold down the
mouse button until the Rectangles bar appears. Click on the filled rectangle,
which is the normal Rectangle button. Draw a rectangle in the new document.

4) In the Object bar, change the colour of the border using the Line Color
drop-down menu. Use any colour for the new border.
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5) Return to the Object bar and select the Gradient option from the Area Style/
Filling drop-down menu and then select a gradient from the list of gradients
in the Area Style/Filling field.

6) Go to the program ruler and right-click on it. Make sure that the unit of

measurement is centimetres. If not, change it.

7) If the rectangle is not selected, do so and select the Edit -> Duplicate main
menu option. Make a copy of the rectangle and place it 5 centimetres to the

left of the original.

Figure 5. Object duplicate dialog box
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The main features of this dialog box are as follows:

e The Number of copies field is used to enter the exact number of copies

we wish to make.

e The Placement section allows us to indicate where we want to create the

new copy, defined as the distance from the top left of the original object.

¢ In the Enlargementsection, we can enter the enlargement factor to apply

to each subsequent copy.

e In the Colorssection, we can choose a start and end colour so that the
colour of the objects gradually changes from the first to the second.
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e  When we click on the Values from Selection button,the attributes of the
current object will be automatically entered in the dialog box fields.

8) Select one of the two rectangles you have created and right-click on it. In the
context menu, select the Position and Size option. In this dialog box, go to the
Position and Size tab and increase the size of the rectangle by 10%. Then go to

the Rotation tab and rotate the rectangle 45° on its bottom left-hand corner.

Figure 6. Rotation tab in the Position and Size dialog box
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9) Enable the Stylist by pressing F11 or selecting the Format -> Stylist menu
option. Select a rectangle and double-click on the Object without fill format.
The rectangle will change to the new style.
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Figure 7. Stylist showing the graphics styles
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10) In the Main toolbar, press the Connector button and connect the left-hand
side of the first rectangle to the right-hand side of the second one.

11) We will now convert one of the two rectangles into a 3D rotational object.
To do this, right-click on the rectangle and select the Convert option from the
context menu, followed by To 3D rotation object.

12) We will now enter some text. Do not select anything and go to the Main
toolbar and click on the Text button. Click on the workspace and enter the
following text: "This is a text test". The text frame will grow to fit the text
inside it. To spread the text over more than one line, select it and right-click
to bring up the context menu. Choose the Text option from this menu and

unmark the Fit width to text option.



GNUFDL e PID_00148481 14 Open Draw. Drawing with OpenOffice.org

Figure 8. Text frame properties dialog box
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13) Click again on the Text button of the Main toolbar and create a text frame
in the document approximately 3 centimetres high by 5 centimetres across.
Position the cursor inside it and type: "We will now see how this text frame
behaves with line wrapping". When you drew the new text frame, the frame

was set at the specified horizontal measurement but automatically grows to
accommodate the new lines of text.

14) Select the text you have just typed, right-click on it and choose the Char-
acter option from the context menu. You can also access this dialog box from
the Format -> Character main menu option. In this dialog box, select the Con-
ga font, size 12 points and colour blue.
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Figure 9. Character properties dialog box
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15) We will now look at how to change the text using the Object bar. In this
bar, change the font to Bitstream Vera Sans size 23 points and colour red.
Right-click the text frame and select the FontWork option. Curve the selected
text using any button and then close the dialog box.

Figure 10. Fontwork dialog box
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The top part of the window contains the buttons for curving text horizontally,
vertically and in a circle. If you cannot see all of the available buttons, use the
vertical scroll bar.
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The second row of buttons is used to align the text at all of the angles shown.
The third row of buttons can be used to select the direction of the text.

Other options in this tool are:

e The Orientation button, used to rotate the text horizontally to vertically

and vice versa

e The Distancefield, used to enter the distance between the text and the

line of curvature, if there is one.

¢ The Indentfield. If you chose to align the text to the left or right, you can
enter the distance from the end of the text to the corresponding end of
the line of the curve or object.

¢ The Contour button, used to indicate whether to display the contour line
next to the text.

¢ The Text Contourbutton, used to give the selected text a contour.

e The Shadow style buttons are used to turn shadows on or off. We can
indicate the distance between the shadow and the text in these fields. We
can also select the colour of the shadow in the Shadow Color list.

16) Double-click the rectangle you did not convert and enter the following
text: "We are writing a long text to explain another one of the program's fea-
tures". If the text is illegible because of the object's angle of rotation, go back
to the Position and Size option and change it.

17) Right-click the rectangle and select the Text option from the context
menu. Then select the Fit to frame option. The text will be too small to read.

Return to the same dialog box and select Adjust to contour.

18) Move the 3D rectangle so that it covers part of the other rectangle. If it is
underneath the other rectangle, right-click it and select the Arrange -> Bring
to Front option to position it on top of the other rectangle.

19) Click on the Curve button in the Main toolbar and hold down the mouse
button until the Curves bar appears. Click on the Curve, Filled button and
draw a filled polygon. Double-click to stop drawing.

20) Go to the Edit Points button on the left of the Object bar. Click on it and
then select one of the object's handles. Drag the handles to change the shape
of the polygon.
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21) Draw a new rectangle with rounded corners that reaches the four page
margins. Go to the main menu and select the Format -> Page option. Go to
the Page tab and select Landscape orientation. Click on OK.

Figure 11. Page tab of the Page Setup dialog box
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22) You will see that the rectangle you have drawn has not changed to fit the
margins. To fit the rectangle to the page margins, you need to select the Fit
object to paper format option when changing the page orientation.

23) We will now deal with the topic of saving the graphics we have created.
Go to the main menu and select the File -> Export option, leaving the two
export options selected.

Figure 12. File Export dialog box
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2. Creating drawings with basic objects

Open Draw can be used to draw basic shapes such as rectangles or ellipses very
quickly and easily. You simply need to select the corresponding option from
the Main toolbar.

The toolbar buttons do not always display the same image because they dis-
play the last tool you selected. This means that you do not always have to
drop down all of the available options in drop-down buttons.

2.1. Use of basic drawing tools
The easiest tools to use are the ones for drawing rectangles and ellipses. To use
these, simply select the contour or shape you wish to use from the drop-down

list and draw the object in your workspace.

You can also draw a rectangle and change its borders to round the corners.
The steps for doing this are as follows:

1) Select the object you wish to round.

2) Click on the Edit Points button on the left of the Object bar.

3) The text handles will change and one of these will increase in size. When
you click on the biggest handle, the mouse cursor turns into a hand and

you can drag the handle to round the edges symmetrically.

The tool for drawing an arch or filled segment is particularly complicated to

use, so we will look at the steps required to do this now:

1) Click on the Ellipse button in the Main toolbar and select the shape you

wish to draw.
2) Draw the circle or ellipse in the document.

3) When you release the mouse button, the radius will appear and the mouse
pointer will adopt the form of a cross. You now need to click on the shape
where you want to make the cross-section.

4) The program will draw this line and another, movable radius will now
appear, which you need to move to the point on the shape where you
want the next cross-section to be made. The shape you have created will
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appear when you click. You can change the size to suit your needs using
the handles.

2.2. Applying attributes with the Object bar

When working with drawing objects, we can format selected objects very
quickly using the program's Object bar, which automatically adapts to our se-

lection.

Figure 13. Open Draw Object bar
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The formatting options of the Object bar are as follows:

e Line Style, Line Width and Line Color can be used to indicate whether
we want to include a border with the selected object. If so, select one from
the line style field. The Line Width and Line Color lists can be used to
define the attributes of the line.

¢ In the Area Style/Filling list, we can define the Invisible, Color, Gradient,
Hatching and Bitmap options. When one of these is selected, the previous
style will be removed. In the list to the right of this, you can choose from
the OpenOffice.org options for each of these categories. If the Color cat-
egory is selected, the program will display the same colours as the Color

bar, but with their names.

¢ The Shadow style button simply enables or disables this object attribute.

2.3. Applying fill attributes with the Area dialog box

All of the options we have just seen can be customised with advanced settings
in the Area dialog box, which can be accessed from the following menu op-
tion: Format -> Area, in the Area tab.

If we select the None option in this dialog box, no settings options will be
available because the selected object will not be filled.

However, if we choose one of the other options, we will see that the contents
of the dialog box change automatically.
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Figure 14. Area dialog box Color option
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With the Color option selected, simply choose the colour from the program
palette that you wish to use. In previous units, we saw how to modify the
palette to add custom colours using Tools -> Options...-> OpenOffice.org->
Colors.

Figure 15. Area dialog box Gradients option
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If you select the gradient option, you must then select the type of gradi-
ent you wish to use from the list. You can then select Automatic, whereby
OpenOffice.org creates the gradient automatically or, if you unmark this op-
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tion, you can enter the number of changes in colour tone you wish to ap-
ply. The more changes, the smoother the gradient. The maximum number of
changes is 256.

Figure 16. Area dialog box Hatching option
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With the Hatching option, you need to select a style of hatching from the list
of options and indicate whether you want to use a background colour. If you
do not select a background colour, the background will be transparent.

Figure 17. Area dialog box Bitmap option
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The Bitmap screen and its options is rather more complicated than the others,
so we will split up our explanation into different sections:

¢ In the Sizesection, we can select the Original option to maintain the size
of the bitmap. If you wish to modify the size, unmark the Original option
and enter your width and height measurements for the bitmap. You can
also check the Relative option and enter the percentage of the height and

width of the bitmap you wish to use.

¢ In Position, you can change the spot where drawing of the bitmap begins.
This percentage relates to the bitmap rather than the object we want to
apply it to. If you select the Tile option, the bitmap will be repeated all
along the surface of the object. We can also select Autofit to adjust the size
of the bitmap to the size of the object.

e In the Offsetsection, we find the options to control where the bitmap is
applied or where bitmap tiling begins, working out from the centre of the
object.

The result of our selections is displayed in the top right of the screen.

This same dialog box can also be used to modify the shadow and transparency
options of objects from their respective tabs. We will now take a look at these.

Figure 18. Area dialog box Shadow tab
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The Shadow tab is used to enable or disable shadows by selecting or unselect-
ing the Use shadow option. We can also select its position, the distance of
the shadow from the object, the colour and the transparency percentage we
would like it to have.
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Figure 19. Area dialog box Transparency tab
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In the Transparency tab, we can select the mode of transparency we wish to
use. With linear transparency, we can control the level of transparency with
the percentage in the linear transparency field. Gradient transparency is also
controlled in the fields in the gradient transparency section.

For some transparency modes, we need to enter centre coordinates so that
the centre of the colour gradient can move along these coordinates. With less

than 50% it moves left and up while with over 50%, it moves right and down.

To enter the value of the colour gradient angle, type in a number from O to
360°.

If the gradient colour is to have a border, the size of this should be entered too.

In the last field of this tab, we need to enter a start and end value for the
intensity of the colour gradient. This value must be at least O percent.

2.4. Creating and formatting lines

Open Draw has different types of lines that we can use in our work. They
include simple lines, connectors and diverse types of curves, and different
attributes can be applied to each of these.

The steps for drawing a line are as follows:

1) Click on the Lines and Arrows button on the Main toolbar and hold down

the mouse button until the Lines bar appears. Click on the type of line

you wish to use.
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2) Draw the line and use the handles to adjust it if the result is not quite
what you had in mind.

If you would like to draw a line at an angle, select the button with the cross
image to draw lines at horizontal, vertical or 45° angles.

2.4.1. Applying attributes to lines using the Object bar

As always, the easiest and fastest way to apply attributes to a line is to use the

program's Object bar.

Figure 20. Open Draw Object bar
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We will now look at its possibilities.

e In the Arrow Style list, we can specify the desired shape of the ends of
the line.

¢ In Line we must select a style, such as Invisible or Continuous or any of
the patterns from the list.

e In the Line Widthfield, we must enter the line width measurement. The
unit of size used will depend on the system of measurements selected in

OpenOffice.org.

¢ In Line Color, we can specify the line colour using the list of colours in

the system palette.

2.4.2. Changing attributes in the Line dialog box

If, after drawing a line, you wish to modify its attributes to precise values,
you will need to go to the Line dialog box, which you can bring up using
the Line button on the Object bar. You can also bring up this dialog box by
right-clicking on the line you have drawn and selecting the Line option from

the context menu.
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Figure 21. Line attributes dialog box
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In this dialog box, you can select the type of line, colour and width, besides
a range of other options:

¢ By choosing Center positions in the Arrow styles section, we will centre
the arrow or line beyond the end of the line, making it bigger than we
originally specified.

e If we select a value greater than 0% in the Transparency field, we will en-
able line transparency to the degree determined by the number we en-
tered.

e If we mark the Synchronize ends option, both ends of the line will look

the same.
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Summary

We have now seen the basics of OpenOffice.org's drawing tool and learnt how
to carry out basic drawing operations by creating a sample document.

We have also learned how to format and create the basic shapes offered by
the program. This unit has not covered text formatting and composition tools
because these topics were discussed in the previous units and the procedure
is exactly the same in this application.

Similarly, everything that we have seen here on drawing tools can be applied
to text documents and spreadsheets.
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