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Introduction

Firefox is a very fast, lightweight, powerful and flexible Internet browser. The
program is based on the well-known Mozilla browser whose source code was
released in March 1998, although it offers many improvements over the orig-
inal product. In fact, Firefox is only based on the essence of Mozilla, the web
page layout engine called Gecko, which confers the browser its power but with

a much more modern and attractive user interface.

In its day, Netscape Communicator, the "parent" product of Mozilla, intro-
duced most of the technologies used on the Internet today, including the SSL
protocol for accessing safe sites, frames, tables, cookies and the JavaScript pro-
gramming language. The influence of this program was key to the Internet's
development.

This unit supposes that students have a basic knowledge of the Internet. It
will not explain basic browsing concepts, but it will look at how they can be

applied to this excellent tool.

We will look at the program's interface and its basic configuration, but we
will focus mainly on the privacy and security options that we consider very
important and one of the main reasons for choosing free software over pro-
prietary solutions.

The main aims of this unit are:

1) to teach students how to use the diverse web browsing features of the
Firefox program,

2) toexplain how to customise these features to adapt them to students' own
needs, and

3) to configure the program correctly to make web browsing as secure as pos-
sible.
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1. Firefox installation and setup

Firefox is a very popular program that comes as standard with all modern
distributions of the GNU/Linux system. For instance, if you are using the latest
version of Red Hat, you can open the program from the panel launcher or with
the Internet -> Web browser main menu option. Nevertheless, new versions
of the program are released on a regular basis so you will probably be tempted
to try a newer version of the product. We will discuss how to do this in this
section.

The first thing we will need to do is to download the original package from
the project website at http://www.mozilla.com/firefox/. You will see a link for
downloading the program on this first page. Pay attention and you will see
that there are different versions available. Unless you know exactly what you
are doing, we would advise you to download the normal version, called the
stable version, for GNU/Linux in a package with the tar.gz extension, which
you should copy to your user folder.

We will suppose that you have downloaded the firefox-1.5.tar.gz file (the exact
filename will obviously be different for each new version of the program) to
your personal folder. There are a number of ways of extracting the contents
of the package and running the installation program but the one way that
is almost certain to work is to enter the following commands in a terminal

window of your system.

$ tar -xvzf firefox-1.5.tar.gz

A new folder entitled firefox will be created inside your personal folder.

This folder contains all of the programs and configuration files needed to run
the application in your personal home folder. This means that we can install
different versions of this program on our computer without them interfering

with the stable version that came with our GNU/Linux system.

To run the program, go to the directory created by the package you download-
ed after it was decompressed and enter the following command:

$ ./firefox &

In a few moments, the Firefox main window will appear on the screen.


http://www.mozilla.com/firefox/
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Figure 1. Firefox main window
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1.1. Selecting profiles

The program may ask which profile to use the first time you run it, especially if

you had previously installed another version of Firefox. If there are no profiles,

one will be automatically created in your personal user folder.

Figure 2. Profile selection dialog box

@

Firefox stores information about your settings, preferences, and
other user items in your user profile.

Hirerox=ChooseUSerProfile’

e

Create Profile...

|
‘ Rename Profile... ’
|

Delete Profile... ’

] Work offline
(] Don't ask at startup

’ ¥ Exit ‘ ‘@Start Firefox

The Firefox program uses profiles to store information such as e-mail messages,

contacts, browsing histories, browser customisations etc. If different people

are going to use the computer, it is a good idea to create a profile for each one.

If you create more than one profile, the program will ask which profile to use

every time you run it unless you tick the option in this dialog box. A green
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arrow next to the profile name indicates that it is a profile from a previous
version of the program and needs to be migrated before it can be used. This
operation is usually automatic and the user does not need to do anything here.

On the left of the screen are the buttons for operating with the profiles. We
can create a new profile, delete an existing one or change its name. The on-
ly information we need to enter to create a new profile is the name and geo-
graphical location. The information on geographical location is used to deter-
mine the language that the program interface will be shown in if the language

package is installed.

1.2. Advanced profile features

Now that we have seen that the profiles store all of our information and con-
figurations, we need to know the actual location of this information so that
we can make backups of it. This location will depend on the operating system

we use.

In GNU/Linux, profiles are stored in each user's personal folder in a hidden
folder with the following path:

~/.mozilla/firefox/[random_string].[profile_name]

Example

~/.firefox/xq9mOu3x.jesus/

Where [profile name] is the name used to log on to the system and
[random_string] is a random string containing numbers and letters. Although
the use of a folder with a random name may seem a little strange and perhaps
even inconvenient for backing up data, it actually considerably enhances the
security of the data stored in the profile because it means that much more
complex programs are required (viruses or Trojan Horses) to extract the data

from the system.
If you use the Windows platform, the profile folder will depend on whether
you are working in 95, 98 or ME or in a NT/2000/XP system. In the first case,
the path is as follows:

%APPDATA% \Mozilla\Profiles\ [profile_name]\ [random_string].slt\

And for Windows NT/200/XP:

C:\Documents and Settings\ [user_name]\Program files
\Mozilla\Profiles\ [profile_name]\ [random_string].slt\
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Example

C:\Documents and Settings\jesus\Program files\Firefox \Profiles\jesus\xvod4stn.slt

If you cannot find the profile name for any reason, you can always search your
hard drive for the file entitled prefs.js. In Windows, you can use the search
utility, which you can launch from the "Start -> Search -> Files and folders..."
option in the task bar.

In GNU/Linux, you can use a similar utility to that used by Windows in the
operating environment or you can enter the following command in the ter-

minal window:
$ find . -name prefs.js -print
We will now take a brief look at the most important files in our profile folder.

This will be very useful if we have a problem with Firefox or simply wish to
back up certain information.

Folders

Cache Contains temporary Internet files

cert8.dir Database of digital certificates

chrome Styles defined by the user, installed themes and applications.
Files

[a_number].s Password data

[a_number].w Form data

bookmarks. HTML Bookmark data

cert7.db and cert8.db Client certificate databases

component.reg Mozilla XPCOM component registry

cookies.txt File with the cookies we have installed

cookperm.txt Data on the configuration of the cookies and image permissions

downloads.rdf Download manager data

history.dat History of visited pages

key3.db Key database

localstore.rdf Information on the status of windows, position, icons, toolbars
etc.

mimeTypes.rdf Definition of MIME types configured in Firefox

panels.rdf Customised configuration of the side panel
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Files
parent.lock !f this file appears in the folder it means that the profile is currently
in use
prefs.js All of our customisations
prefs.bak Backup of the previous file
search.rdf Data on search engines
secmod.db Security module databases
URL.tbl List of websites excluded from automatic forms
user.js User configuration

This is a non-exhaustive list of the main elements found in the profile fold-
er. A full list of these files can be obtained from the following website: http:/
/gemal.dk/mozilla/files. HTML

1.3. Installing a language package

Although some versions have been fully translated into many of the world's
languages (installer included), we have chosen to install a version in English
so that we can see how to install a language package for the program. The
project website, where you can check on the status of translation projects and

download language packages, is:

http://wiki.mozilla.org/L10n:Home_Page

By way of example, we will walk you through installation of the Spanish lan-
guage package. The volunteers who translate the program into Spanish belong
to a project called Proyecto Nave. You can visit their website at:

http://nave.escomposlinux.org/.

You will find the language package in the XPI section on the download page.
You can in fact choose from a number of packages: language, which includes
translation of the user interface only; regional, which adds regional content
such as language community website links to the application, or you can opt
for the global package, which includes both of the above. For our demo, we
will select the global package.


http://gemal.dk/mozilla/files.HTML
http://gemal.dk/mozilla/files.HTML
http://wiki.mozilla.org/L10n:Home_Page
http://nave.escomposlinux.org/
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Figure 3. Package installation dialog box

@ Instalacionide’software Zan

Un sitio web esta solicitando permiso para instalar el siguiente
elemento:

FireBug 0.4

desde: http://releases.mozilla.org/pub/mozilla.org/exte

Un software malicioso puede dafar su ordenador o violar su
privacidad.

Solo deberia instalar software de sitios en los que confie.

¥ Cancelar| 2

When you click on the link to the package with the XPI extension, a dialog box
will pop up asking for permission to install it. Since we are downloading from
a reliable source, click on Install now to begin installation. The program will
be downloaded from the Internet and installed automatically. If the download

is completed correctly, a window will pop up with the instructions to follow.

Click on OK and exit Firefox by closing the program's main window. The next
time you run Firefox, the interface will be displayed in the language you chose.
You can install as many languages as you like but you can obviously use only
one at a time.

1.4. Installing plug-ins

There are now many plug-ins that are virtually essential for browsing any
modern website. The most common of these are the ones by Macromedia,
which allow us to execute Flash files, the Acrobat Reader plug-in , for viewing
documents in PDFformat, and the ever-present Sun Microsystems plug-in for
running Java programs. Unfortunately, the Firefox project cannot incorporate
these plug-ins into its program or distribute them with it because they are
proprietary applications. Obviously, GNU/Linux distributions do not usually
distribute them either for the same reasons. We will see that the installation
and configuration of these plug-ins are necessary for a completely satisfactory

web browsing experience.

We will now turn then to their installation.
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1.4.1. Installing the Java plug-in

You will find the Java virtual machine plug-in on the Sun Microsystems web-
site:

http://java.sun.com/products/plugin/

containing a link to the latest version of the product. On the page of the
latest version of the product, click on the blue Download button in the top

right-hand corner.

On the downloads page, go to the J2SE section and find the version for your
platform.

The JRE version is simply the virtual machine used to run programs in Java.
The SDK version includes programming tools besides the virtual machine. If
you are not interested in developing programs in this language you will not
need to install SDK.

The next step in the process is to accept the product installation licence. To
do this, click on "I agree" in the lower section of the licence page.

The Windows version uses Microsoft Windows Installer, so it integrates per-
fectly into the environment of this operating system.

Figure 4. Licence acceptance dialog box

{& Java 2 Runtime Environment, SE v1.4.2_01 - Lice X|

License Agreement

Please read the following license agreement carefully,

Sun Microsystems, Inc. il
Binary Code License Agreement
for the

JAVA™ 2 RUNTIME ENVIRONMENT (J2RE),
STANDARD EDITION, VERSION 1.4.2 X

SUN MICROSYSTEMS, INC, ("3UI") IS WILLING TO LICENSE
THE SOFTWARE TODENTTFTET REL.OW TO VOTT ONTY TTPOT =

% 1 accept the terms in the license agreement:

¢ Ido not accept the terms in the license agreement

Mext = | Cancel |

The first screen we see when we run the program is the licence acceptance
dialog box. Here, you will need to read the conditions of use of the program
and tick the "I accept the terms of the license agreement" option. Click on
Next to continue.


http://java.sun.com/products/plugin/
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Figure 5. Selection of type of installation dialog box

{&& Java 2 Runtime Environment, SE ¥1.4.2_01 - Set

Setup Type

Choose the setup type that best suits vour needs.

Please select a setup type.

All recommended features will be installed.

" Custom
‘ Specify the installation directory and choose which program features
, toinstall. You can change your choice of features after installation
by using the Add/Remove Programs utility in the Control Panel.
Recommended for advanced users.

Installshield

< Back I Mext = I Cancel I

In the selection of type of installation window, you must choose the type
of installation you require. The best option is Typical, which will install the
default components. After this, click on Next to begin installation. The time
that this takes will depend on whether you downloaded the full program or
the installer alone. If you only downloaded the installer, the program must
download the rest of the files from the Internet and this can take some time,

depending on how fast your Internet connection is.

Figure 6. Final installation dialog box
]’3 Java 2 Runtime Environment, SE ¥v1.4.2_01 - x|

InstallShield Wizard Completed

The InstallShield Wizard has successfully installed Java 2
Runtime Environment, SE v1.4.2_01. Click Finish to exit the
wizard,

The final installation dialog box indicates that the process has concluded sat-
isfactorily. Now you simply need to restart Firefox to access all of the function-
alities of the Java environment for web browsing. When Firefox is running a
Java applet , it displays a small white icon in the system tray with the Java

programming language logo, which is a cup of coffee.
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The process is very similar on the GNU/Linux platform except that text mode
is used. We must accept the licence terms and then indicate the installation
folder. As in Windows, we cannot download the plug-inalone; we need to
download the entire environment with it. In the sections on other plug-ins

we will see how this process is carried out.
1.4.2. Installing the Macromedia Flash plug-in

If you use the Windows platform, you will need to visit the Macromedia down-
loads site. The address is http://www.macromedia.com/downloads/ Here, you
will need to select the Macromedia Flash Player option. When you click on it,
the site will detect the version of the browser you are using and a page will ap-
pear with a link where you can download an installer program for the plug-in.

Click on Download now to save the program to your hard drive. The program
takes a while to download. Once the process is complete, double-click on the
program to run it.

Figure 7. Language selection dialog box

Select Language E X|

Please select the language that you would like to use during the
installation.

1.5, English I
Frangais

Deutsch

Portuguese

carcl_|

In the first screen, you can select the language you want the installation pro-
gram to use. Select the language you require and click on OK to continue.

Figure 8. Welcome screen

#2 Instalacién de Macromedia Flash Player x|

Bienvenido al programa de Configuracién Macromedia Flash Player.

Antes de empezar, cierre las demas aplicaciones, incluyendo
navegadores web.

Haga un clic en Siguiente para continuar con el programa de
Configuracidn.

Cancelar



http://www.macromedia.com/downloads/
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The first screen is for information purposes only. So simply click on Next.

Figure 9. Web browser selection dialog box

é% Instalacién de Macromedia Flash Player

Seleccione el navegador o navegadores compatibles con Netscape en los
que desee ejecutar el reproductor Macromedia Flash Player:

Otro Explorador...

< Blrds LCancelar |

This screen should automatically detect that you have Firefox installed on
your system as well as the version. Otherwise, you will need to select the Other
Explorer option and manually enter the folder where the program is located.
After selecting Firefox correctly, click on Install.

Figure 10. Final installation dialog box

42 Instalacién de Macromedia Flash Player

Presione el batén Terminar para terminar la instalacién de
Macromedia Flash Player

=

This screen indicates that the plug-in installation process has been complet-
ed successfully. When you close the installation application, Firefox will au-
tomatically close (be prepared for this if you need to save any information
first) and the Macromedia website will appear automatically running an ap-
plication in Flash.

If you are running GNU/Linux and wish to install the Flash plug-in , you
will need to download the web package as we saw earlier for Windows. This
time, instead of an executable, the file will be a zipped package that you
need to download to your user folder. You should then unzip and run the in-
stallation program following the example below, where the package name is

install_flash_player_7_linux.tar.gz:

# tar-xvzf install_flash_player_7_linux.tar.gz
# cd install_flash_player_7_linux
# ./flashplayer-installer
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In this case, installation will be in text mode. If you run the program as the
superuser, you can install the plug-in for all system users. If it is run with your
privileges, the plug-in will be installed in your personal profile and only you
will be able to use it. The program may prompt us to install the plug-in in the
Mozilla or Netscape folder if we have or have had these two programs installed
on the system or if we use a Mozilla-based browser (such as Galeon, Epiphany

or Firefox). In our case, we should select the Firefox folder.

1.4.3. Installing the Acrobat Reader plug-in

To download the latest version of the Acrobat Reader plug-in for viewing PDF
documents in your web browser, you will need to go to the following website:

http://www.adobe.com/products/acrobat/readstep2. HTML and select your ap-
plication language, operating platform and whether you have a broadband
connection. You can also choose whether or not to download the full prod-
uct. One of the more useful options of the full product is the possibility of
searching for text in PDF documents. As the full product option is ticked by
default, leave it as it is.

Once you have ticked and selected the required options, click on the Down-
load button to open the Firefox downloads dialog box. Either run the applica-
tion directly or save it to disk, to a location that you will be able to find easily.

When you run the program you have downloaded, Acrobat Download Man-
ager will launch and download the rest of the files needed from the Internet.
This can take a while, depending on the speed of your connection, but it will
not take as long as the Java plug-in

When all of the necessary files have been downloaded, the welcome screen

will appear.


http://www.adobe.com/products/acrobat/readstep2.HTML
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Figure 11. Welcome screen

{& Programa de instalacién de Adobe Reader 6.0 ]

USSR

Bienvenido al Asistente para la instalacion de
Adobe Reader 6.0 - Espariol

El Asistente instalard Adobe Reader 6.0 - Espafiol en su
equipo. Para continuar, haga clic en Siguiente.,

ADYERTEMCIA: Este programa esta protegido por las leyes de
derechos de autor v otros tratados internacionales.

Cancelar |

The welcome screen is for information purposes only and is not important to
us. Click on Next to continue the installation process.

Figure 12. Folder selection dialog box

{& Programa de instalacién de Adobe Reader 6.0 X|

Carpeta de destino

Haga clic en Siguiente para instalar en esta carpeta o en Cambiar para instalar
en una carpeta diferente.

InstalarAdobe Reader 6.0 - Esparfiol en:
i C:\Archivos de programalAdobelacrobat 6.04

Cambiar carpeta de destino. .. I < Atras

Cancelar |

In this dialog box, you can select the installation folder for the application.
Unless you have a justified reason for installing it in another location, it is
always best to use the default folder. Click on Next to continue.
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Figure 13. Review of installation settings dialog box

Preparado para instalar el programa
El Asistente esta preparado para comenzar la instalacion,

Haga clic en Instalar para comenzar la instalacion.

Si desea revisar o cambiar las carpetas de instalacién, haga clic en Atras, Haga clic en
Cancelar para salir del asistente.

< Atras Cancelar |

When you reach this window, installation is ready to begin, although you still
have time to change the information you have entered before this point. To
do so, click on Back to return to the previous windows. If you are sure that all
the information is correct, simply click on Install to start copying the files.

Figure 14. Final installation dialog box

{& Programa de instalacién de Adobe Re:

Asistente para instalacion finalizado

El asistente ha instalado Adobe Reader 6.0 - Esparfiol
correctamente, Haga clic en Finalizar para salir del asistente.,

If the final installation dialog box appears, this indicates that installation was
successful and the program has been installed correctly on the system. In this
dialog box, click on the End button to exit the installation program.

If your operating platform is GNU/Linux, installation is also very similar to
the installation of Macromedia Flash Player. Firstly, download the package
from the website and decompress it to a folder. This time, a new folder will
not be created with the name of the package; you have to create it your-
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self beforehand. For instance, if the name of the file you downloaded was
AdbeRdr701_linux_enu.tar.gz, you can enter the following in a terminal win-
dow:

$ tar-xvzf AdbeRdr701_linux_enu.tar.gz
$ cd AdobeReader
$ ./INSTALL

The program will display a text with the licence, which you must accept by
typing in Accept. You must then specify the installation folder. To install it
in the suggested folder for use by all system users, you must have superuser
privileges.
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2. Interface and general use of the program

The program's GUI is very similar to that of any other web browser, so you
should have no problems getting to work with it. It has a browser bar, buttons

and menus, the functions of which should be immediately familiar.

If you are used to much more complex web browsers, you will see that Fire-
fox does not include the small icons usually found in the bottom left of the
main application window, giving access to various functions. Firefox is a very
straightforward program that has no default mail manager, address book or
IRC program, but it can be built on and complemented very easily with dif-
ferent add-ons, browser bar and themes.

2.1. Themes

The program comes with a default grey theme called Firefox 2.0, but you can
use other themes to customise your browser. It is even possible to use buttons
and colours that are very similar to those of Internet Explorer. Besides the
theme that comes with Firefox, you can obtain many more from the Internet.

To change the appearance of the program, go to the Tools -> Themes menu,
which will indicate the options for selecting themes.

Figure 15. Theme selection preferences dialog box

@ Jemas! e

&1 Firefox (default) 2.0
" The default theme

@ Buscar actualizaciones| Obtener mas temas
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If you have not previously downloaded a Firefox theme, you will only see the
Firefox 2.0 theme, which cannot be uninstalled. When you select a theme,
you will see how the program will look in the preview window. In the bottom
of the dialog box, you will see a Download new themes link, which will take
you to a website containing many different themes that you can use.

The system for installing new themes is very similar to installation of a lan-
guage package but in this case the files have the extension JAR instead of XPI.
An alert dialog box will appear first of all, asking whether you wish to install
the theme. The software installation dialog box will then appear on the screen,
indicating the progress of the installation. If installation is successful, you will
have a new theme in the selection dialog box.

Figure 16. Theme installation alert dialog box
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Once you have selected the theme you wish to use, you must quit the appli-
cation and open it again for Firefox to adopt the new appearance.

Figure 17. Main Firefox window with a new theme
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2.2. Bookmarks toolbar

This personal toolbar is used to save the customised addresses of websites for
easy access to them. If it is not enabled by default, you can turn it on with the
View -> Toolbars -> Bookmarks Toolbar menu option.

It is very useful for saving sites so that we do not need to type in the address
again. It offers the same features as Bookmarks but is much easier to use. To
add a site to the Bookmarks toolbar, simply select the address and drag it to
the toolbar.

Figure 18. Firefox Bookmarks toolbar
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We are not limited to creating direct links to websites; we can also create fold-
ers to group them into different categories. To create a new folder, right-click
the toolbar and select the New Folder option. A dialog box will appear in
which you can enter the name and, if necessary, a short description.

Figure 19. Folder properties dialog box
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To add a link to a folder, drag the address to it as you did in the previous
example. To select a link from a folder, click on its name inside the folder,
which will display a drop-down list of the items that you have added to it.

2.3. The Sidebar

Although the Sidebar may initially seem a bit of a nuisance because it takes
up valuable screen space, when used properly, it can be very useful. The Side-
bar can display our downloads, bookmarks and browsing history and can be
closed by clicking the X in the top right-hand corner of the panel. To display
the Sidebar, simply select the View -> Toolbars -> Sidebar menu option. Repeat
this step to hide the bar again.

Figure 20. Browser window with the Sidebar
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The two standard options offered by the Sidebar are bookmarks and browsing
history. The top section of the Sidebar contains a text box for quick searching
within these items and, in the case of histories, a button to arrange the data

by diverse preset criteria.

2.4. Web browsing with tabs

In other browsers, we can view more than one web page at a time if we open a
browser window for each. One of the best features of Firefox is the possibility
of Internet browsing with tabs, allowing the user to view various web pages
at a time inside the same window. To open a new tab, select the File -> New
tab option from the main menu or use the Ctrl+t key combination, which is
the fastest way of opening a new tab.
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Figure 21. Browsing with tabs

) UOC) URiVersitat OBerta e Cataliny 2 SO 2T erox) [
Archivo Editar Ver Ir Marcadores Herramientas Ayuda " jeorrius ~
j - v i;r;l Y"ﬁ | &7 http;/jwww.uoc.eduweb/cat/index.html E\ OlIr

[ELatest Release Notes Fedora Project Fedora Weekly News Community Support Fedora Core 5 ®Red Hat Magazine

Google » \:H G Buscar - (1 & &2 P2Rnk 4% Corrector ortografico - - [JOpciones

> El Cau del Senglar, la Destral, i ... | ¢<1UOC, Universitat Oberta de C... \ 8
<]juoC
Bhog e hrectora | Contacta amb nosaltres | Cercaa k UOC Espafiol | Englsh | AAA

Nom

l(,'/ \‘\l ‘ Accés obert

4 Titulacions oficials
Estic atent a les possibilitats que ly ) .
generen les noves tecnologies” » 17 de jule

Willam Mitchell és prof Arquitectura Utti

Chu

LA UNIVERSITAT

# Ateneu universitari
Massachuset amp diestudi abraga Més de 40

Projecte educatiu

La UOC par Gestié de continguts a les

organitzacions

de continguts e

Empreses associades [

Data lim

comunicacions: [2

RECERCA § Espai Europeu d'Ensenyament

Institut de recerca - IN3 Superior

[T

Terminado

You can open as many tabs as you like in a single window. However, if you
open too many, it might be difficult to work with them all so it is better to
spread them out across several windows. To switch tabs, simply click on the
tab title. If you right-click the tab title, you will see the various actions you
can perform, such as closing the tab. It is also possible to close the current tab
by clicking on the X button to the right of the tab title.

Just as we can open a link in a new window, we can open it in a new tab. To
do so, right-click the link with the mouse and select the Open in a New Tab
option from the context menu.

In Firefox 1.5, it is possible to drag tabs into the main window for better or-
ganisation. To do this, simply click on the tab title and hold down the left
mouse button as you drag the tab to the desired location.

2.5. Help

The Firefox browser free software project is one of the best for documentation.
You can access this general information from the Help -> Help Contents menu
option and there is also a Help button in most windows and dialog boxes. The
Help is very thorough and you will almost certainly find the answer to your
questions here.
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Figure 22. Main Help page
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3. Basic browser configuration

We will now look at the program's configuration and customisation tools.
We will deal specifically with determining the behaviour of the browser, web
searching and the management of the different types of file we can find while
browsing the Internet. This section will deal with the basic configuration of
the program and look only at the most important options. The next section

will focus on everything that concerns web browsing security.

All of these options are grouped into a series of windows in Preferences. Those
of you who remember previous versions of Mozilla or Netscape will see that
this dialog box has been greatly simplified. To access these options, go to Tools
-> Options.

Figure 23. Browser preferences window

@ Preferenciaside’-irerox: ==
] & @ 5 &

General Privacidad Contenido Pestafias Descargas Avanzado

Pagina de inicio

Direccion(es): | file:///usr/share/doc/HTML/index.html

Usar pagina actual | | Usar marcador...| | Usar pagina en blanco

Conexion

Configurar proxies para acceder a Internet. £l Configuracion de conexion...

&) Ayuda X Cerrar

We can customise the following options in this initial preferences window:
Home page
In the text box, we can select or type in the page that will be shown by the

program for each of the following actions: when Firefox is launched, when a
new window is opened and when a new tab is created. This is also the page
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that will appear when you click on the Home page button. This gives us greater
flexibility when it comes to customising our browser behaviour. The available
options are as follows:

Current Page: If you check this option, Firefox will open at the last page
you visited. For privacy reasons, if you share your computer with other
users, it is important to check the selected page because the other users will
see the last page you visited and it may contain confidential information.
If you have more than one tab open, Firefox will open as many tabs as are

open, using their current addresses.

Bookmarks: Here you can select a web address from your Bookmarks fold-
er to replace the page indicated as your home page in the Address text field.

Figure 24. Bookmark selection dialog box
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Blank Page: If you check this option, the program will not display a page,
so the new window or tab will be opened instantaneously because there is

no need to wait for a page to load before you can start using the browser.

Default browser

The button in Default browser makes Firefox the default system browser. The
following options are available here:

Check to see if Firefox is the default browser: Every time you launch
the program, Firefox will check to see whether it is the system's default
browser. If it is not, a dialog box will appear asking you whether you wish
to make it the default browser.

Check Now: When you click on this button, Firefox will immediately
check to see if it is the default web browser for the system.
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Connection

For obvious security reasons, many companies block Internet access from their
networks. This means that third parties cannot access important information
in the company network from other computers. This protection uses a proxy

server or firewall.

If your company has a firewall or your Internet provider needs one, the brows-
er may need to go through a proxy server to connect to the Internet. You can

configure this using the Settings button under Connection.

Figure 25. Internet options configuration dialog box
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The options offered in this configuration dialog box are:

e No proxy: this is the default option for the program, indicating that we

do not want to use a proxy to connect to the Internet.

¢ Auto-detect proxy: If the network is configured with automatic proxy
settings (using a configuration file), we can select this option. This means
that we will not have to update the settings if the network configuration
changes.

e Manual proxy configuration: If there is only one proxy for connecting to
the Internet, type the address in the appropriate text box. It is also possible
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to enter a different address or port for each of the available services if
greater flexibility is required in the configuration settings.

3.1. History

Figure 26. History preferences dialog box
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The history preferences dialog box is used to customise the behaviour of Fire-
fox for the pages we have visited. The following fields can be customised:

e Browsing history

The history file contains all the addresses visited over the last few days. We
can access these from the Sidebar or by using the Ctrl+H key combination.

In the text field, you can enter the number of days you wish to keep the visited

pages for. To delete the record, click on Clear history.

e Address bar history

The address bar also has a mini-history of the last pages visited, although it
is much less exhaustive than the main history. However, as you start to write
a website address in the address bar, Firefox will display the last pages visited
that match the address you are typing. So, if you always visit the same pages,
this feature offers very easy access to them. To visit one of the suggested pages,
click on the address in the drop-down list.
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The Clear addresses button is used to delete this history so that the above
suggestions are not displayed.

3.2. Languages

Figure 27. Language preferences dialog box
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The next section, Languages, is used to select the language in which you would
like websites to appear, when a site offers versions in different languages. The
websites of leading companies normally have these features. If the page is only
available in one language, these options will have no effect.

e Languages for websites

By default, the program uses US English. If you want to enable more languages,
click on the Add button. This action will open a dialog box in which you can
select your preferred language, or you can enter its ISO code in the text field.
The languages are organised by order of preference, so, for example, if you
want websites to be displayed in Spanish first and then English, select Spanish
and move it to the top using the Move Up button on the right-hand side of
the dialog box.

¢ Character encoding

Character encoding determines text decoding. In general, the default encod-
ing will be correct and it will not need to be changed. This is the place to go
when, for instance, certain letters appear as question marks or funny symbols
as this tells us that the character set is incorrect.

To change the default browser character encoding, go to Tools -> Options ->
Content -> Font and Colours -> Advanced and select the default encoding.
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Figure 28. Dialog box for default encoding selection
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3.3. Accessory applications

Figure 29. Dialog box with the accessory application preferences
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In this dialog box, you can specify the accessory applications. We can come
across several file formats on the Internet that Firefox cannot open alone, such
as audio tracks in mp3 format or video files. In these cases, the program calls
up accessory applications, which display or run these files for us.

There is normally no need to change any of the options in this window be-
cause the program will prompt you to indicate which program you wish to
use to open a file in an unfamiliar format to Firefox. However, it can be useful
if you want to enter new formats to be automatically opened without being
prompted or, more importantly, if you have made a mistake. Imagine that you
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want to open an audio file and mistakenly tell the program to use the system
notebook (for instance, gEdit) to open it. From this point on, Firefox will al-
ways open this type of audio file with the selected program. You can change
this behaviour in this setup window.

To change an existing type, first select it and then click on Edit. A dialog box

will appear with a number of fields, as shown below:

Figure 30. File type editing dialog box
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The features of the file type are displayed in the upper part of the window.
Each has a specific MIME.

MIME is the abbreviation for Multipurpose Internet Mail Extensions and is
a standard for displaying e-mail message content. For example: text/plain for
text or image/jpeg for a JPEG image.

There are websites on the Internet with lists of all available MIME types. To
create a new type, you will need to consult these lists to find out which type
corresponds to the extension. However, this is a very advanced topic that will
not be dealt with in this module.

Click on the Change Action button to specify the default behaviour of the
browser when you have one of these files. A new dialog box will open with
a list of options:
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Figure 31. 'Change Action' dialog box
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e Open using the default application

If you select this option, the file will be opened with the default system appli-
cation. Thus, it would open in the same way if, for example, you clicked on
it while using Nautilus.

e Open with

If you want Firefox to open the file in another application not included by
default in the system, click on Select to find the path for the application you
wish to use.

e Save to disk

If you select this option, the file will be downloaded to your user folder and

you will have to open it manually.

e Always ask for files of this type

If this option is checked, the program will always ask which action to take
regardless of what was entered in the previous fields.
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3.4. Tabs

Figure 32. Tab preferences dialog box
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We have already looked at basic tab browsing. In this dialog box, we will see
how to configure some of its features. At the top of the dialog box, we see that
the options for opening an external link from another program using Firefox

as the default browser are:

¢ A new window: The external browser link will open in a new window.

e A tab in the current window: The external link that we clicked on will
open in a new tab in our window and will be automatically added to the
existing tabs.

¢ Current window/tab: The web contents of the external link will replace
the contents of our current window or tab, meaning that the previous

contents of the browser window will be lost.

This window also offers advanced user options. Let's look to these individually:

¢ Force links that open in a new window to open in: This option enables
us to change the default behaviour of windows that open in a new window
when we click on them on a web page. When this option is checked, we
can indicate whether these windows should open in the current window
or in a new tab rather than a new Firefox window.
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e Hide the tab bar when there is only one tab in the window: When this
option is checked, the tab bar disappears when the window only has one
tab open. This is the default behaviour of the tab bar.

¢ Select new tabs opened from links: If this option is selected, Firefox will
change the new tabs opened from links into active tabs. If this option is
not marked, the active tab will always be the current one when we open

a new tab from a link.

¢  Warn me when closing multiple tabs: If you try to close a window con-

taining more than one open tab, Firefox will display a warning message.

Figure 33. Warning message when closing a window with multiple tabs.
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3.5. Downloads

Figure 34. Downloads preferences dialog box
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The downloads dialog box can be used to customise the behaviour of Firefox

when downloading programs from the Internet.

There are three options for this feature:
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e Download folder

We can tell Firefox to either always save our Internet downloads to the same
folder (user desktop by default) or to ask us each time where to save the file
being downloaded.

¢ Open download manager

If you mark this option, the download manager will appear when download-
ing begins. The download manager can be used to pause and restart a down-

load in the same session provided that the server supports this.

¢ Download actions

Here, Firefox can be configured to perform a specific action after downloading
a given type of Internet file. This is a very convenient option but we need to be
very cautious with it (particularly if we are Windows users) because some file
types can be Trojan Horses or viruses that can put the security of our system
at risk.

3.6. Advanced

Figure 35. Advanced preferences dialog box
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The advanced preferences dialog box has a number of tabs with different func-
tions covering three broad areas: General, Updates and Security. We will now
look briefly at each of these areas.
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e General

This section is used to customise accessibility, browsing and language pref-
erences. The accessibility options, designed particularly for individuals with
some form of disability, allow us to select text using the keyboard instead of
the mouse and to automatically perform text searches in a page when we start
typing, without the need to tell it to do so first.

The configurable browsing options are used to indicate whether to adjust
images displayed in the browser to fit the screen and the different types of
scrolling to use for navigating around the window contents. Finally, the lan-
guage selection section is used for selecting website languages, which we dealt
with in detail earlier.

e Updates

The updates tab is used to configure diverse aspects of Firefox updates, which
are installed automatically by default. It is a good idea to leave this as auto-
matic because it will install all program security updates without the need for
user intervention. This means that we will always be protected.

Figure 36. Advanced update preferences dialog box
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e Security
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Figure 37. Advanced security preferences dialog box
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The advanced security preferences allow us to indicate the secure web proto-
cols we wish to use while browsing the Internet and to operate with our secu-
rity certificates. We will deal with all this in the next section, which discusses

how to configure Firefox for the most secure browsing experience.
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4. Privacy and security in Firefox

This is an important aspect that needs to be taken into consideration when
choosing a common tool for Internet use. Browsers have become essential
tools of any computer environment. However, they are also one of the biggest

threats to user security and privacy.

Firefox is generally a very secure web browser, both in GNU/Linux and in
proprietary environments like Windows. Rather than list the technical details
of its security features or dwell on the astounding loopholes detected in Mi-
crosoft products in the past, we would do well to note that computer "pirates"
mainly seek out holes in common products and that the vast majority of users
currently use Internet Explorer and Outlook.

The default configuration of the program shows how all of these aspects have
been taken into account. We need to be aware that absolute security does not
exist and the ultimate responsibility for this lies with the user. This section
will look at the security features and options of Firefox.

4.1. Cookies

Of all of the elements affecting privacy, cookies are usually the biggest concern
for users. Cookies do not pose security risks because they are simply small text
files containing information. In most cases, they actually make web browsing
easier for users because they remember the pages we have visited, the options
we have chosen etc. For example, if we are registered users of the Amazon
site, cookies remember who we are so that, every time we connect to the site,
we are given tailored information on offers based on our tastes and hobbies.
However, cookies also allow companies to compile statistics on how we use

the Internet and what pages we visit, without our knowing it.

We can access the program's cookie options through the Tools -> Options...
-> Privacy -> Cookies menu option.
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Figure 38. Cookie preferences dialog box
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For ease of browsing, we will need to accept cookies on all websites. If we do
not, we might not be able to access all of their features or enter certain sections.
For increased security, we can check the Accept cookies option, which will
generate a dialog box asking whether or not we want to accept the cookie in
question.

Figure 39. Cookie acceptance dialog box
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If you think the asking option will work best for you, check the Use this option
for all cookies on the site option so that the program asks us just once for each

website we visit.

The program offers different options for the use of cookies , depending on our
browsing needs and habits. A foolproof way of visiting websites without being
asked anything is to uncheck the "Warn me before accepting a cookie" option
and to check Limit maximum life of cookies to: - current session. This means
that our system will accept cookies and store them on our hard drive but that
they will all be deleted when we close the program. This will ensure access to
all websites but the data will only be saved for the current browsing session.
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Although they may be useful to some users, it is not generally a good idea to
use the Only accept cookies originating from the same server as the page being
viewed and Enable cookies based on privacy settings options because they are
affected by factors that we cannot always control. These properties can allow
access to most websites but this may not always be the case. It is best to use
one of the options described at the start.

If you are an advanced user or simply prefer only certain sites to store your
data (for example, an Internet banking site where you have an account), you
can use the cookies. If you are visiting a site where you want to block or allow
the use of cookies, simply select the relevant option from the Tasks -> Cookie
manager main menu option.

For a more advanced setup, you will need to access the cookie manager per se,
either by clicking on the Show cookies button in the preferences screen or by
using the menu option: Tasks -> Cookie Manager -> Manage stored cookies.

Figure 40. Firefox Cookie Manager dialog box
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This window is used for very detailed customisation of the cookies we wish
to keep on our computer.

4.2. Images and banners

Another of the program's features is that it allows us to block advertising im-
ages in the Options menu, although it is not directly available through the
Security section. You can access these settings from the Tools -> Options... ->

Content menu option.
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Figure 41. Content options dialog box
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We will now look at the available options.

¢ Display images

As one might well imagine, unchecking the Display images option blocks all
graphic content from the Internet. To display images, you will need to right-
click on the frame of the same name and select the Display image option.
You can use this feature to browse in text mode. However, in this day and
age, there can be no doubt that the best option for surfing the Internet is
Display images, as this will allow us to view all graphics without restrictions.
The alternative option of displaying only images originating from the server
can be very effective if we wish to avoid displaying advertising banners but
some servers, particularly those with a great demand for pages, store copies of
images on other servers. This means that we would be unable to view them
automatically. Later on, we will see how to block images from specific servers.

¢ Only display images from the original server

Although we will not dwell here on the e-mail program, this is a very impor-
tant option because it redirects a lot of junk mail. If you use Thunderbird to
read your e-mail, it is almost essential to check this option because many junk
mail messages are written in HTML format. In this format, invisible one-pixel
images can be incorporated that contain identifiers for our e-mail address. If
we open the message and the remote image is loaded, the person sending us
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the message knows that the e-mail address is correct and that we have read the
message, meaning that we will receive more junk mail. This option only blocks
remote images; it does not block images on the page that we have opened.

Recently, there has been a rise in the number of viruses and Trojan Horses that
use images as their method of propagation and we are at even greater risk if we
use Windows. It is therefore important to mark this option in web browsers

too, rather than just in e-mail programs.

As these rules are very general and we probably require much greater image
blocking flexibility, Firefox gives us a tool to customise all of this. To access
the Image Manager, click on the Exceptions button to modify image blocking
for specific websites.

Figure 42. Firefox Image Manager dialog box
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The Image Manager lists the websites for which the program will load images.
To delete a site from the list, highlight the name and click on the Delete site
button.

The quickest way of blocking all images from a given server is to right-click
the mouse on one of its images and select the following option : Block Images

from this server.

Bear in mind though that this will block the entire domain. For example, if we
block images from a personal page in the www.geocities.com domain, we will
effectively block all images from this domain and we probably do not want to
do so. On the other hand, we will often find that advertising images always
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come from the same domain and this feature will prove very useful in this
respect. To quickly block images from a server, simply right-click an image and
select Unblock Images from this Server.

4.3. Popups

Popup windows are probably one of the most irritating items that Internet
users come across while browsing. The worst offenders are those that appear
when we close a window. This section will cover the Firefox tools designed
to rid you of these nightmares. Obviously, there may be new techniques for
opening pop-ups that Mozilla still cannot block. You can display the program
options using the Tools -> Options... -> Content menu option.

Figure 43. Content options dialog box
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In this dialog box, select the Block popup windows option (the default config-
uration in the program). This will enable popup blocking and automatically
notify the user when the program is blocking a popup. This is important as
Firefox may block popups that are not advertising. Some websites use them to
gain users or to allow programs to be downloaded from other servers. If you
are on a site and click on a link where something should happen and nothing
does, check the Firefox bar to see whether it has blocked a popup. If this is
the case, an icon with an exclamation mark on an orange background will
appear in the bottom right of the window. If you double-click this icon, the
program's Popup Window Manager will launch and you can add the site to
those allowed to use popups. All popup windows are blocked by default so
you will need to specify exactly when you want a site to display popups.
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Figure 44. Popup Manager dialog box
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After giving permission, you will need to load the page again for the new
properties to take effect.

4.4. Passwords

The use of passwords to access certain Internet services or content (for in-
stance, newspaper content or free e-mail accounts) is increasingly common.
If, as recommended, we use a different password for each one, we may find
it difficult to remember them all. However, it is more risky to use the same
password for all of them because if it falls into the hands of a malicious user,
they could use it to access all of our data.

If you are going to have problems memorising them all, you can use the Firefox
Password Manager. To enable this option, go back to the program's preferences
dialog box. The path is: Tools -> Options... -> Security -> Passwords.
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Figure 45. Passwords preferences dialog box
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If you want the program to save the passwords, you will need to check the
Remember passwords option. By default, Firefox uses encryption to store con-
fidential information in order to enhance password security. As a result, you
will need a master password to access the data. We will look at this now.

Firstly, you must go to the Master Password dialog box. If you are in Password
Preferences, simply click on the Master Password button to the right of the

window.

Figure 46. Master Password preferences dialog box
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Once inside this window, click on the Change Master Password button, which
will open a dialog box where you can enter your password. One very useful
feature of this dialog box is the password quality meter, which indicates the
reliability of our password.

Figure 47. Master Password dialog box
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There are a few basic rules to bear in mind when choosing a password. The
first is that it should be easy to remember. The second is that we should not
use words that can be easily related to us (such as our own date of birth or the
name of our dog). It is important to use a combination of letters, numbers and
symbols. When these elements are added, the deciphering difficulties increase
exponentially. The password quality meter bar will give us a rough idea of this
difficulty.

We need to take special care with this password because a malicious user could
access all of the other passwords saved by Firefox.

After entering the password, click on OK to save it.

It is only natural to be wary about saving all of our passwords in Firefox, con-
sidering that it is a computer program that connects to the Internet and is
hence vulnerable to computer attacks. Absolute security does not exist but
the system used to save them by the program, with encrypted data and a vari-
able profile folder, is much more secure than the one supplied by default in
Microsoft's Internet Explorer.
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4.5. Scripts and plug-ins

One of the basic features of the Internet today is its use of JavaScript and plug-
ins, such as Macromedia's popular Flash Player, to increase the usability and
attractiveness of web browsing. But because nothing is perfect, all of these
improvements could seriously compromise the security and privacy of Inter-
net users if they are not adequately controlled. We will now look at the tools

offered by Mozilla for their control.

To access these options, go to Edit -> Preferences...-> Advanced -> Scripts and

plug-ins, which will bring up the following dialog box:

Figure 48. Content options dialog box
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The options offered here are:

e Enable Java

The Java virtual machine can be very useful for sites with advanced content,
such as dynamic maps created by users or other complex web applications.
Java programs that come from known websites are generally quite safe and
do not usually cause security problems. Nonetheless, if you never visit sites
that use Java, it is best to turn it off, just in case. It is important to disable
whatever you do not use.

¢ Enabling Javascript:
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For satisfactory web browsing, you must enable the Javascript option because
it is a language used by most Internet sites. However, this option should never
be enabled in an e-mail program. Javascript code can be used in a message
to send data to a server in a similar fashion to invisible images in junk mail.
There is no use for Javascript in a normal e-mail message. No friend would

send us an e-mail with Javascript in it.

If you want to further customise your control over Javascript for, although
necessary, it can be used to bother the user with advertising, click on the Ad-

vanced button to configure its behaviour.

Figure 49. Advanced Javascript options dialog box
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For security reasons and particularly for the bother it can cause, it is best to
uncheck the Move or resize existing windows, Raise or lower windows and
Hide the status bar options. In contrast, it is important to allow the creation,
modification and reading of cookies, so we should select the Create or change
cookies and Read cookies options. The other options will depend on the indi-

vidual user but they will not have a direct impact on security.

4.6. Digital certificates

Digital or electronic certificates are an increasingly important aspect of secu-
rity. In an Internet environment, these documents serve to verify the source
of the displayed data. In other words, they are used to check that the issuer
of the data really is who they say they are. We can therefore think of it as an
identity card allowing us to identify ourselves on a network.

Security certificates can also be used to sign or encrypt e-mail messages but we
will look at this later. We will focus exclusively on the web environment here.

We can obtain a personal certificate from a CA (certification authority). These
organisations must have the authority to issue this type of certificate. Dif-
ferent types of certificate are available depending on their purpose, but it is
usually fairly easy to obtain one for purely personal reasons. If you need a
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company certificate, the process tends to be far more complicated. The most
widely known certification authority is VeriSign Inc, whose website is http://

www.verisign.com/, but there are many others too.

4.6.1. Secure websites

In the web environment, certificates are used for visiting websites securely. If
you look at the address of these sites, you will see that it begins with https://",
rather than "http://, indicating that we are on a secure site. When this hap-

pens, the colour of the address bar in Firefox turns bright yellow.

A much easier way of checking this is to observe the padlock icon displayed
in the status bar in the bottom right of the main window. It is very important
to know the meaning of the different positions of the padlock icon.

¢ A closed padlock icon means that all data sent between the server and our
web browser are encrypted.

e An open padlock means that communication between the server and our
web browser uses data that are not protected.

e If we see a broken padlock on a red background, this means that not all
of the elements of the page were received as encrypted although the page
containing them is marked as encrypted.

For more information about the status of the page, click on the padlock icon
to display a dialog box containing information about the page in the security
tab. You can also access this information from the Tools -> Page Info -> Security

menu option.


http://www.verisign.com/
http://www.verisign.com/
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Figure 50. Dialog box displaying security information for a page
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The top section of the dialog box indicates whether the website to which the
page belongs has been validated and which authority has certified it. Click on
the View button to see the full details of the certificate.

In the rest of the dialog box, we can see whether the contents of the current
website are encrypted and to what level. There are different levels of encryp-
tion, offering varying degrees of security.
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Summary

This unit on the popular Firefox web browser has looked at various aspects
of its installation and configuration and described key elements that can be
very important when using the tool. Throughout, the approach has been to
provide an introduction to Firefox, rather than to web browsing, so we have

not covered basic aspects that we believe students will already be familiar with.

We have seen the process for installing the program and the different plug-ins
that make web browsing much more attractive, since this is one of the big us-
ability problems faced by users who use programs not developed by Microsoft
and the software giants that only support Internet Explorer and Outlook Ex-
press.

Another key area that we have looked at in this unit is data backups. Users do
not normally pay attention to this but we consider this information essential

if users are to be able to use the program comfortably and with peace of mind.

We have looked in detail at the program's security and its configuration, since
we consider this one of the most important aspects that need to be underlined

in Firefox and all free software in general.
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