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Introduction

This unit will look at the various options for configuring OpenOffice.org that
will enhance our experience of the program. As usual, we will focus on GNU/
Linux, but we will also deal with the problems that can arise using Windows.

To feel at ease with a computer program, we believe that users must know the
diverse options and features that could cause problems and learn how to solve
these. This make us more confident in our use of the product.

We will focus on the three areas that generally cause the most problems
for users: printer configuration, the compatibility of OpenOffice.org docu-
ments with Microsoft Office and the installation of new dictionaries for the
program's spellchecker.

The main aims of this unit are:

1) to explain how to install and configure a new printer in OpenOffice.org,

2) to analyse the compatibility issues that we could come across when im-
porting or exporting documents to Microsoft Office formats and other

platforms, and

3) to describe the process of installing a new language dictionary for the
program's spellchecker.
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1. Installing and configuring printers in GNU/Linux

If you use the Windows platform, OpenOffice.org can use the printer or print-
ers installed in the system in a transparent way for users. When you want to
print a document, simply select the printer you wish to use and the system

will do the rest. Unfortunately, this is not possible in GNU/Linux.
OpenOffice.org has a utility for configuring printers and fax machines and
for installing typefaces for use in the program's production environment. It is
called oopadmin. We will now explain how to use it.

To run the program, go to the installation folder and type:

$ cd /program
$ ./oopadmin

In a moment, the main window of the printer administration tool will pop up.

Figure 1. Oopadmin main window

Installed printers

Propetties...
Rename...
Default
Test Page

Command: Ipr

Driver: Generic Printer (SGENPRT)
Location:

Comment:

New Printer... ‘ Fonts...

o

This program must be launched following an OpenOffice.org server installa-
tion. The system administrator must then run the oopadmin program as a
superuser. This is so that the printers created can be used by all users of the
computer. Otherwise, each user would have to create his or her own.

After launching the program, the system administrator must create a file with
the general printer options. This file will be located in the /share/psprint/
psprint.conf folder of the main server installation folder. Any change to this
file would have an immediate effect on all client users of OpenOffice.org.
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The system administrator can also add new typefaces, made available to all
client users, but these changes will not be immediate like the printer settings;
instead, users will need to restart the program first.

The following sections deal with the options available in the program.

1.1. Printer setup

The configuration of printing devices is dramatically improved with each
new version of OpenOffice.org. In some GNU/Linux platform environments,
the program can automatically detect the printers installed on the system.
Nonetheless, we will probably still need to manually install these devices in
OpenOffice.org to ensure that the system works properly. We will see that,
although the theory may seem a little complicated, installing a printer is a
relatively straightforward process.

1.1.1. Installing a new printer

We will now look at the procedure for installing a printer:

1) Click on the New Printer option in the bottom left of the window. The

device selection window will appear:

Figure 2. New Device selection dialog box

Seleccione un tipo de dispositivo

Desea

* anadir una impresora
" anadir un fax

" conectar un convertidor PDF

Avanzar »» ’

_

(i

2) Select the Add Printer option. The driver selection window will now appear.
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Figure 3. Device driver selection window

Seleccionar un controlador

Seleccione un controlador adecuado

Generic Printer 4] Importar...

HF Color LaserJet PS

HF DesignJet 2500CF Eliminar
HF DeskJet 1200C/PS —|

HF Laserlet 4

HP LaserJet 4

HP LaserJet 4ML

HF LaserJet 4MP

HF LaserJet 4MP

HF LaserJet 4 Plus

HF LaserJet 4 Plus 300dpi
HP | ncar lat AQIA QMY PS 200AR [~

Cancelar == Regresar

3) Select the driver for your printer. If you cannot find your model or your
printer does not support PostScript technology, select the generic printer.

In GNU/Linux, the program can only print to printers with PostScript tech-
nology support. If you install a printer on your system that does not support
this technology, you will need to configure the system to be able to use it in-
directly. You can use a conversion program for this. Ghostscript is probably
the most comprehensive of these programs and will no doubt come as stan-
dard with your distribution.

If you have a printer of this sort, you will need to install it as a generic printer
in OpenOffice.org and ensure that the margins are correct when you configure
it.

If your printer supports PostScript, you will need to install the description file
that you will find on the disk or CD-ROM containing the drivers. You will
be able to identify this file quickly because it has the extension .ppd. You
need to install this to be able to access the advanced features of the printer
(clearly, these will depend on the brand and model of the device), which you
would be unable to access with a generic controller. Moreover — and this is very
important — you can use the default typefaces. Obviously, if you just want to
print, you can also select a generic printer and then set the margins correctly.

As with Windows, most distributions now come with drivers for different
printers, so you will probably already have a PPD that works with your print-
er. If not, you will probably find it on the manufacturer's drivers disk. If this
is not the case, Adobe has a large PPD file on its site: http://www.adobe.com/
products/printerdrivers/.


http://www.adobe.com/products/printerdrivers/
http://www.adobe.com/products/printerdrivers/
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If your printer can work internally with more typefaces than a normal
PostScript printer, you will also need to load the AFM files for these typefaces.
Copy these to the /share/psprint/fontmetric folder of the server installation
or to the client installation /user/psprint/fontmetric folder.

The steps for importing drivers during the creation of a new printer are as
follows:

e Click on Import in the device driver selection window.

¢ Select Browse to locate the folder containing the unpacked PPD files.

e Return to the device driver selection screen and select the driver that you
have just installed.

You can also delete the device driver when you create a new printer. Simply
select the driver and click on Delete.

If you want to delete a device control, be careful not to delete the generic
driver because OpenOffice.org will not work properly if you do. As we ex-
plained earlier, if you delete a driver, it will disappear from all clients using
this OpenOffice.org installation as a server.

Figure 4. Command Line selection window

Seleccione una linea de comando

Introduzea una linea de comando para comunicarse con este dispositivo.

Cancelar == Regresar

)

4) In the command line selection window, select the command that
OpenOffice.org will use to print on the printer. This command is Ip —d queue,
where queue is the name of the printer queue. After selecting it, click on Next.



GNUFDL e PID_00148480 11

OpenOffice.org. Basic program setup

Figure 5. Printer name selection screen

Seleccione un nombre

Introduzca un nombre para la impresora

Wi impresora

[~ Definir como impresora predeterminada

Cancelar == Regresar Crear ’

5) Enter the name of the printer in this window. This is the name you will
see in OpenOffice.org in the printer selection dialog box. You can also decide
here whether to make this your default printer. Once you have made your
choices, click on End.

6) When you return to the main screen, click on Test Page to check that the
configuration is correct. If the page does not print or prints incorrectly, you
will need to check the printer settings.

1.2. Changing the settings of a printer
After installing a printer, we can modity its settings using the oopadmin pro-

gram. Launch the program and select the printer you wish to modify from the

main screen and then click on the Properties button.
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Figure 6. Properties window Commands tab
piedades de Generic Printer______________ BERUEXITER R

A,E Ccmando‘Papel[D\sposmivo‘ itucion de fuente | Otra confi ion | =

+ ¥ 4

= AAR Estilos de parrafc Zix
O00E p+=@E
Confrontacion

Cuerpo de texto
Cuerpo de texto con sangri:

Configurar como = Ayuda \ Encabezado
|
Eliminar
Ipr =

| Impresora
Generic Printer

1]

Comando: lpr +10- 0 11 12 150 o =ik 0 <ile o Hl5

Seleccionar comando

contiene diferentes

de acuerdo con ¢l

mos scleccionar el Encabezado 7 =
ic no nos interesen /Automatico =
— —/
eptar ancelar
= =)
En la pestaiia de papel podemos especificar opciones como ¢l tamaiio y formato del
papel de la impresora asi como las propicdades de la bandcja Los valores escritos aqui
seran los valores por defecto de la impresora en o OpenOffice.org. Debemos de tener
en cuenta que no todos los valores estaran disponibles para todas las impresoras. ya que
estos dependeran de las especificaciones del archivo PPD.
Inicio imagen M4_008
Fig 8. Pestaiia de dispositivo en la ventana de propicdades -
Finimagen M4_008 3
Pagina 10/36 Convertir 6 100% INSERT STD HYP Nivel 1: WWS8Numl

The properties window will appear with several tabs. Here, you will need to
specify the characteristics based on the PPD file for the selected printer. To do
this, select the command from the list. You can also delete commands that
you do not need using the Delete button.

Figure 7. Properties window Paper tab

Formato de papel

Qrientacion [Portrait

-
Doble ISimpIex j
[<
=

|

Escala I 1

Aceptar | Cancelar |
L =

The paper tab is used to specify options such as the printer's paper size and
format, as well as tray properties. The values entered here will be the default
printer values in OpenOffice.org. Remember that not all values are available
for all printers as these will depend on the specifications in the PPD file.
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Figure 8. Properties window Device tab

Comando | Papel Dispositivo |Sustituci6n de fuente Olraconﬁguracién|
Opcién Valor actual
2400dpi
Manual Feed 720dpi

1440dpi

1200dpi

360dpi

144dpi

600dpi

7 2dpi
Nivel PostScript |de| controlador j
Color |de| controlador j
Profundidad de color |24 Bit j

L Aceptar | Cancelarﬁ

The device tab is used to enable the printer's special options. For example, if
your printer can only print in black and white, you should specify Grayscale
in the list of colour options. These commands and their meanings should be
in the printer manual or on manufacturer's website. If their function is not
entirely clear, look there first.

Figure 9. Properties window Font Substitution tab

i¥4 Propiedades de Generic Printer ’ - X

Comando | Papel | Dispositivo  Sustitucion de fuente | Otra configuracion |
v Activar sustitucion de fuente

Fuentes sustituidas

Albany -» Helvetica

Arial -» Helvetica

Courier New -» Courier
Cumberland -» Courier
Helmet -» Helvetica
Thorndale -» Times

Times New Roman -» Times
Timmons -» Times

Afadir | |

Sustituir fuente con fuente de impresora

| -l -]
Aceptar Cancelar
L | oo
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The Font Substitution tab is used to select an internal printer typeface for
each of the fonts installed on your computer. This will considerably reduce
the volume of data sent to the printer and the time taken to print documents.

We can enable or disable substitution for each individual printer installed on
the system.

Figure 10. Other Options tab

Comando ‘ Papel [ Dispositivo l Sustitucion de fuente  Otra configuracion ’

Margen izquierdo m 3: Predeterminado

Margen superior 6mm
Margen derecho 6mm
Margen inferior 6mm
Comentario

U: Aceptar CancelarJ

In the Other Options tab, you can enter the correct margins for your printer if
you are having printing trouble. You can also add a description of the device
in the Comment text box, which will be displayed in the OpenOffice.org print
dialog box.

Remember that many of these settings can be specified in the OpenOffice.org
Print or Print Settings dialog box, so it is not necessary to launch oopadmin
to modify settings. In fact, we recommend only using it to access the device's
advanced features.

1.3. Changing the name or deleting a printer

You can change the name of a printer or delete it from the main window of
the oopadmin utility. To do so, select the printer you wish to delete or change
the name of and select the button to perform the action.

If you wish to change the name, type a new one in the dialog box that appears
and then click on OK. This name cannot be the same as that of any other
printer installed on the system and it must be meaningful enough for you to
find it quickly if you have a lot of devices installed (if you work on a network,
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for example). The printer names must be the same for all users because during
document exchange, the selected printer will not change if a user has the same

printer available with the same name.

If you wish to delete a printer, bear in mind that the default printer created
by the system administrator cannot be deleted from this window.

Another option in this window is the possibility of making an installed printer
the default OpenOffice.org printer. To do this, double-click on it in the list of
names and mark the Default Printer option.

1.4. Configuring a fax machine

The oopadmin utility can also be used to configure a fax machine if a package
such as Efax or HylaFax is installed on your system. These and similar packages
with the same features usually come with the GNU/Linux distribution or you
can easily find packages for it.

To use a fax in OpenOffice.org, we need to install it in much the same way as
a printer. The steps are as follows:

Figure 11. Oopadmin main window

Impresoras instaladas

£ Generic Printer (Impresora predeterminada)
Q FPDF converter

>ambiar nombre..
Predeterminado
“aginade prueb:

Comando: Ipr

Controlador: Generic Printer (SGENPRT)
Ubicacion:

Comentario:

Nueva impresora ‘ Fuentes... Cerrar

i =

1) In the oopadmin main window, select the Add Printer option by clicking
on the corresponding button.
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Figure 12. New Device selection dialog box

Desea

¢ anadir una impresora
" anadir un fax

" conectar un convertidor PDF

I

Avanzar == I

L

2) In the new device selection dialog box, click on Connect a fax device fol-

lowed by Next to continue the process.

Figure 13. Driver selection dialog box

Para esta conexion de fax se debe usar el siguiente
controlador:

* el controlador predeterminado

" Un controlador especifico para sincronizar el formato
con otra impresora

Cancelar == Regresar

|

=

3) In this window, you can select whether to use the default driver or a specific
driver. If you decide to use a specific driver, a window will pop up where you

can select it. Click on Next to continue.
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Figure 14. Command Line selection window

Seleccione una linea de comando

Introduzea una linea de comando para comunicarse con este ¢ Ayuda

Cancelar == Regresar l

4

In this window, just as we did with the printers, we need to enter the command
that OpenOffice.org uses to communicate with the fax device. When entering
data in this window, we need to take into account two variables:

e (TMP) which will be replaced by a temporary file. If this variable is in
a terminal window, the fax PostScript code will be transmitted in a file.
Otherwise, standard piping will be used.

e (PHONE) which will be replaced by the fax number of the recipient.

After entering the relevant command line, click on Next to continue.

Figure 15. Printer name selection screen

Introduzca un nombre para el dispositivo de fax

Impresora de fax

[ Eliminar nimero de fax en la salida

== Regresar Crear I
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In this window, you must name your fax device and determine whether the
fax numbers marked in the text of the document should be deleted when
printing. Click on Finish to complete the creation of a new fax device.

You can now start sending faxes with OpenOffice.org. To do so, you will need
to print the document with the device you have created.

To indicate the fax number of the recipient, enter a text in the document. You
can also create a text field to insert this number from any database activated

in the program. The telephone number format is:

@@#[telephone_number]@@

Where [telephone_number] is the recipient's fax number. A valid fax number
entry might be: @@#9342060801@@.

If these characters, including the telephone number, are not printed, you must
enable the Fax number is deleted from printout option in the Properties op-
tion of the command line selection tab. Nonetheless, if you do not enter a tele-
phone number in the document you send, a dialog box will appear prompting
you to enter it after sending the document to print with the fax device.

In OpenOffice.org, we can enable the option of automatically sending docu-
ments to the default fax. To do this, right-click on the Function bar and then
select from the drop-down list:

Visible Buttons -> Send Default Fax.

Select the default fax in:

Tools -> Options -> Text Document -> Print.

Figure 16. Text Document Print options

Opciones - Documento de texto - Imprimir B ; X|

OpenOffice.org

Cargar/Guardar Contenido Paginas Notas
Configuracién del idioma [V Imagenes [V Paginas izquierdas & Sin
Internet
o ‘ol
B Documento de texto [V Tablas [V Paginas derechas Solo notas
General [v Dibujos I Inyertido " Fin del documento
Ver
Ayuda para el formate [V Campos de contral [~ Prospecto " Fin de la pagina
Cuadricula
Fuentes basicas (occic o st
[ Imprimir en negro
Tabla
Modificaciones Otros

Documento HTML

Hoja de calculo o Crear tareas individuales de impresion

Presentacion [ Bandeja segqun configuracion de impresora
Dibujo
Férmula Fax AROSANHP Laserjet 3150

Diagrama
Fuentes de datos

HEEEEEE

Aceptar | Cancelar Ayuda Reagresar
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Remember that documents have to be printed as separate jobs for each fax that
you need to send. Otherwise, the first recipient will receive all of the faxes.
Hence, you will need to open the Print Options dialog box by going to File ->
Print...-> Options and marking Create single print jobs.

Figure 17. Print Options dialog box

Opciones de impresion ] x|
Contenido Paginas Motas
eptar
[v Imagenes |v Paginas izquierdas & Sin 2
v Tablas [V Paginas derechas " Sdlo notas Cancelar
[v Dibujos 7 Invertido " Fin del documento
: Ayuda
v Campos de control [~ Prospecto £ Fin de la pagina
[V Fondo

[~ Imprimir en negro

Otros

[V ‘Crear tareas individuales de impresion:

|~ Bandeja segun configuracidn de impresora

Fax Fax ﬂ

1.5. Converting documents to PDFs

The most recent versions of OpenOffice.org already offer the option of au-
tomatically converting documents to PDF format simply by clicking on this
button in the program's Function bar.

It is also possible to create a printer that sends the document to a conversion
program such as Acrobat Distiller on Windows or Ghostscript if you use GNU/
Linux. For reference, we will take a brief look at the steps to take to create this
type of printer with oopadmin:

1) In the oopadmin main screen, select the New Printer option. This will open

the New Device selection dialog box.
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Figure 18. New Device selection dialog box

Desea

" anadir una impresora

" anadir un fax

* conectar un convertidor PDF

I

Cancelar Avanzar == I

2) Select the Connect to PDF converter option and then click on Next to con-

tinue.

Figure 19. Driver selection dialog box

Use el siguiente controlador para este convertidor PDF

" El controlador predeterminado
* E| controlador Adobe Distiller{tm):

" Un controlador especifico para adaptar el formato a
otra impresora

Cancelar == Regresar Avanzar »» I

=

3) In this window, you will need to select the driver you wish to use. If you
are using GNU/Linux, it is a good idea to use the generic driver. In Windows,
the best option is to use the Acrobat Distiller driver if you have this product

installed on your computer. Click on Next to continue.
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Figure 20. Command Line selection window

Seleccione una linea de comando

Introduzea una linea de comando para comunicarse con este ¢ Ayuda

{fustibinigs -q -dNOPAUSE -sDEVICE =pdfwrite -sOutputFile="{OUTFILE}" -

Directorio destino PDF:

Cancelar == Regresar

4) In this window, enter the command for the PostScript to PDF converter
that OpenOffice.org will use. You must also enter the folder in which to save
the PDFs created; if you do not enter a folder, the program will use the user's
personal folder. The variables we can use in the command line are as follows:

e (TMP) which will be replaced by a temporary file. If this variable is in a
terminal window, the PDF PostScript code will be transmitted in a file.

Otherwise, standardpiping will be used).

e (OUTFILE) which will be replaced by the target file, the name of which

will be created from the name of the document.

If Ghostscript or Adobe Acrobat Distiller are in the file search path, you can

simply use one of the preconfigured default command lines. Otherwise, you

will need to modify them.
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Figure 21. Printer name selection screen

Seleccione un nombre

Introduzea un nombre para la conexion PDF

Convertidor PDF

== Regresar Crear ’

= J

5) In this last window, enter the name of your PDF converter and click on
End to finish.

Now, to convert a document to PDF, simply print it to the PDF converter you
have just installed.

1.6. Font configuration

After working with the program for a while, you will realise that
OpenOffice.org does not display the same number of typefaces in all of the
documents you use. This is because not all available fonts can always be used.
We will now look at some of these features:

¢ Only typefaces in the document's font selector that can also be printed
will be displayed. The program assumes that you will only want to use the

fonts that can be printed out.

e If you are working with a HTML document or online, only the fonts that
can be displayed on screen will be available.

e In contrast, when you use Open Calc or Open Draw, you can use any of
the typefaces that can be printed and displayed on screen.

Where possible, OpenOffice.org always attempts to use the same typeface on
screen and in the printed document. This is referred to as WYSIWYG (What
you see is what you get). The program displays any incompatibilities and
problems with fonts in the bottom section of the Characters window, which
can be opened using the Format -> Character option in the main menu.
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Figure 22. Character formatting window

Caracteres’ )
\Fuente Efectos de fuente | Posicién ‘ Hiperenlace | Fondo
Fuente Estilo Tamafio
| | |Predeterminado [ [12
Nimbus Sans L Regular Italic 13 L
Nimbus Sans L Condensed Negrita 14
OpenSymbol Negrita cursiva 15
Standard Symbols L 16
URW Bookman L 18
URW Chancery L 20 ||
Idioma
\“'f/ Espafiol (Espafia) : \
Nimbus Roman No9 L,
Se usara la misma fuente en la impresora y en la pantalla.
‘ Aceptar ‘ ‘ Cancelar ‘ \ Ayuda | Restablecer

1.6.1. Adding new fonts

We can add new typefaces to OpenOffice.org. Depending on whether you are

using an up-to-date or earlier version of OpenOffice.org, these fonts may or

may not be available outside the program. The latest versions of the program

allow font sharing with other applications. This is not the case with 1.0.x

versions, which we can still find in many GNU/Linux distributions.

OpenOffice.org can display and print PostScript Type 1 and TrueType fonts.

The program works best with the latter type so we recommend you use these

wherever possible.

The steps for adding new typefaces to OpenOffice.org are as follows:

1) Launch the oopadmin program as we saw earlier and click on the Fonts

button in the main application window.

Figure 23. oopadmin fonts window

OpenSymbol, Predeterminado (opens___ttf)
OpenSymbol, Predeterminado (opens___ttf)

Nota: Las fuentes estan disponibles solo para la aplicacion.

L




GNUEFDL ¢ PID_00148480 24 OpenOffice.org. Basic program setup

2) The fonts window displays all typefaces added to OpenOffice.org. Click on
the Add button.

3) A dialog box will pop up where you can enter the name of the folder where
you wish to add new fonts or click on the ellipsis (...) button to select it.

Figure 24. Font selection dialog box

Cancelar
Seleccionar todas

Directorio fuente

]

[” Al anadir, crear solo softlinks

Elija primero la carpeta de la que desee tomar las fuentes y pulse luego la tecla
Aceptar para anadirlas.

L =)

4) A list will appear in the font selection dialog box with all available typefaces
in the folder you specified. To add them all, simply click on the relevant but-
ton. One useful option in this dialog box is the one to create symbolic font
file links, which means that the files will be used from their current location
rather than copied to the OpenOffice.org font folder. If you install fonts from
a device that will not always be available, such as a CD-ROM, unmark this
option to copy the files. Click on OK to complete the addition of the fonts.

When working on a server installation, fonts must be installed through this
so that the new fonts will be available to all users. If the user has write access
to the server installation folder, the fonts will be installed in the relevant in-
stallation folder of the workstation so that the user who installed them will
have access.
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1.6.2. Deleting and renaming fonts

Figure 25. oopadmin fonts window
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In the oopadmin fonts window, you can delete any typefaces you wish. To do
so, simply select them and click on the Delete button. In this window, you

will only be able to delete the typefaces you have added to the program.

You can also change the name of the fonts you install. For this, select the font
and then click on the Rename button. A new dialog box will pop up prompting
you for the new name of the font. If the font has several names, these will be
listed in the list field where you can enter the new name as a suggestion. After
entering the name, click on OK to complete the process.

If you select more than one font to rename, a different dialog box will appear
for each. This will also happen if you select a TrueType Collection (TTC), which
groups several fonts in a single file.
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2. Document interchange issues

One of the most useful features of OpenOffice.org is to be able to use the
same program on different platforms and interchange documents more or less
automatically with Microsoft Office, which is now the most widely used office

suite in the world.

Although compatibility between the two products is very good, particularly
when exporting documents, the formats used by Microsoft are very complex
and only partially documented, which means that absolute compatibility is
impossible. Even different versions of Microsoft programs have difficulty read-
ing documents written in previous versions of the program.

This section will attempt to clarify certain aspects of document interchange
that can create problems for users.

2.1. Document interchange with Microsoft Office programs

We will look at the diverse options to create smoother integration between
OpenOffice.org and Microsoft Office, divided into a number of subsections.

2.1.1. Options for greater compatibility with Word

Although one of the most important and indeed, famed, characteristics of
OpenOffice.org is its compatibility with Microsoft Office documents, difficul-
ties can be found in converting and importing documents to this format. We
will now look at OpenOffice.org's features for improving compatibility.

Firstly, we have to remember that format definitions are not the same in all
word processing programs. However, we can enable certain options to make
Writer behave in a similar way to Microsoft Word, thus enhancing compat-
ibility between the two. The settings we will now see are only available for
documents in use and cannot be defined globally for all documents. Hence,
they must be manually entered for each document with formatting problem
issues relating to these options.

To access the dialog box for enabling these options, go to the main menu
option:

Tools -> Options -> Text document -> General.
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Figure 26. Compatibility settings window

&

Opciones =Openofficeiorg Whiter=iGt bilidad’ X"

OpenOffice.org
|C argar/G ua(daﬂ
Configuracion de idioma Opciones
OpenOffice.org Writer P

General .
¥ Agregar espacio entre parrafos y tablas (en documento activo)

erl A )
¥ Agregar espacio entre parrafos y tablas en la parte superior de las paginas (en documento activo
Ayuda para formateado areg P P N P p paginas ( )

Opciones de compatibilidad de Sin nombre2

) I~ Usar formato de tabulacion de OpenOffice.org 1.1
|cuadricula ]
Fuentes predeterminadas (occidental) I~ No agregar espacio adicional entre las lineas de texto
[\mpnmldp < ! < ™ Usar interlineado de OpenOffice.org 1.1

¥ Agregar espacio de tablay parrafo en la parte inferior de las celdas de la tabla
™ Utilice el posicionamiento de objetos de OpenOffice.org 1.1

I Usar ajuste de texto de OpenOffice.org 1.1 alrededor de objetos

I~ Tenga en cuenta el estilo del ajuste al colocar objetos

Tabla
[Cambios|

Autotitulo

Correo electrénico de Combinar corresg
OpenOffice.org Writer/Web
OpenOffice.org Base
Graficos
Internet

< >

Usar como predeterminado

5 Aceptar Cancelar Ayuda Regresar

The compatibility section contains three options that may be of use here.

These are:

Add spacing between paragraphs and tables. Open Writer marks the
space between paragraphs differently to Microsoft Word. If you enter a
space before and after a paragraph, this space is inserted in Microsoft Word
documents, whereas Open Writer only inserts the bigger space. If you want
Writer to always insert two spaces, check this option.

Add paragraph and table spacing at tops of pages. When this option is
enabled, the space before the paragraph is also inserted at the top of the
page or column if the paragraph is found at the start of the document.
This also applies to page breaks. If you import a document from Microsoft
Word, the spaces are automatically added in the conversion process.

Align stop tab position. When this option is enabled, paragraphs con-
taining centred or right-aligned tabs are formatted together in the centre
or to theright. If this option is not enabled, only the text to the right of the
last tab is aligned to the right and the text left of the tab stays where it is.

2.1.2. Automatic conversion of Microsoft Office documents

The easiest and most intuitive way of converting a Microsoft Word, Excel or

PowerPoint document to the corresponding OpenOffice.org format is to open

it and save it in Writer, Calc or Impress format, respectively. OpenOffice.org

can also convert Office documents from Word to an older or more recent for-

mat.
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At this stage, we should point out one exception: password-protected Mi-
crosoft Office documents cannot be imported. Microsoft has not documented
the system it uses to protect its files, so it is impossible to open them. Any
protected documents that you wish to open will simply be skipped.

OpenOffice.org can import documents in a range of formats but it only has a
tool for automatically importing Word, Excel and PowerPoint documents and
their respective templates. One of its top features is the possibility of simulta-
neously converting whole folders of documents and templates.

For our peace of mind, the document converter does not modify the original
documents; instead, it makes copies of them.

The document conversion tool can be launched from the following menu
option:

File-> AutoPilot-> Document Converter.

The steps to this process are as follows:

Figure 27. First document converter screen
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su funcionalidad.
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‘ Cancelar ‘ ‘ Ayuda ‘ Continuar >> ‘

1) In the first screen, you will need to select the type of Microsoft Office doc-
uments you wish to convert. After selecting them, click on Continue.
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Figure 28. Second document converter screen
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2) In the second screen of the converter, select whether to convert the tem-
plates, documents or both and indicate the source and target folders. Click on
Continue to move on to the next step. If you have selected more than one
type of file, this screen will appear for each of the Microsoft Office file types
you marked.

Figure 29. Last document converter screen
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3) This screen confirms the data you have entered. Check it to make sure that
all of the options you have entered are correct. When you are sure that every-
thing is correct, click on the Convert button to launch the process. Informa-
tion on the process will appear on the converter screen. Once conversion is
complete, click on End to close the window.
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When the converted documents are displayed, you will notice that Word doc-
uments of 260 kb are reduced to a size of 50 kb. This dramatic reduction in
size may cause concern initially, but it does not mean that information in the

Word document has been lost.

The reason for it is that Word (like all Microsoft Office documents) uses a bi-
nary format, while OpenOffice.org documents use a plain text file that can be
read with any text editor. This considerably reduces the size. In addition, the
OpenOffice.org format also automatically compresses files, so the document

you are seeing is really a compressed XML document.

If you open this document in Windows with WinRAR or WinZip, you will
see that it is actually a series of text files organised into different folders. This
means that we can be safe in the knowledge that, even if the OpenOffice.org
product were to disappear, we would still be able to recover the information
created with the program. If this were to happen with Microsoft Office, the
problems would be far more serious.

2.1.3. Automatically saving documents in Office format

If you often work with Microsoft Office documents, you may find it tedious
to use the native OpenOffice.org format and always have to convert the doc-
uments to Office format before sending them to others. There is an option
that you can use to define the default format in which to save the document
in the File -> Save menu option or when you click on Save document in the
Function bar.

To do this, go to the Tools-> Options...-> Load/Save-> General menu option.
The following window will appear:

Figure 30. General options dialog box for saving documents
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In the Default file format group, you can select a type of document and then
select the default format in which to save it from those available for each
type of document. In this dialog box, select the Microsoft Office format (for
example, Microsoft Excel 97/2000/XP for spreadsheets).

2.2. Interchanging documents between platforms

The previous section looked at the process of installing new fonts that can
be used on-screen and/or printed out, but we have not yet discussed one of
the basic points that need to be considered if we interchange documents with

people using OpenOffice.org on other platforms.

We may well find ourselves in a situation where we need to write a document
such as a presentation on GNU/Linux. We may then have to display our pre-
sentation on a computer with a version of OpenOffice.org installed on Win-
dows. When we do so, we will see that it is displayed very differently to how
we saw it when we were composing it and that the quality of the typeface used
to display the texts is considerably poorer than the original.

This is because we used fonts that were available on our GNU/Linux system but
which are not available on the version of Windows on which we are viewing

our presentation.

There are two basic options for solving these problems. The first and recom-
mended option is to use the same fonts on all platforms. If you have a Mi-
crosoft Windows licence, you can install its fonts on a GNU/Linux computer
or an installation with a different partition. Most distributions have automat-

ic recovery utilities.

If this is not possible, you can use the replacement table for the various fonts
you use on the different platforms. The idea behind this is that if the system
cannot find the font of a document, it will use a standard typeface, which
is very often different to what we expected and very possibly of an inferior

quality.

To make substitutions, go to the Tools -> Options... -> OpenOffice.org -> Fonts
menu option.
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Figure 31. Font substitution screen
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1) The first thing you must do is to activate font substitution by marking the
Apply replacement table option.

2) Select the original font and then the font to replace it. One example would
be to replace the StarMath font with Wingdings for working in Windows
or vice versa if you are using GNU/Linux. Then click on the green tick.

3) In the font list, check the Always option for the substitution you have just
made.
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4. Installing and configuring spellcheckers

There are a few easy steps that need to be taken before using a new spellcheck-
er in OpenOffice.org. Small utilities are currently available for installing new
dictionaries more or less automatically depending on our platform. However,
here we will study the manual process because it is the safest and will work in

all scenarios. As we shall see, the process is not at all complicated.

There are two parts to the process. The first is the installation of the dictionar-
ies to a specific folder in our system and the second is enabling of the dictio-
naries so that we can correct our documents with them. Dictionaries consist of
two files with different extensions. One has the extension .DIC and contains
the list of words, while the other has the extension .AFF and includes the affix
combination rules.

Dictionaries can be downloaded as compressed packages from the
OpenOffice.org project website:
http://lingucomponent.openoffice.org/download_dictionary.html.

Most packages contain a document with installation instructions. Nonethe-
less, we will describe the process briefly.

1) Firstly, you must quit the program. In Windows, if you use the Quickstarter
option, you will need to right-click the OpenOffice.org icon in the status bar
and select Exit Quickstarter.

2) You must then copy the decompressed files from the zip package to your

user profile folder, /user/wordbook.

3) You now need to edit the dictionary.lst file, which is located in the folder
where you just copied the decompressed files. For example, you will enter the
following for the Spanish dictionary:

DICT es ES es_ES

This line tells OpenOffice.org that it must use a dictionary containing two files
named es_ES (es_ES.aff and es_ES.dic) in the local configuration specified as
es ES which, in this case, is Spanish of Spain. As you can see, the name of the
affix file and list of words must be the same if OpenOffice.org is to register it.

Now that your dictionary has been registered correctly, you will need to acti-
vate it. Dictionaries are not enabled by default because program performance

is very slow if several are running at the same time. You must therefore man-
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ually enable the dictionaries you wish to use and only ever leave active the
ones you regularly use. This will considerably enhance the performance of
OpenOffice.org. The steps for enabling a dictionary are as follows:

4) Launch OpenOffice.org again and go to the following option in the

program's main menu:

Tools -> Options... -> Language Settings -> Writing Aids

and then click on Edit in this window.

Figure 32. Edit modules dialog box
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The Edit modules dialog box contains a list of all available languages. The
names of the languages with a blue tick and the letters ABC before them are
the languages for which we have a registered dictionary. As explained earlier,
just because a dictionary is registered, this does not mean that it is enabled.

5) To enable a dictionary for a language, mark the OpenOffice MySpell
SpellChecker option in the spelling group.

If this group does not appear it is because there is no registered spellchecker
for this language. If you have followed all of the steps correctly, make sure that
the values you entered in the dictionary.Ist file were correct. All dictionaries
come with a Help file in the compressed package explaining this procedure.
If in doubt, look here for information.

4.1. Advanced dictionary configuration
This section will describe how to install dictionaries on a server installation

and look at some of the problems we may come across when installing dictio-
naries for the OpenOffice spellchecker and their possible solutions.
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4.1.1. Installing dictionaries on a server

From version 1.0.1 of OpenOffice.org onwards, it is possible to install dictio-
naries on a server for remote access by all users. In the previous section, we
saw how to install a dictionary for a specific user, where the files were copied
and changes made in the user profile folder. It is a good idea to allow users
to install the dictionaries they need but it can also be useful to install group
dictionaries for all of the clients of a server installation. This means that inex-

perienced users will not have to install the dictionaries themselves.

The system administrator or anybody with superuser permissions can install
group dictionaries in the /share/dict/ooo/ server installation folder. These dic-
tionaries will be available to all system users. There is no need to describe the
procedure here as it is the same as the one we have just seen.

However, users will not be able to use the dictionary until they exit
OpenOffice.org completely and enable the dictionary using the Tools -> Op-
tions... -> Language Settings -> Writing Aids menu option and the Edit button.
4.1.2. Dictionary paths

Most problems with dictionaries occur because OpenOffice.org cannot find
them, so make sure that the values that were entered in the program are correct
before you start investigating other possibilities.

These values can be accessed from:

Tools -> Options... -> OpenOffice.org -> Paths.

Figure 33. Path configuration dialog box
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In this screen, check that the values for Dictionaries and User-defined Dictio-
naries are correct and that the specified folders actually contain the dictionary
files and dictionary.Ist. If you need to edit these values, click on the Edit but-
ton and select the correct path.

4.1.3. Font issues

If the dictionary has been registered and enabled but does not correct (for
example, it highlights all of our words although they are correct), the typeface
used is probably not supported by the spellchecker engine. The two most likely
reasons for this is that you are using a symbol font or that you are working
with a typeface that has not been installed on your system.

This can occur with a font called Thorndale, which is the default font in many
OpenOffice.org versions but which will not be installed on your system un-
less you have installed StarOffice at some point in the past. It can lead to
OpenOffice.org being unable to correct a document properly, though this does
not apply to all versions of the program.
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Summary

In this unit, we have seen diverse ways of configuring and installing devices
in the OpenOffice.org program, which is the main root of problems for users,
and we have looked at possible solutions for these.

We have focused particularly on aspects such as compatibility between
OpenOffice.org and Microsoft Office documents, which is usually one of the
main sources of headaches for users since, for better or for worse, we live in

an information society dominated by Microsoft products.






	OpenOffice.org. Basic program setup
	Introduction
	Index
	1. Installing and configuring printers in GNU/Linux
	1.1. Printer setup
	1.1.1. Installing a new printer

	1.2. Changing the settings of a printer
	1.3. Changing the name or deleting a printer
	1.4. Configuring a fax machine
	1.5. Converting documents to PDFs
	1.6. Font configuration
	1.6.1. Adding new fonts
	1.6.2. Deleting and renaming fonts


	2. Document interchange issues
	2.1. Document interchange with Microsoft Office programs
	2.1.1. Options for greater compatibility with Word
	2.1.2. Automatic conversion of Microsoft Office documents
	2.1.3. Automatically saving documents in Office format

	2.2. Interchanging documents between platforms

	4. Installing and configuring spellcheckers
	4.1. Advanced dictionary configuration
	4.1.1. Installing dictionaries on a server
	4.1.2. Dictionary paths
	4.1.3. Font issues


	Summary


