Open Writer.
OpenOffice.org
word processor

David Megias Jiménez (coordinador)

Jordi Mas (coordinador)

Ana-Elena Guerrero Roldan (coordinadora)
Jestus Corrius i Llavina

PID_00148476

Universitat Oberta
de Catalunya

www.uoc.edu




GNUFDL e PID_00148476 Open Writer. OpenOffice.org word processor

© 2009, FUOC. Se garantiza permiso para copiar, distribuir y modificar este documento segiin los términos de la GNU Free
Documentation License, Version 1.2 o cualquiera posterior publicada por la Free Software Foundation, sin secciones invariantes ni
textos de cubierta delantera o trasera. Se dispone de una copia de la licencia en el apartado "GNU Free Documentation License" de
este documento.



GNUFDL e PID_00148476

Open Writer. OpenOffice.org word processor

Index
INtroduCtION. ... ...coooiiiiiii e
1. The Writer working environment....................ccccooiiiiiiininneennn.
1.1. Customising the toolDArs .........ccccceeiiiiiiiiiiiiiiiee e
1.2, CustomiSing MEeNUS .......cooeeeviiiiiiiiiieeeee e e
1.3.  Setting keyboard ShOTtCULS ........ccovivviiiiiiiiiiieiiieieeeeeeeee e
1.4. Changing the size of program elements ..........cccccceerevieeeeennnnnee.
2. Basic Open Writer functionality......................ccciiiiinninne.
2.1. Creating a sample dOCUMENT ......c.ccccuvieiiiiiiiieerniiiieee e e
2.2, AUOTEXt oo
2.2.1. Specifying new paths ....cccccccceeiiiiiieeiiniiiiienieeeee e
2.2.2. Creating new categories ..........cccccevvvvuiiiiiininniecninnnnnn,
2.2.3. Inserting AutoText in documents .......ccccecceeeeerreinneeennn.
3. Document formatting................cccccoviiiiniii
3.1.  Character formatting .........ccccceerviiiiieiiiiiiieiiieec e
3.1.1. Creating custom COIOUTIS .....cccceveervrrreeeeiriiiiieeiieeeeene
3.1.2. Using the Stylist in Fill Format Mode ..........ccceeuueeeenn.
3.1.3. Character formatting dialog box ........ccccoevvieiiiiinneennn.
3.2. Paragraph formatting ......c.ccccceeeeeriiiieniiieniee e
3.2.1. TaDS o
3.2.2. Paragraph formatting dialog boxX .......cceccvrrieirrieennnnen.
3.3. Bullets and NUMDbETING ......ccceereeiiiiiiiiiiiieee e
3.3.1. Creating an outline .........ccccccceeeiiiiiiiiiiiiiiiiieeeeeeee e,
3.3.2. Configuring numbering, bullets and outlines ...............
3.3.3. Position and spacing between levels ..........cccceccueeeennn.
4. Word Completion and AutoFormat...............ccccooooiiinniiiiiinnnnnne
4.1. Configuring AUtOReplace .......ccccocoveeeeiriiiiiieiiiiiieee e,
4.2. Configuring automatic UPPeICase ........cccceeeevveererriiieeeeerrenieeeennns
4.3. Turning off AUtOCOTITECE ......eeeiriiriiieiiiiiiiieereee e
4.4, Word Completion ......ccccoeecuiieiiiiiiieeeiiiitee e
5. Using graphics and sounds................ccccooiiiiiiiiiiiiiiiinniiee e,
5.1. Using the OpenOffice.org picture and sound gallery .................
5.1.1. Creating gallery themes .........c.cccoceiiviiiiniiiiniiinninnnn.

10
12
13

15
15
18
19
19
20

21
21
22
23
24
29
29
30
36
38
38
40

42
42
43
45
48

51
52
53

57






GNUFDL e PID_00148476 5 Open Writer. OpenOffice.org word processor

Introduction

Open Writer is the OpenOffice.org text document creation application. As we
shall see, the program can carry out the same functions as any other program
of this nature on the market and offers filters for other types of document
(Microsoft Word included), graphics support, the creation of books and tables,
non-consecutive selections of blocks of text, version control and the automat-
ic creation of tables of contents.

This unit will deal with general use of the program, but it will not cover the
basics of document composition and editing because it is not the aim here. We
will look at the features of OpenOffice.org for users who routinely use other
text editors, such as Microsoft Word or WordPerfect, so that they can weigh
up the possibility of using OpenOffice.org as an alternative. Nonetheless, we
will cover key concepts when considered necessary.

The main aims of this unit are:

1) todescribe the working environment of the Open Writer program in order

to familiarise students with it,

2) to teach students how to use the basic tools for composing and formatting
text documents, and

3) to explain how to set up the text composition help features in order to
adapt them to our working needs.
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1. The Writer working environment

This section looks at the working environment of the Open Writer program,
offering an introduction to familiarise readers with the environment and how
it can be customised. Some of the concepts covered here will also prove useful

for other components of OpenOffice.org.

Writer can be launched from any OpenOffice.org application by selecting the
File -> New -> Text Document menu option.

Tips can be very useful for learning about the different features of the program.
Tips are displayed for each of the labels and icons on the screen so we can find
out what they do simply by pointing the mouse at them. You can enable or
disable this option using the Help -> Tips menu option.

If you need help with a dialog box or window, you can always click on the
Help button or press F1. OpenOffice.org is a very well documented program
and its Help is very good. You should learn to use it whenever you have a
query about something as this will enhance your experience as users.

Figure 1. The Writer working environment
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We will now describe the diverse elements in the program's workspace:

e The Menu bar contains the various actions that can be carried out global-
ly across the OpenOffice.org program and those that are specific to Writ-
er. New entries can sometimes appear in this bar, such as when you are

working with tables.

¢ TheFunction bar indicates the full path of the file being edited and pro-

vides a shortcut to the program's global features.

¢ The Object bar is used to apply formatting to the objects you are working
with at a given time. It will most often display text formatting tools but
it may also contain table and drawing tools if you are working with these
elements.

¢ The horizontal ruler displays the page dimensions and can be used to
insert tab stops. The measurement units of the ruler can be changed very
quickly by right-clicking on it. Though not enabled by default, the pro-
gram has a vertical ruler too, which is very useful for working with draw-
ings and tables. We will see it shortly.

e The Main toolbar, positioned vertically down the left-hand side of the
document, gives quick access to the most common word processing func-

tions.

e The Status bar at the bottom of the screen has a number of functions,
which include viewing page numbers, applying page styles (by right-click-
ing on Standard), changing zoom percentage and changing the default
type of text selection.

1.1. Customising the toolbars

All OpenOffice.org components display lots of icons on screen simultaneous-
ly so that the user can access functions very quickly. To display all of the tool-
bars, select them in the drop-down list that appears after selecting the View
-> Toolbars menu option. Here, you can select the toolbars that you want the
program to display. We recommend that you always keep the Function, Ob-
ject and Main toolbars checked as these give access to most of the actions that
you will need.

Most toolbar buttons only carry out one action, which is the one indicated in
the tip that appears when you hover over it with the mouse. However, some

buttons have several functions, in which case you will see a green arrow next
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to the button image. To see all of the button's options, click and hold down
the left mouse button over the image. This can either produce a new toolbar
or display a drop-down list of options.

For example, if you click on the Insert button, the first one on the Main tool-
bar, the Insert Table dialog box will appear. However, if you hold down the
left mouse button as you click on it, a toolbar will appear containing more

buttons with drop-down lists.

Figure 2. Element insertion toolbars
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If you often use the various toolbar options, you can click on the blue space
around its title to make it into a real toolbar that can be dragged to any point
of the screen for direct access to its various functions.

The appearance of the Object bar changes according to the context in which
you are working. For example, its buttons will vary if you are in the middle
of a paragraph of text or a table.

Figure 3. Object bar in text context
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For paragraphs, it displays basic text formatting elements, which you will be
very familiar with at this stage.

Figure 4. Object bar in table context
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If you are inside a table, it will display the most common actions for working
with tables. Very often in a table we need to use text formatting tools. To do
this, simply click on the button with the blue arrow at the end of the Object
bar. This button allows us to manually toggle between the two contexts.

If you find that the buttons on the Object bar are the fastest and most conve-
nient way of formatting text, you may need to add new features to the bar's
default ones. OpenOffice.org only includes the most common ones by default.

To view all of the available options, simply right-click the relevant toolbar and
select the Visible Buttons option from the menu. This will open a drop-down
list where you can select all of the available actions for the bar that you just
clicked on.
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If, besides modifying the available buttons, you wish to organise them using
a different criteria to the program, you will need to use the customise toolbars
tool. To call it up, right-click on the toolbar you wish to customise and select
the Customize option.

Figure 5. Customise toolbars tool
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The left-hand list contains all of the program's functions grouped into cate-
gories, which you can add to your toolbar by clicking on the Add button.
The Move Up and Move Down buttons move the added actions along the bar
while the Icons button is used to customise the button images. Note that some
of the program features (the least common ones) do not have a predefined
image. To restore the toolbar to the default program values, simply click on
the Default button.

1.2. Customising menus

Finally, some computer programs have adopted a strategy of hiding menu op-
tions when they are unavailable. In this case, the menu options that cannot be
accessed simply disappear instead of being greyed out. This can lead to con-
fusion as users may think that the program feature does not exist or that there
is a problem with the program. In contrast, if an option is greyed out and dis-
abled, the user will realise that the option is not available in this context. The
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OpenOffice.org program behaves differently here, depending on the version
you use. To enable inactive menus, go to Tools -> Options -> OpenOffice->

View and mark the Inactive menu items option.

It is possible to customise application menus, just as we did with toolbars.
Normally, however, it is much quicker to access functions through toolbars,
so we would recommend using these for the more common activities. Besides,
customising menus is for very advanced users. Your average user would not

modify default program options.

To go to the menu configuration tool, go to Tools -> Configure and select the
Menu tab.

Figure 6. Customise menus tool
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Each of the different OpenOffice.org applications (Writer, Calc, Impress etc.)
has its own menus, so be sure to access this option from the application you
wish to customise. Customised menus are saved in files with the .cfg extension
in the /user/config folder of the personal profile of each user. When we create,

modify or save menus, we make changes to these files.

The customising procedure is similar to the one seen above. New menus and
items can be created and existing ones can be deleted. In this case, the func-
tions are divided into categories and subfunctions in the two windows in the
lower half of the dialog box.
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1.3. Setting keyboard shortcuts

Another useful option of this configuration dialog box can be found in the
Keyboard tab. We can also access it from Tools-> Configure...

Figure 7. Customise keyboard tool

ad personalizar =
Mentis [Teclado| Barras de herramientas | Eventos
Combinacion de teclas OpenOffice.org
B :
F2 Formula Wiltey
F3 Ejecutar entrada Aut
F4
F5 Navegador
F7 Revision ortografica
F8 Activar Seleccion Ex
F9 Campos
F11 Estilo y formato
F12 Activar/desactivar n
Down Ir alalinea de abajo
Up Ir alalinea de arriba~
4 »
Funciones
Area Funcién Teclas
Ver Abrir
Plantillas Acerca de OpenOffic
Editar Asistencia
Opciones Asistente: Presentac
BASIC Asistentes
Insertar AutoPiloto: Fuente de Cargar...
Documentos Ayuda
Formato Ayuda activa Guardar...
Campos de cont|  Ayuda de OpenOfficev
o 5 T RS Restablecer
Aceptar Cancelar Ayuda Restablecer

In OpenOffice.org, actions can be assigned to keys or — as is more often the
case — key combinations. Some keys already have default actions assigned to
them by the program. These include F11, which launches the Stylist box, and
F5, which launches the Navigator. Some actions depend on the application
you are in at the time. In Writer, for example, F12 turns numbering on or off
while in Calc it is used to define a group of cells.

In addition to the program's functions, keyboard shortcuts can also be as-
signed to the macros we create. This allows users to create key combinations
that can be used, for instance, to insert a text for which we would otherwise
need to press a number of keys and set a number of formatting options every

time if we were to create it manually.
The required steps for creating a new keyboard shortcut are:

1) Inthekey combination list, select the key or combination of keys to which
you would like to assign a function.
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2) In the list of categories, specify the category of the function you wish to
assign. To assign a macro, select the category where you created it. The
actions available in this category will be shown automatically in the func-

tion window.

3) Select the command you wish to assign to the key in the function window.

4) Click on the Modify button. The name of the command will be inserted

alongside the name of the key in the list of key combinations.

Even if you do not want to assign or modify a program key, this dialog box
is the quickest reference for the program's shortcut keys and can be useful for
finding out which key or key combination can be used to perform a given
action.

1.4. Changing the size of program elements

For people with some form of visual impairment or those who simply wish
to work more comfortably, it is important to be familiar with the accessibility
options of OpenOffice.org.

Although it is not the aim of this unit to cover these topics in detail, we will
look at how to change the size of program elements to make them bigger than
normal. To do this, bring up the following dialog box by going to the menu
option:

Tools -> Options... -> OpenOffice.org -> View.

Figure 8. Display options dialog box
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Although this window contains various settings, such as the appearance of the
program windows, the options of interest to us here are Scale and Icon size.
For example, we can select a scale of 120% and a Large icon size and click on
OK for the changes to take place immediately in the program interface.
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Remember that any changes made to these options will only affect the pro-
gram display. If you increase the scale, text fonts will appear bigger but their
actual size (the size they will be if they are printed and the size at which other
people will see them) will be determined by the size of the font.
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2. Basic Open Writer functionality

This section will look at how Writer can be used for everyday word processing.
We will begin by creating a sample document that will serve to introduce us to
the basic features of the program and we will then look at the various options

for formatting our text.
2.1. Creating a sample document

We will create a text document to familiarise ourselves with the Writer envi-
ronment. To do so, follow these instructions step by step.

1) Launch OpenOffice.org and create a new text document by selecting the
File -> New -> Text Document option from the main menu. This will open a

new window.
2) Type the following text in the blank document: "Planning for UOC work".

3) Press the F11 key to open the Stylist and check that the title of the dialog
box reads "Paragraph Styles" by clicking on the first button on the toolbar
inside the box. If you click on the other buttons, you can see the different
styles available in the program.

Figure 9. Stylist displaying paragraph styles
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4) If the size of the text on the screen is too big or too small to work with
comfortably, you can change the scale of the zoom using the View -> Zoom
menu option or by double-clicking on the percentage in the program's status
bar.

5) We will now look at the Stylist. The first thing to do here is to click the
mouse to position the cursor somewhere in the text you have entered, and
then double-click on the Heading 1 style in the Stylist. The text will automat-

ically change to adapt to the selection.

6) Press the End key to move to the end of the text and then press Enter to
go to the next line.

7) Type the list of subjects you have this term, separating each one with a new
line. Once you have completed the list, select them all with the mouse and
click on the Bullets On/Off button in the Object bar.

8) With the text selected, click on the Increase Indent button. This will indent
the text to the right.

9) We will now change the formatting of the first paragraph. To do so, go to
the "Planning for UOC work" text, right-click on it and select Paragraph from

the context menu.

Figure 10. Paragraph formatting window
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In the spacing below paragraph box, increase the value to 0.5 cm, for example.
When you click on OK, you will see that the distance between the title and
the text has increased substantially.
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10) To make the title appear more attractive, we are going to change the colour.
To do this, select it again and go to the Format -> Character main menu option
and select the Font Effects tab in the dialog box.

Figure 11. Character formatting window

a Caracteres: s
Fuente |Efectos de fuente| Posicién Hiperenlace | Fondo
Subrayado Efectos
(Ninguno)

Tachado Relieve

(Sin) : (Ninguno)

Color de fuente [] Contorno

] Automético - Sombra

| Intermitente
Oculto
Nimbus Roman No9 L
Aceptar Cancelar Ayuda Restablecer

In the drop-down font Color list, select your favourite colour from those avail-
able. Click on OK to see the colour change.

11) Go to the end of the text you have written. If this is the text you have
formatted as bullet points, you will need to press Enter twice: once to move
on to the next line and one to automatically stop bullet formatting. We will

now insert a table.

12) Go to the Main toolbar and press and hold the Insert button until the
Insert toolbar appears. Go to the Insert table button and select the number
of rows and columns you wish to insert. Use two columns and the number
of subjects you typed in for the number of rows, plus one extra for the title.
Therefore, if you entered three subjects, the table will be 4 x 2.

13) In the first row, write "Subject" in the first column and "Hours' study" in
the second. In the rest of the rows, type in the name of the subjects and the
hours you plan to spend studying for them. When you have completed the
table, click outside it.

14) Finally, we are going to insert a header in the document. To do this, go
to the Insert -> Header -> Default menu option to automatically insert a text
field at the top of the page.
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15) Position the cursor inside the header by clicking on it with the mouse and
then select the fields you wish to insert. For this step, go to the Main toolbar
and click on the Insert Fields button but do not release the left mouse button
until the insertable text fields menu has appeared. Here, you can select the
Date or Page Number options, for example. Inside the header, if you click once
on the tab, you will be taken to the centre of the field and if you click twice,
you will be taken to the far right.

If you have followed this example word for word, you will already be familiar
with the basics of the program and can start working on your documents with

total peace of mind if you are used to working with office suites.

2.2. AutoText

The AutoText feature is used to enter a text or a text combined with other
elements very quickly. It is very useful if you often find yourself writing the
same text over and over, such as an e-mail signature or a document header.
We will now look in detail at how we can customise the program to insert
these items.

1) In a Writer document, create the text you wish to convert into autotext.
You can also add graphics.

2) Select the text you have typed with the mouse and click on the Edit Auto-
Text button.

Figure 12. AutoText dialog box
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3) Enter a name for the AutoText in the Name field and its shortcut in the
same field. Choose this carefully because it is very important as we will see
in a moment.

4) In the list underneath the name and shortcut fields, select the category it
should belong to. Categories are simply folders in which to organise our texts.
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5) Click and hold the left mouse button on the AutoText button and select the
New option from the menu. The AutoText is now created. You will be able to

see it in the category you selected and you can insert it if you click on Insert.
2.2.1. Specifying new paths

If you want to use other folders besides the default ones of the OpenOffice.org
program to save AutoText items, you will need to indicate them by clicking

on the Path button, which will bring up the dialog box below.

Figure 13. Select Paths dialog box
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This dialog box displays the default paths but new ones can be added by click-
ing on Add and then selecting the folder. To change the program's default
AutoText paths, go to Tools -> Options -> OpenOffice.org -> Paths.

2.2.2. Creating new categories

As we mentioned above, AutoText categories are simply recipients for organ-
ising AutoTexts. The program already comes with some categories but you will
probably need to create new ones to organise these texts according to your
needs.

To create a new AutoText category, call up the AutoText dialog box by clicking
on the Edit AutoText button in the Main toolbar and clicking on the Cate-
gories button. This will bring up the following dialog box.

Figure 14. Edit Categories dialog box

= Modificarareas’ )
Area Ruta
Aceptar
| file://jusr/lib/openoffice.org2.0/share/autot :
Lista de seleccion Gancelay
. Ayuda
Estandar file://jusr/libjopenoffice.org2.0/share/autotext/e
My AutoText file:///home/jesus/.openoffice.org2.0/user/autot
Only for Templates file://jusr/libjopenoffice.org2.0/share/autotext/e
Solo para plantillas file://fusr/lib/openoffice.org2.0/share/autotext/e
Standard file://jusr/libjopenoffice.org2.0/share/autotext/e
Tarjetas de visita, trab. (85 x 50) file://fusr/lib/openoffice.org2.0/share/autotext/e
< »

In the Category text field, type in the new name for the category you wish to
create and select the path to its location. If the desired path does not appear
in the list of paths, you will need to create it in the way we saw in the previous
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section. After selecting the name and path of the new category, click on New
to add it. You can also delete categories you no longer need in this dialog box.
Click on OK to save the changes made.

When you return to the AutoText dialog box, you will see the new category.
At this point, you may wish to re-classify elements into the new category you
have created. To move an AutoText from one category to another, simply select
it, and without letting go of the mouse button, drag it to the new category.
As you drag it, a bar will appear to indicate which category you are dragging

the autotext to.

2.2.3. Inserting AutoText in documents

Thus far we have seen how to create AutoTexts and how to organise them, but
we have not seen how they can be used in our documents. The easiest option
is to position the cursor where you want to insert the text and then click and
hold down the Edit AutoText button on the Main toolbar. A list of available
categories will appear. Simply select the AutoText you require to automatically
insert it in the document.

A much quicker way of inserting an AutoText is to use its shortcut. Obvious-
ly, it can be very difficult to remember all of our shortcuts but it is not too
hard to remember the ones we use most often. To insert an AutoText with a
shortcut, type the latter in the document and press F3. For example, to insert
an AutoText called My AutoText with the MAT shortcut, type these three let-
ters in the document and then press F3. This will insert the contents of the
AutoText you have created.
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3. Document formatting

Formatting a text or section of text is one of the basic functions of any word
processing program. In fact, it is essential considering that, when it comes to
creating documents, we spend most of our time on formatting. As a result, we
think that it is important to mention some of the formatting possibilities of
OpenOffice.org.

3.1. Character formatting

To format characters quickly using basic operations, such as changing font
and size and applying styles such as bold type, italics and underlining, we
can use the program's Object bar. This bar will be very familiar to users who
have worked with word processing programs before, but there are two features
worth mentioning here: Character color and Character background, located
at the end of the Object bar.

If you click and hold on these buttons, you can select the font or highlighting
colour.

Figure 15. Character color selection dialog box
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Simply clicking on the selected text will apply the last font or highlighting
colour you chose. Any of the colours in the palette can be used or you can

even create your own custom colours.
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3.1.1. Creating custom colours

To define a new custom colour, go to the following menu option: Tools ->
Options... -> OpenOffice.org -> Colors, where you will see the colours in the
system palette.

Figure 16. Colour preferences dialog box
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To add a specific colour, select RGB or CMYK and enter the combination of
values. If you do not know the values or prefer to use your intuition, click
on Edit...

Figure 17. Color selection dialog box
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Once you have chosen the colour you require, click on OK to return to the
previous window. In the Name field, delete the name of the current colour and
type in the name you wish to give to your new colour (e.g. "Lettuce green").
Finally, click on Add to insert your new colour in the program palette.
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3.1.2. Using the Stylist in Fill Format Mode

If you have ever used Microsoft Word, you will probably be familiar with the
Format Painter tool, which copies the formatting features from one element
to another. OpenOffice.org has a similar tool called Fill Format Mode. We will
see step by step how this characteristic can help us with our work.

1) Open the Stylist using the Format -> Stylist menu option or by pressing
F11. The Fill Format Mode button has a picture of a pouring can on it and is
located in the upper section of the window. Click on it to enable it. The colour

of the button background will change.

Figure 18. Stylist
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2) Select the category you wish to apply to the text from the available styles
list. You may wish to apply a style that has not yet been defined to the text,
in which case right-click on the list of available styles and then select New
to set the new style you want to use. If you do not want to enter all of the
options and simply wish to copy the text style as quickly as possible, select
the text with the original style in the document and click on the New Style
From Selection button in the Styles and Formatting box.
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Figure 19. Create Style dialog box
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This will bring up the Create Style dialog box, where you will need to enter a
name for the style you have created from the text format.

3) Once you have selected the style, position the cursor in the text or on the
object you wish to format and click on it. The style will be applied to every
element you click on. When you have finished formatting, close the Stylist or
click on the Fill Format Mode button.

3.1.3. Character formatting dialog box

Thus far, we have looked at the more basic features of character formatting.
The advanced options are located in the Character formatting dialog box. To
access these, select the text you wish to format and then to go to the Format
-> Character menu option, or right-click the text and select this option from
the context menu. In this section, we will look at the options offered in this
dialog box.

When you select the text to apply character formatting to, be careful not to
select the spaces between the selection and the rest of the text because these
will also be formatted and the result will probably not be as you had planned.
To avoid this, select words by double-clicking on them. If you want to select
more than one word, double-click on one and drag the cursor across the rest
of the words. This will give you greater control over the elements selected.
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Figure 20. Character formatting font tab
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In the Font tab, we can configure the following character style settings:

¢ Font displays the current typeface and allows us to select any of the avail-
able fonts.

e Style allows us to choose a style to apply to the selected font. The list of
styles will vary depending on the characteristics of the font.

e Size allows us to select the size of the font. We can choose one of the preset
values or enter the font size we require, such as 13.5.

e Language mainly used to tell the program which spellchecker to use in the
fragment of text. If you do not select the right language, the spellchecker
will not work properly. Languages with a blue tick on their left have a
dictionary installed in OpenOffice.org, so they can be used for correcting
documents.

The bottom part of the dialog box displays a preview of the selected text as
it will look when the specified changes have been made. Below this box is a
text informing the user of any conflicts with the selected typeface. If we see
the text "The same font will be used on both your printer and your screen”,
this tells us that there are no contflicts.
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Figure 21. Character formatting Font Effects tab
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This tab contains more advanced aspects of font formatting. These are:

¢ Underlining allows us to choose between different types of underlining
for the selected font. The font is not underlined by default. The colour of
the underlining may differ from the colour of the font, so we must also
select a colour.

e Effects can be useful if you need to automatically control character capi-
talisation. For instance, this feature can be used to automatically change
all of the letters in the selected text to capitals.

e Strikethrough is used to select different types of strikethrough effects for
the selected font. Letters appear without strikethrough by default.

e Relief lets us specify whether to give the font a relief effect and what the
characteristics of this will be.

¢ Font Color is used to change the colour of the characters based on the
options available in the system palette. We have already seen how to create

custom colours in this unit.

¢ Individual words is a very interesting feature that can be turned on if
you enable font underlining or strikethrough. When this is checked, un-
derlining and strikethrough are not applied to spaces in the document.

e Outline, Shadow and Blinking are some of the other effects that can be
selected individually or in combination with others.
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Figure 22. Character formatting Position tab
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We have divided the options inside this window into their three broad sec-

tions:

Position is useful for specifying the subscript and superscript options, as
we can manually enter their height and relative size. Or we can mark the
Automatic option to accept the program's default values.

Rotation / scaling rotates the text on a vertical axis so it is read from
bottom to top (90°) or from top to bottom (270°). If you want the text to
take up all of the available space on the page, check the Fit to line option.
You can also customise font width in this section using the Scale width
option. Values above 100% will make the font wider while values below

this figure will make it narrower.

Spacing allows us to expand or condense the space between characters by
the number of points entered in this field. If you check the Pair kerning
option, letters will be placed closer together to enhance the appearance
of the text.
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Figure 23. Character formatting Hyperlink tab
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If you want to make the selected text into a hyperlink, this tab has all the

options you might need.

URL, enter the name of the website or file you want to open when the
hyperlink is clicked in this field. You can also select it by clicking on the
Browse button.

Text allows you to enter the hyperlink text that will be seen in the text

document.

Name allows you to enter a name for the hyperlink. OpenOffice.org uses
the HTML NAME label for this.

Target frame used to indicate the name of the frame in which the associ-
ated file or link should be opened. You can also select one of the standard
default frames. If you leave this option blank, the link will open in the

current location.

Events this is very useful if you want a given event to take place when
the hyperlink is clicked. For instance, if we want a program macro to run.
You will need to specify the action in the dialog box that appears when
you click on the button.

Visited links allows us to specify the style of links with this status. For
this, select an available style from the Stylist.

Unvisited links, as above, it allows us to specify the style for this link
status.
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Figure 24. Character formatting Background tab
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This tab is used to choose the background colour for the selected text. You can
use a colour from the program's standard palette or one that you have created
yourself. To clear the background colour, select the No Fill option.

3.2. Paragraph formatting

Character formatting requires the text for formatting to be selected. However,
to use paragraph formatting, simply position the cursor inside the paragraph
to which you want to apply the formatting changes.

As with characters, it is best to use the Object bar for basic formatting features.
This can be used to justify or indent the paragraph, or to change the back-
ground colour. We will also see how to use the ruler to define basic paragraph
formatting settings.

To change a paragraph indent quickly without going through the paragraph
formatting dialog box, you can use the program's horizontal ruler. To do so,
select the paragraph you want to indent by positioning the cursor in it and
then move the triangle on the lower part of the ruler to specify the left indent

(the top triangle will move with it).

3.2.1. Tabs

The horizontal ruler can also be used to insert and move tabs for one or more
paragraphs in the document. To configure tabs, first select the paragraph you
want to indent by positioning the cursor in it. In the small box on the left
edge of the horizontal ruler, you can select the type of tab you wish to insert
by clicking on it repeatedly. The available options are:
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a) Left tab

b) Right tab

¢) Decimal tab (which allows us to align texts such as amounts by their dec-
imal point when clicked).

d) Centered tab

To add a tab to a point on the ruler, simply drag it to the desired position.
To delete a tab, drag it outside the edges of the horizontal ruler. If you are
working on a document that has no specified tabs, OpenOffice.org's default
tabs will be used.

3.2.2. Paragraph formatting dialog box

This section will look at the dialog box containing the paragraph formatting
options. This and the character formatting dialog box complement each other.
For instance, to select the paragraph font, mark it and go to the character
formatting dialog box as we have already seen.

To bring up the Paragraph formatting dialog box, position the cursor or mouse
pointer in the paragraph you wish to format and right-click the mouse to select
Paragraph in the context menu. A dialog box with different tabs will appear.

Figure 25. Paragraph formatting Indents & Spacing tab
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The Indents & Spacing tab contains the following options:

¢ Indent lets us specify the distance between the text and the page margins.
The First line option is used to indicate the distance of the paragraph's



GNUFDL e PID_00148476 31 Open Writer. OpenOffice.org word processor

first line in Before text. If you mark the Automatic checkbox, the default
indent will automatically be applied.

e Spacing used to configure the space above and below the paragraph. This
space will not be applied if the paragraph is at the top or bottom of the
page. Adjacent paragraphs will use the largest separation value.

¢ Line spacing allows us to choose from the different line spacing options,

which can be customised in some cases.

¢ Register-true gives us the option of aligning ends of paragraph with the
lines of adjacent columns.

On the right of the window, the program offers a preview of the values being
modified so that we can see exactly what we are doing.

Figure 26. Paragraph formatting Alignment tab
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The Alignment tab is used to configure the following:

e Options used to select the Left, Right, Center or Justified options. If you
select the latter, you can align the last line of the text separately. For in-
stance, if the last line is very short, you can align it to the left to avoid
large spaces between words.

e Text-to-text lets us specify the vertical location of the text if line spacing
is greater than the text.

On the right of the window, the program also offers a preview of the values
being modified so that we can see exactly what we are doing.
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Figure 27. Paragraph formatting Text Flow tab
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e Hyphenation if we select the Automatically option, the program will
separate the last word of the line into syllables. We can control
OpenOffice.org's hyphenation system by specifying the number of char-
acters that need to be present at the end and start of the next line and the
maximum number of consecutive lines that can be hyphenated.

e Breaks used to select the page or column break option for the selected
paragraph. If you choose the Before option, the current paragraph will be
moved to the next page or column; if you select After, the next paragraph
is moved. When you move on to the next page, you can choose the style
for the new page from those available.

e Options useful for setting the minimum number of lines to appear on
the previous page (orphans) or the next one (widows) when a paragraph
continues on to the next page.
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Figure 28. Paragraph formatting Numbering tab
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e Numbering Style allows us to apply predefined numbering styles to the
selected paragraph.

¢ Numbering used for lists of numbered paragraphs when we wish to restart
numbering. In Start with, you can specify the first number of the series.

e Line numbering if you use line numbers in the document margins, you
can use the line numbering options to control whether the paragraph has
to be numbered and how this should be done.

Figure 29. Paragraph formatting Tabs tab
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e Position inserts a new tab position, measured from the page margins.
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e Type lets us select the type of tab. Earlier, we looked at the tabs available

on the vertical ruler.

¢ Fill character very useful if we want the specified characters to appear be-
tween the position at which the tab key was pressed and the tab position.

To add a tab that you have created, click on the New button. You can also
delete one or all tabs from the paragraph by clicking on the corresponding
button. If you are working on a paragraph with no specified tabs, the default

OpenOffice.org tabs will be used.

Figure 30. Paragraph formatting Drop Caps tab
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This tab is used to format the initial letters of a paragraph. The available op-

tions are:

e Settingslets us activate this feature when we mark Display drop caps. You
can specify Whole Word to use the first word as text. If you do not select
this option, you can specify the number of characters to use. You can also

indicate the number of lines to use and distance to text.

¢ Contents used to specify a different text to the one at the start of the
current paragraph. A character style can also be applied to the specified
text.

On the right of the window, the program offers a preview of the text we are
modifying so that we can see exactly what we are doing.
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Figure 31. Paragraph formatting Borders tab
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e Line arrangement, we can click on the different types of line to apply
the type of border they represent. We can also click on the blank box to
delete all line settings. The grey box in the User-defined box represents the
paragraph. We can add or delete lines around the paragraph by clicking
on them.

e Line, in this section we can choose the type and colour of line to use.

e Spacing to contents allows us to specify the distance between the para-
graph and the outermost shadow line. If we modify a value and wish to
apply this change to all of the other values, mark the Synchronize option.

e Shadow style allows us to select the position at which to apply the angle
of shade to the line. The first of these boxes disables shadow configuration.
The drop-down Color list is used to change the shadow colour, which is
grey by default.
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Figure 32. Paragraph formatting Background tab
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The Background tab can be used in two ways: it can colour in the background
and it can make the background into an image:

e Color this is used to change the background colour using the options in
the system palette. We have already seen how to create custom colours in
this unit. Select the No Fill option to turn off background colour.

e Graphic this offers a number of options for using graphics as paragraph
backgrounds. When you click on the Browse button, a selection window
will appear in which you need to select the graphic to use. The Link option
creates a symbolic link to the graphic. This will reduce the size of your
document but the graphic will need to be available in order to see it. If the
graphic is smaller than the paragraph, use the Type options to position it
in relation to the paragraph.

3.3. Bullets and numbering

As we saw in the last two cases, for quick formatting with bullets and num-
bering, it is best to use the options available in the program's Object bar. To
do so, simply select the text to number or convert to bullets and click on the
relevant button in the Object bar.

The bullets or numbers appear in grey boxes to help locate them better in the
document. These grey boxes will not be printed with the document. If you
find them distracting though, you can turn them off with the View -> Field
Shadings menu option.
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The program's default bullet and numbering options are basic but they can be
customised to adapt them to our needs. The procedure for this is as follows:

1) Select the paragraphs you wish to number or change to bullet points or
position the cursor on the blank line where you wish to begin numbering.

2) Go to the Format -> Numbering/Bullets menu option and select the tab
you require from Bullets, Numbering type and Graphics; if you select this last

option, the following dialog box will appear:

Figure 33. Numbering/Bullets Graphics tab
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This dialog box allows us to use much more attractive tabs than the program's
default ones. If you choose a graphic, it is very important to check the Link
graphics option in the bottom part of the window because if you need to send
the document to others, they will be unable to see the bullets if the graphics
are not installed on their computer or if the path to the graphics is not the
same as on yours. As these graphics take up a minimum of space, it is not

necessary to link them to the document instead of inserting them.
3) After selecting the style you wish to use, click on the OK button.
If you are starting a new list, enter your first text and press Enter. The new

paragraph will also be a list item. To exit list mode, press Enter twice on a
blank line or turn off the list from the Object bar.
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3.3.1. Creating an outline

We can use the system we saw in the above section on bullets and numbering
to create an outline, as the procedure is very similar. There is no quick way to
create an outline in OpenOffice.org like there is for bullets and numbering.
The steps to the process are as follows:

1) Position the cursor in the document where you wish to start the outline.

2) Go the Format -> Numbering/Bullets menu option and select the Outline
tab.

Figure 34. Numbering/Bullets Outline tab

= NOmeracionlyvinetas: |
Vifetas ‘Tipo de numeraci()n‘Esquema Iméagenes | Posicién | Opciones
Seleccion

1) 1. (1) l.

2) 2. (2) Il

3) 3. (3) 1.

(a) i
B) b) (b) i
C) C) (c) jii.
Aceptar Cancelar Ayuda Restablecer

3) In the Outline tab, select the style of outline you wish to use and click on
the OK button. The first level of the outline will appear in your text.

When you press Enter at the end of a line of text, you will remain at the same
numbering level but the numbers will increase. If you want to move within a
level, press the Tab key on the keyboard. To return to the previous level, use
the Shift+Tab key combination.

3.3.2. Configuring numbering, bullets and outlines

There are several settings options for numbering, bullets and outlines. The
main reasons for configuring these would be to change symbols and indents,
as well as numbers and typefaces. The process for configuring these is as fol-

lows:
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1) Select the paragraphs you wish to number or change to bullet points or
position the cursor on the blank line where you wish to begin the list of items.

2) Go to the Format -> Numbering/Bullets menu option and select the Options
tab.

Figure 35. Numbering/Bullets Options tab
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3) Select the level number from the Level field. The level numbers correspond
to the text indent level. The higher the level, the greater the indent.

4) In the Numbering field, select the type of numbering or bullets you wish
to use for this level. The formatting options differ according to the type of
numbering selected.

e If you select a numerical format in the Before and After text fields, you
can enter the text that will appear before and after the number. You can
also choose the character style you wish to use for the numbering. This
option allows different styles to be used in the paragraph numbering and
text. The Show sublevels and Start at fields are used to specify the number

of sublevels to include in the numbering and their initial level, respective-

ly.

e If using graphics, click on the Select button to determine which graphic
to use. You can enter the width and height of the selected graphic but
it is always preferable to leave the Proportional option marked to avoid
distorting the image. Finally, in Alignment, you can enter the alignment
position in relation to the baseline of the text.
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e If you select the Bullet option, you can choose the character style and
select a special character for the bullets. To do this, click on the ellipsis (...)
button to the right of the Character option.

5) Select the appropriate options for the level you have chosen. To configure
another level, mark it, define its settings and then click on the OK button.

3.3.3. Position and spacing between levels
Another settings option is to change OpenOffice.org's default position and
spacing for bullets and numbering. The process for changing these settings is

very similar to the one we have just seen. The steps are as follows:

1) Select the paragraphs you wish to change or position the cursor on a blank
line where you wish to begin the list of items.

2) Go to the Format -> Numbering/Bullets menu option and select the Position
tab.

Figure 36. Numbering/Bullets Position tab
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3) Select the level number from the Level field. The level numbers correspond

to the indent. The 1-10 field applies the changes to all levels.

4) Change the level settings. The changes that can be made here are to modify
the distance between the number or bullet and the page margin, the minimum
and maximum distances between the text and the number or bullet, and lastly,
the alignment of the bullet or number with the space created. Click on the
OK button to exit the dialog box and accept changes.
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The lower part of the window has a preview area where you can see the visual
effects of the changes as you make them.
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4. Word Completion and AutoFormat

One of the most useful features of OpenOffice.org is its ability to complete
words and format text automatically and to correct common typographical
errors. However, one thing is clear, these options can either be very useful or
very bothersome. It all depends on the person using the program. What can
sometimes be a great feature for some, may put others off using the program
precisely for that reason. This section will describe how to adapt these features
and functionalities to our needs and how to turn them off.

4.1. Configuring AutoReplace

This can be a very useful feature if you tend to make the same spelling mistakes
or grammatical errors all the time or if you regularly type the letters of a word
the wrong way round. It can also be used to automatically change letters for
their corresponding symbol. For example, "(c)" can be used for the copyright
sign or "(r)" for the registered sign. If you have used any other word processor,
they will probably have had this feature too. We will now look at how to
configure the feature in OpenOffice.org.

To access Replace, go to the Tools -> AutoCorrect/AutoFormat menu option
and select the Replace tab in the AutoCorrect dialog box.

Figure 37. AutoCorrect Replacement tab
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The first thing to do is to select the language of the document or the language
in which you usually work, as the replacement table is different for each. To do
this, select the required language from the list in Replacements and exceptions
for language. Most languages already have their own replacement table that
you can modify if you need to.

In the Replace text field, type the word or character that you would like to
automatically replace with another and write the substitution in the With text
field. Once you have completed this step, click on the New button to add it

to the replacement table.

To type a symbol or special character in the substitutions text fields, right-click
the text field and select the Insert Symbol option from the context menu,
which will bring up all of the symbols for the fonts installed on the system
for you to choose from.

Figure 38. Symbols selection dialog box
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To delete a default replacement or one that you created yourself, first mark it
in the replacement table and then click on the Delete button. Use this method
to delete all substitutions affecting your work instead of disabling the function

altogether.

4.2. Configuring automatic uppercase

By default, the OpenOffice.org program automatically changes the letter fol-
lowing a full stop and blank space into uppercase. This can be very useful but
it can also be irritating if you often type abbreviations.

The program automatically changes words that start with two consecutive
uppercase letters, converting the second uppercase letter into lowercase. The
feature was designed for people who type very quickly, as the program thinks
that the user has not had time to release the shift key before typing the second
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letter. Nonetheless, at some point during use of this program we will no doubt
need to type a word with two consecutive uppercase letters, such as the name
of a company or product.

Note that this rule only applies to words that begin with two uppercase let-
ters. When the program detects three or more consecutive uppercase letters,
it assumes that this is not a mistake and that the user has intentionally typed
the word like this. As we shall see, this feature can be turned off completely

or we can create exceptions to the general rule.

To do so, go to the Tools -> AutoCorrect/AutoFormat menu option and select
the Exceptions tab from the AutoCorrect window.

Figure 39. AutoCorrect Exceptions tab
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After confirming that the language is correct, enter the exceptions for Auto-
Correct to Uppercase in this dialog box. The top section includes a list of ab-
breviations not followed by uppercase letters, while the bottom section con-
tains words beginning with two consecutive capitals. You can enter exceptions
in the appropriate text boxes and then click on the New button to add the

exception. To delete an exception, select it and click on the Delete button.

Each of the items in the two groups of exceptions include options marked by
default with the word "AutoInclude". These are applied as you edit your docu-
ment. If you correct an AutoCorrect to Uppercase that the program automat-
ically entered and then carry on typing, the correction will be automatically
added to the list of exceptions. For this to happen, the Autolnclude option
must be checked.
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4.3. Turning off AutoCorrect

OpenOffice.org comes with a wide range of AutoCorrect options, which we

will introduce here. To locate them, go to the Tools -> AutoCorrect/AutoFor-

mat menu option and select the Options tab from the AutoCorrect window.

A dialog box like the one below will appear:

Figure 40. AutoCorrect Options tab
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We will deal with these one by one. Some have a very obvious function but

others do not. Moreover, the original meaning of some of the options may

have been lost in translation.

¢ Use replacement table allows the program to use the replacement table

from the Replace tab we saw earlier.

e Correct TWo INitial CApitals automatically converts the second consec-

utive capital into a lowercase letter. You can add exceptions to this rule in

the Exceptions tab of the AutoCorrect dialog box.

e Capitalize first letter of every sentence changes any letter after a full

stop and a space into a capital. You can enter exceptions to this rule in

the tab we saw above.

¢ Automatic *bold* and _underline_automatically converts a word to bold

if you enter an asterisk before or after it. This functionality also applies

to words with an underscore before and after them, though this time the

words are underlined.
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¢ URL Recognition converts a group of characters that the program thinks
is a web link into a URL. For example, if you enter "http://www.uoc.edu",
the program will effectively convert it into a link to this web page when
you click on it. If this autoformatting is useful most times but not so use-
ful at others, you can restore the original text by selecting the full link
and right-clicking it before clicking on the Default option. You can also
undo autoformatting with the key combination Ctrl+Z after it has been

converted.

¢ Replace 1st... with 1/st... this option is useful if you write documents in

English. It automatically superscripts ordinals in English.

e Replace 1/2... with % ... converts the three characters of a fraction into a
single character with the corresponding symbol. This change only applies
to character sets with the corresponding fraction symbols. Character sets
normally only have three or four fraction symbols.

¢ Replace dashes converts minus signs into true dashes as long as they at
least have a space on either side.

¢ Delete spaces and tabs at beginning and end of paragraph deletes the
spaces and tabs at the start of a paragraph if the Apply Styles option is
checked.

¢ Delete spaces and tabs at end and start of line deletes the spaces and
tabs at the start of each line if the Apply Styles option is checked.

e Ignore double spaces makes sure that there is only one space between
two characters.

¢ Apply numbering - symbol X converts a number followed by a full stop
plus space and any text into a numbered list when you press Enter. This is
a quick way to access the same feature in the Object bar. Instead of typing
in a number, you can use a dash or an asterisk for numbering with dashes
or bullets, respectively. You can change the character for turning on bullet
numbering by clicking on the Edit button.

e Apply border allows you to create a line below the paragraph when you
enter three consecutive characters and press Enter. To restore the original
text, select and right-click on it and select the Default option. The follow-
ing table illustrates the types of border that can be created:

---1 0.5pt single underline

___| 1.0pt single underline

===|1.1pt double underline
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***1 4 5pt double underline

~~~| 6.0pt double underline

#i##| 9.0pt double underline

¢ Create table if this option is turned on, you can automatically create a
table in your document simply by using the keyboard. The + key represents
a column border and the - character represents the width of the column.
After combining the two characters to suit your needs, press Enter. Valid

columns must begin and end with the + character. For example: "+--------- +

e Apply Styles allowsOpenOffice.org to automatically apply paragraph for-
matting when using the Default style. When you begin a paragraph with
a capital letter and do not end it with a full stop, press the Enter key twice
at the end of the line and the paragraph style will automatically change to
Heading 1. If you press the Tab key twice before typing in text, Heading
2 will be applied. If you press tab three times, the Heading 3 style will be
applied, and so on.

¢ Remove blank paragraphs if this feature is turned on, when you choose
Format -> AutoFormat -> Apply, all blank paragraphs in the document will

be removed.

¢ Replace Custom Styles when use the Format -> AutoFormat -> Apply fa-
cility, this converts the custom styles of the document into the equivalent
standard styles of the program.

¢ Replace bullets with: X when using the Default style, this option allows
you to change all paragraphs starting with a number, asterisk or dash fol-
lowed by a space (or tab) and text into a list when you choose Format ->
AutoFormat -> Apply. You can change the character for turning on bullet

numbering by clicking on the Edit button.

¢ Replace standard quotes with custom quotes when this option is turned
on and you choose Format -> AutoFormat -> Apply, all single and double
quotes in the document are changed to the characters indicated in the
Custom Quotes tab of the AutoCorrect window that appears when you
select the Tools -> AutoCorrect/AutoFormat menu option.

¢ Combine single line paragraphs if length greater than ... when using
the Default style, you can choose Format -> AutoFormat -> Apply to com-
bine consecutive paragraphs that only have one line. Single-line para-
graphs must be at least the specified percentage of the width of the page.
You can change this percentage by clicking on the Edit button.
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4.4. Word Completion

We will now look at what is probably the most visible automatic feature
of the entire program. When writing a document in text or HTML format,
OpenOffice.org will try to predict the word you are typing and automatically
supply the rest of the letters in the word, which can either be extremely help-
ful or very irritating if not configured correctly. In this section, we will try to

explain how it works and look at some of its limitations.

The best way of using this feature to our advantage is to limit the number
of words for which the program offers suggestions. For example, if you are
working on a scientific document with very long or complicated words that
come up again and again, you can add them to the program so that it provides
automatic suggestions and ignores others. This would make your task less te-
dious and considerably increase your productivity.

Remember that the Word Completion feature can only be used with single
words. If you want to enter longer texts with more than one word, you will
need to use OpenOffice.org's AutoReplace feature.

To set up this function, go to the Tools -> AutoCorrect/AutoFormat menu op-
tion. Once inside the AutoCorrect dialog box, select the Word Completion
tab, which will look like this:

Figure 41. AutoCorrect Word Completion tab
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The options in this window are:
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Enable word completion enables OpenOffice.org's Word Completion
function. If you do not want to use this feature, unmark the box.

Append space adds a space after completing the word.

Show as tip displays suggestions from the program's list of words like a
help tip much like the one we see when we hover the mouse pointer over
a button, rather than like the rest of the word highlighted in blue. This

makes word completion much less intrusive for users.

Collect words tells OpenOffice.org whether or not to collect words for
the list of suggestions. You can collect words regardless of whether or not
the Word Completion feature is turned on. It is generally a good idea to
collect words once you have the most common ones in the list. This will
prevent the program from suggesting words that you never use instead of
the ones you often do.

When closing a document, save the list for later use in other docu-
ments allows us to reuse words in other texts. Words are generally only
collected for the current document.

Accept with allows us to select the key to use to complete words. The
default key is Enter.

Min. word length controls the words added to the list by specifying a
minimum number of characters for words to be added. The default value
of 5 is ideal so it is best not to change it unless there is an important reason
for doing so.

Max. entries allows us to specify the maximum number of entries for the

word list.

The field on the right of the window lists the words that OpenOffice.org will

attempt to complete as they are typed in a document. The program will au-

tomatically add the words you type to the list if the Collect words option is

enabled, provided that the words meet the specified requirements.

If you have mistyped a word or added one by mistake and the program is al-

ways suggesting it, you can delete it in this window. Simply select the mistyped

word and click on the Delete Entry button.

If you have two or more words formed from the same root, such as "process"

and "procedure" and OpenOffice.org suggests the word you do not want, you

can scroll up or down the list to select the right one. To go to the next word,
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press Ctrl+Tab. To go to the previous one, press Ctrl + Shift + Tab. This feature
allows us to scroll through the full list of words, but we can also use it to scroll
back and forth in groups of words with the same root.
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5. Using graphics and sounds

Almost any type of graphics file can be inserted into a document, including
GIFs and JPEGs. We can also work with less common graphics formats, since
OpenOffice.org has filters for most of these. However, remember that only the
most usual ones are installed by default. To work with a rare graphics format,

you will need to modify your installation to install filters.
To insert graphics in a document, follow these simple steps:
1) Position the cursor where you want to insert the graphic and click.

2) Click and hold the left mouse button on the Insert button and select Insert
Graphics. The default Insert button will then change to adapt to the last se-
lected action. This means that you now need only click on Insert to insert a
picture in the document. You can also use the program's main menu by going
to Insert -> Graphics -> From File... The result is the same in both cases.

Figure 42. Insert Graphics dialog box
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Besides the typical actions of any file selection dialog box, this window has a
graphics preview feature, which is very useful if you do not use meaningful
names for your graphics files. To enable this feature, check the Preview option.

Another option that can be very useful, but also quite risky, is Link. When you
check this option, the graphics are not physically inserted in the document;
instead, the program inserts a symbolic link to their location. On a practical
level, this means that if you want to send this document to others, you will
also need to send the pictures with it, as you would for a web page.
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So, if you link a graphic from a given folder (for instance, img) to the docu-
ment, you will need to send it to the recipient in a folder of the same name.

5.1. Using the OpenOffice.org picture and sound gallery

We have seen the basic method for adding graphics to documents but
OpenOffice.org also has a very powerful tool for classifying and working with
graphics and sounds called the Gallery. To enable it, select the Tools -> Gallery

menu option or click on this button in the Function bar.

Figure 43. OpenOffice.org displaying the gallery
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The gallery is displayed as a series of images and/or sounds that can be classi-
fied into different categories although, in fact, they are a group of links. So,
for example, each of the graphics that we see in a single category may be in
different locations on our hard drive.

To insert an image into your current document, simply select the theme on
the left of the screen and then drag the image on the right to the desired

position in the document.

The program comes with a number of default gallery images and sounds. These
will depend on the installation you used as some are not installed with stan-
dard installations.
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5.1.1. Creating gallery themes

You can add your own graphics, sounds and animations to an existing theme

or you can create new themes to suit your needs. This section will look at how

to create a gallery theme and add graphics to it. The method is very similar to

adding elements to an existing gallery. The steps of the process are as follows:

1) The first thing to do is to open the gallery by selecting the application's

Tools -> Gallery main menu option or by clicking on the Function bar button.

If the gallery is selected but you cannot see it, it is probably hidden. To display

it, click on the small arrow at the edge of the workspace of the current docu-

ment. Clicking on this arrow will show the gallery.

2) To create a new theme, click on the New Theme button in the top left of

the gallery.

Figure 44. Properties of New Theme dialog box
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3) This will bring up the Properties of New Theme dialog box, which has two

tabs called General and Files. In this first screen, type in the name of the theme

you wish to create and click on the Files tab to add the contents.
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Figure 45. Properties of New Theme Files tab
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4) In the Files tab, first select the type of file you wish to add to the theme.
If you mark the All Files option, you will be able to select all OpenOffice.org-

compatible files in the folder. Click on the Find Files button.

Figure 46. Folder selection dialog box
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5) In this window, simply select the folder of the files you wish to add and
click on the OK button to continue the process. The program will search for all
elements compatible with the gallery in the specified folder and its subfolders.
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Figure 47. Files tab with found elements
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6) This will take us back to the Files tab but you will now see that the left-hand
side of the dialog box is displaying the elements found in the specified folder
that matched your file type selection. If you check the Preview option, you
can view the pictures or listen to the sounds in the files. However, note that
if these images are very big or very small, they will be considerably distorted.

7) To add a file to the gallery you are creating, select it and click on the Add
button. If you want to add all of the files from the folder and subfolders, click
on the Add All button. As explained above, the added files are not copied; the
gallery simply adds a reference to them in order to access them. If you delete
a file added to the gallery from its original location, you will no longer be able
to use it. After selecting all of the files, click on OK to create the new gallery.
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Figure 48. Gallery with new theme
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To add new sounds or images to an existing theme, right-click the name of
the theme and select the Properties option. This will bring up the Properties

dialog box we saw earlier where we can add new file references.

It is much easier to delete a file reference in a gallery theme. Right-click on the
icon and select Delete from the context menu that appears. A dialog box will
appear asking if you really want to delete the object. Note that you are only

deleting the gallery reference here, not the original file.
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Summary

In this unit, we looked at the OpenWriter working environment and learnt
how to use and configure it for routine word processing operations. We fo-
cused particularly on the formatting possibilities of OpenOffice.org as these

are the most commonly used features for writing documents.

We also dealt with the configuration of the program's text composition help
tools so that we can customise them to suit our needs. These features can often
be very irritating to users if they have not been sufficiently adapted to their
expectations.

Lastly, we saw OpenOffice.org's organised system for saving images and
sounds, although we will probably only need to work with pictures.

From what we have learned in this unit, we should be able to discover for

ourselves the other OpenOffice.org tools for creating text documents.
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