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Introduction

There can be no question that the database management tool of

OpenOffice.org 2.0 was one of the most long-awaited features of the latest

version of the product. It is not that OpenOffice.org could not work with

databases in previous versions – it could and did so in a very powerful way –

but the program did not have a database client like Microsoft Access, which

is what was added in version 2.0.

In this unit, we will look at the steps required to create a database. This will

involve operations such as creating tables or simple forms for the simple ex-

traction of data from these databases. This unit will focus on these two actions

in particular.

The complex topic of databases contains subtopics that should be dealt with in

detail: queries, reports, limitations of spreadsheet databases, links to existing

data, links between fields or tables in the same database, and many, many

others. However, these are mainly advanced topics that do not fall within the

scope of an introductory text such as this.

The main aims of this unit are:

1) to familiarise students with the use of the main database and table creation

features of OpenBase through its wizards, and

2) to describe the process of creating forms for easy data input.
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1. Creating a new database

There are two steps to the creation of a new database: the first is to create the

actual database and the second is to create tables in which to insert data.

What we will do is create a database from scratch, which means that our data

does not yet exist; we will enter it later. We are going to create a new database

without taking into account the type of data we are going to use, which we

will input ourselves.

In OpenOffice.org 2.0, this step is not at all complicated; the application has

a wizard to help us create an automatic database that is also easy on the eye.

Open Base can be launched from any OpenOffice.org application using the

File > New > Database menu option.

Tips can be very useful for learning about the different features of the program.

Tips are displayed for each of the labels and buttons on the screen. You can

enable or disable this option using the Help > Tips menu option.

Figure 1. Open Base main window
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1.1. Creating the database

To create a new database, select File > New > Database, which will bring up

the following dialog box:

Figure 2. Create database wizard dialog box

Select Create new database and click on Next. The wizard settings are clear

throughout, so the process can be followed without major difficulties. You will

need to continue with the wizard right to the end. Take care not to accidentally

click on Finish in this or any other of the dialog boxes in this process.

At the end of the wizard, type in a suitable name for the database. For exam-

ple, if it is a customer database, we might call it: "customer_data" or a similar

meaningful name.

When you exit the wizard, you will see the main database configuration dialog

box. In this window, you can create tables, queries, forms and reports. It looks

like this:
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Figure 3. Main database configuration dialog box

1.2. Creating a table

A database can contain many different tables. This section will deal with cre-

ating one of these. In the main configuration dialog box, select the Tables

button on the left.
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Figure 4. Tables button

It is possible to create tables with a wizard or in Design View. If you are an

advanced user, you will probably use Design View to create it. However, we

will explain how to create tables with the wizard here. So, click on the Use

Wizard to Create Table option to begin. This will bring up the following dialog

box on your screen:

Figure 5. First Table Wizard dialog box
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In the first wizard dialog box, you will see a lot of default fields that can be

used in your table. There are various sample tables, such as employees and

expenses, which you can use. These options are available to help users create

tables quickly with sample fields. Many of the fields you have in mind will

probably already be available in the samples, so you won't need to create them

from scratch.

Select the sample tables, the fields you wish to use and use the arrows to enter

them in your list of selected fields. Note that you will need to put them in the

order you want to use them in. To continue, click on Next, which will take

you to the following wizard dialog box:

Figure 6. Second Table Wizard dialog box

This dialog box allows us to change the default data structure if we wish. These

structures can also be changed in Design View – advanced users are advised

to use this mode. We, however, will simply check that the structures match

the right criteria and click on Next.
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Figure 7. Third Table Wizard dialog box

The next dialog box allows you to set the primary key. The default behaviour

is to create a separate field that increases automatically, whose sole function

is to act as the primary key of the table. If you do not use a primary key that is

separate from the data, you must select a database field that is unique for all of

the items in the table. For example, if the table is a list of customers, you can

use a field called "Customer Number". If you cannot be sure that this value

will always be unique, it is better to use a field separate from the data as the

primary key, even if it is only used for this purpose. Once you have selected

a primary key, click on Next again.

Figure 8. Fourth Table Wizard dialog box

In this dialog box, give a meaningful name to the table, such as "Customer

Data" and save it. If you leave the Insert data immediately option selected and

then click on Finish, you can start entering data in the table as soon as you

exit the wizard. We will now see this:
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Figure 9. OpenBase main window with the created table

You will have now created your table. It is important to put the items in the

correct order in the wizard because this order cannot be changed afterwards.

It is at this point that you will realise whether you have put the items in the

right order or not.

You can now start to insert data. If you reach the end of the line, you can click

on the Save button on the Object bar or simply press the tab key to save the

data automatically. You can use either of these two methods although the tab

key is much more convenient because you don't have to take your hands off

the keyboard to save the information.

After entering some data, close the window with the table in it. You will be able

to see the data you have added in the main database configuration window if

you select the document from the drop-down list to the right of the workspace.
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Figure 10. Open Base main window

Tables are a useful tool but it is a good idea to create a form if we want every-

body to be able to input data easily in the database table without entering the

main database configuration window. The following section explains how to

create a form so that users can enter data in the tables.
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2. Forms

We will continue with this introduction to OpenOffice.org with the creation

of a form, which is one of the basic operations of this program. In the previous

section, we saw how to create a database and table and how to enter data in

the latter from the main database configuration window. We will now look at

an alternative way of entering data using forms.

To create a form, position the cursor inside the main database configuration

window and click on the Forms button on the left. We will again see two

options, so select the one that will create the form with a wizard. The first

wizard dialog box is as follows:

Figure 11. First Create Form wizard dialog box

In this first window of the Create Form wizard, you will need to select the table

fields that you would like to add to the form. To do so, first select the right

table from the drop-down list. As above, make sure that you select the fields

in the order in which you would like them to appear in the form. You can

change the order using the up and down arrows in the middle of the window.

It is important to get this right now because it is very complicated to move

them around later, partly because you also have to change the tab order.
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Figure 12. Second Create Form wizard dialog box

The next windows are used to specify the subforms and relations (these are

advanced topics that we will not discuss here). Just click on Next to continue.

Figure 13. Third Create Form wizard dialog box

In the next window, you can modify the form controls. This is easy, all you

have to do is select the one you would like to modify and the form document

will change to incorporate the effects. Once you have made the necessary

control modifications, click on Next to continue.
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Figure 14. Fourth Create Form wizard dialog box

You must leave the data entry window in a way that will meet your needs. It

is generally common practice to leave it as it is in order to start working with

the form. In other words, leave it as wide-ranging as possible. When you have

finished, click on Next to move on to the next window.

Figure 15. Fifth Create Form wizard dialog box

The next window is used to apply styles to the form. Simply select the style

you wish to apply. You can preview the results before you make your final

decision on the style to choose. When you have applied your preferred style,

click on Next to move on to the last wizard dialog box.
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Figure 16. Sixth Create Form wizard dialog box

In this last dialog box, give a name to your form and save it. This form is not

a separate document or file; it is associated with the database, so we cannot

have a form that is separate from a database. To access it, go to the database

settings window. You can enter new data in your database by double-clicking

it. The completed form should look like this:

Figure 17. Completed form

2.1. Entering data in forms

To enter data in forms, although it may seem paradoxical, the first thing to do

is check that we can actually input data. The toolbar with the "Record X of Y"

field in the bottom part of the screen will indicate whether we can enter data



GNUFDL • PID_00148479 19 Databases in OpenOffice.org

easily. If this field is not displayed, go to View > Toolbars > Form Navigation

to display it. Another possibility is that your OpenOffice.org is too small and

the field is hidden.

If the form has data in it, you can type in the new information and click on

Save Record in the Form Navigation toolbar.

To create a new record, use the arrows to move to the end of the existing

records. These fields will be blank so you can enter your data and then, very

importantly, click on the Save Record button. Alternatively, you can click on

the New Record button. The record you have created will be the last one in

the database although it will not appear as the last one.
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Summary

This unit has offered a brief introduction to the database creation tool in

OpenOffice.org 2.0. We have only looked at the very basic features of the tool,

leaving out functions such as multi-user forms, relations, queries and reports.

Hence, there are many tools yet to be discovered, although we can still do a

lot with what we have seen.

We have shown how the wizards are very easy to use and how we can do many

things with them. They can help us a great deal in our work with databases

in OpenOffice.org but we need to read the text in each dialog box carefully

to uncover their true potential.
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