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Introduction

We have already seen Firefox work and how its parent program Mozilla and

cousin Thunderbird allow it to be used for everyday e-mail purposes. This

unit will look at one of the leading free software programs: Novell Evolution,

Novell since the multinational bought out Ximian, the company that created

the product.

Evolution is not just an e-mail manager; it is a complete and attractive envi-

ronment for managing information and group work that is very similar in ap-

pearance to the popular Microsoft Outlook, though for free software environ-

ments and UNIX in general. One of its most interesting features is the possibil-

ity of working with a Microsoft Exchange server, a widespread phenomenon

in business IT environments nowadays.

In recent years, this program has been gaining ground as the default mail

manager for most commercial distributions of GNU/Linux to the detriment

of the Mozilla mail manager and Thunderbird, which are two very good prod-

ucts. This should give us an idea of the importance of the product we will be

looking at over the next few pages.

This unit will also look at the program's vast group work capabilities along

with its powerful contact management and capacity for organising everyday

tasks.

Because of its importance in business environments, Evolution is among the

fastest moving free software programs. This unit will look at the basic program,

for which we can use any version, although we would recommend using a

sufficiently updated version.

The main aims of this unit are:

1) to explain how to install and configure Novell Evolution on our GNU/

Linux platform,

2) we will study all of the features of the program's e-mail manager in detail,

from the most basic to the most advanced, and

3) we will also learn how to use the schedule and contact manager for organ-

ising group work.
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1. Installation and setup

Most modern distributions of GNU/Linux already come with a customised ver-

sion of the product (which now forms part of the GNOME desktop) installed

on our computer in the standard installation of the distribution. Nonetheless,

we will describe the installation process, which is very quick and easy.

For automatic installation, you must have a supported version of a GNU/Linux

distribution. You should find this out from the Novell support pages but if you

have a modern version of Red Hat, SuSE or Mandrake, you should not have

difficulty installing it like this.

Then, you will need to connect to the Internet and type the following com-

mand in a terminal window as a superuser:

wget q O  http://go.novell.com |sh

After the Novell Desktop installation has launched, go to Novell Desktop Core

Environment in the component selection screen and uncheck all available

options except for Evolution. If you do not have a supported distribution and

want to install a more recent version or product development, you can down-

load the GNOME CVS program source codes and compile it yourself. However,

you will probably already have the program installed with your distribution.

If not, you can install it very easily with the tools available, such as aptget for

Debian-based distributions or yum in distributions based on Red Hat.

Once the Novell Evolution program is installed, you can launch it from the

desktop panel menu or the command line by typing in "evolution". As with

most programs, we can access the full list of options that we can add to the

program by entering "man evolution" or "evolution –help".

When we use a program that allows us to save sensitive information, it is

always very important to know where this data is located so that it can back

them up. In this case, the program creates a folder called evolution in our

user folder. All of the data saved there is in standard file formats, allowing the

information to be recovered by third-party applications.

1.1. Setup wizard

The first time you run the program, a wizard will launch to configure an e-mail

account and import data from other applications. We will look at the various

steps to this process, skipping out the wizard dialog boxes that only give us

information.
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Figure 1. User identity dialog box

The first wizard screen is the user identity definition screen. Here, you type

in your name, e-mail address and, if you like, your reply address and organi-

sation. If you have several e-mail accounts, you can set up different identities

later in Edit > Preferences > Mail Accounts.
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Figure 2. Message receiving dialog box

The message receiving dialog box is used to configure the type of server from

which you will receive e-mail. The configuration options shown will depend

on the type of server you selected. It is also possible not to select a type of

server if you are not going to use this account to consult your e-mail.

If you select POP or IMAP, you will be asked for the following information:

• The name of the server (you can also use its IP address).

• Username.

• Whether you want to use secure SSL connections (if your server allows

this).

• The type of authentication (if you are not sure, click on Check supported

types).

• Whether you want the program to remember your password (so that you

do not have to enter it every time you run the program).
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If you are not sure of the server to use or the settings information for this page,

you will need to ask the systems administrator of your e-mail service. In most

cases, it will be a POP server.

Figure 3. More e-mail options dialog box

If you selected POP or IMAP, another dialog box will appear with more mail

configuration options. These will depend on the type of server selected. To

change this configuration after creating the account, go to Tools > Configu-

ration > Mail Accounts, select the account you want to modify and click on

Edit.

For POP servers, the two options you will be asked are:

• Whether you want the program to check whether you have new e-mail

and at what interval.

• Whether you want to leave a copy of the messages you have downloaded

on the server.
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Figure 4. Sending e-mail screen

The Sending e-mail screen offers two basic options: using your own computer

to send e-mail or using a remote server.

To send e-mails from your computer, you must have the Sendmail program

(or a similar application such as Postfix) correctly installed and configured as

a service. If you are using any modern GNU/Linux distribution, the manufac-

turer will probably have included it.

However, remember that if you do not have the program correctly configured

and updated, it can pose a serious security risk for the system. If you are not

familiar with the Sendmail program, it is better to use an external mail sending

server.

In this case, you will need to fill in the following options:

• Server: the name of the server or its IP address.

• Use secure connections (SSL): whether you want to use secure SSL connec-

tions (the best option if your server allows it).

• Server requires authentication: check this option if the mail sending server

requires you to enter a password to send messages.
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• Authentication type: the best option in this case is to leave the default

option unless your system administrator has requested otherwise.

• Username: usually the name you use to read your e-mail.

• Remember this password: select this option if you do not want to enter

your password every time you send a message.

Figure 5. Mail account management screen

You can enter a name in the Account Management screen to refer to this ac-

count in the program and indicate whether you want it to be the default ac-

count.
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Figure 6. Time zone selection screen

In the time zone selection screen, simply select your geographical location on

the world map.

Novell Evolution will now be configured and ready to use.

1.2. Importing data

You can import e-mail from other programs with the File > Import menu

option, but if during configuration the wizard detects that you have e-mail

saved on your hard drive or known files containing contact details, the import

wizard will launch during this initial configuration.

The Novell Evolution program can import the following data formats:

• VCard�(vcf,�gcrd). This is the standard address book format used by most

contact managers. Any program of this nature should be able to export its

data to this format for Novell Evolution to then import it.

• Microsoft�Outlook. E-mail data from this program can be imported di-

rectly to Novell Evolution if your version allows. Some versions of the pro-

gram cannot be imported because of the use of a proprietary data format

in Microsoft's program. Nonetheless, you can try to import your e-mail

using Mozilla as an intermediate stage between Outlook and Novell Evo-

lution or by exporting the data to CSV.

• LDAP. This widely-used protocol was created for users to exchange contact

information through the network, sharing access to a central directory
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where all contacts are stored. Many companies have an LDAP directory

for their internal or client contacts.

• Berkeley�e-mail�inbox�(mbox). This is the standard UNIX mail data sys-

tem used by Mozilla, Netscape and Eudora, among others. Most historical

programs support this format.

1.3. Exporting data

Exporting data is even more important than importing data, so Novell Evo-

lution uses standard formats to store information. If you use this program to

save important data, you should have no problem exporting it to other appli-

cations if you need to.

For your information, the format for mail is Mbox, for calendars it is iCal, and

for the address book it is vCards. If you look at any information management

application on the market today, you will see that most of them can recover

data in these formats.

1.4. Connection to a Microsoft Exchange server

One of the most useful features of Evolution for business is the possibility of

connecting to a Microsoft Exchange server to obtain and synchronise e-mail,

contacts and appointments with other members of staff at the company, re-

gardless of whether they use Windows or GNU/Linux. This section will study

the steps required to connect to a Microsoft Exchange 2000 or 2003 server

through the Evolution Exchange connector. This connector is free software,

licensed under the GNU GPL licence.

There are two requirements for connecting to an Exchange server. We first

need the Evolution Exchange connector installed on our system. This connec-

tor will be available for our platform but the GNU/Linux distribution we use

will probably not install it by default. If you do not install the connector, the

options below will not be available in the program.

The other requirement is that the Microsoft Exchange server be one of the

versions supported by the program. It now only supports versions 2000 and

2003 and also requires Outlook Web Access (OWA) to be enabled. In addition,

each user will need a valid Microsoft Exchange server account, which includes

a valid licence.

In Evolution 2.6, the program comes with a tool for the straightforward cre-

ation of Exchange accounts. If you have not yet set up an account, the con-

figuration wizard that launches at the start of Evolution will allow you to cre-
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ate it. The wizard only asks for the Outlook Web Access (OWA) URL and your

username and password. Evolution will obtain the rest of the information au-

tomatically.

Figure 7. Evolution Exchange Wizard dialog box

If we cannot launch automatic account setup, it is usually because we have

already added an account to our computer and so we will have to set up the

new account manually. To do so, go to Edit > Preferences and click on the

Add button. In this case, you will create the account in the same way as in

the previous section, selecting Microsoft Exchange in the message receiving

window.

If you wish to create more Microsoft Exchange accounts, you must carry out

these steps again. Evolution currently only allows one account to be set up

at a time.



GNUFDL • PID_00148478 16 Novell Evolution. E-mail manager and personal information manager

2. E-mail

One of the most interesting features – and one of the strong points – of the

Novell Evolution program is its capacity for work and e-mail management.

This section will look at all of these features in detail.

To launch the e-mail client program, click on the Entrance icon on the short-

cut or select an e-mail folder from the folder bar.

Figure 8. E-mail management feature main screen

2.1. Straightforward operations with the e-mail reader

This section will look at the most common e-mail options, such as reading

and deleting messages.

2.1.1. Reading

To read a message, simply select it from the list of messages and it will appear

in the screen display, in the bottom right of the application. To view a message

in full-screen mode, double click on it or use the Ctrl+O key combination if

you prefer to use the keyboard.

Once you are familiar with it, the keyboard can be a very fast way of accessing

the program's diverse actions. For example, it is quicker to use the space bar

and the delete key to scroll up and down in an e-mail message than it is to

use the mouse.



GNUFDL • PID_00148478 17 Novell Evolution. E-mail manager and personal information manager

Figure 9. An e-mail message in full-screen mode

2.1.2. Sorting

As with most e-mail viewers, Novell Evolution allows us to sort lists of e-mail

messages. We can sort them by sender, subject or date by clicking on the bars

above the list of messages. The direction of the arrows beside the name of the

bars indicates the direction of the order, which can be reversed by clicking on

this bar again.

Figure 10. Messages sorted by name of sender

By default, the list of messages column contains the following fields: an en-

velope icon that tells us whether we have read or replied to a message, an ex-

clamation mark indicating its priority, and the message recipient, subject and

date fields. If you right-click the bar, you can also configure the order and add
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or remove information from the messages you wish. For example, if you have

a slow Internet connection, displaying message size is very useful. The process

for adding a new column is as follows:

1) Right-click the column header.

2) Select the "Add column" option.

3) Drag the column you wish to add between two existing column headers.

A red arrow will indicate the position of the new column.

For a list of message sorting options, select the column header you wish to use

to sort messages and right-click on it. A list of the actions you can perform

will be displayed, which are:

• Sort�ascending: sorts messages from the highest column field value to the

lowest.

• Sort�descending: sorts messages from the lowest column field value to

the highest.

• Group�by�this�field: instead of sorting messages by a given criterion, mes-

sages with the same value (e.g. sender or date) are grouped together and

separated from the rest.

• Remove�this�column: deletes the selected column from the message view.

Another way of removing it is to drag it outside the columns headers.

• Add�column:�with this option, a new column can be added by dragging

it to the column header bar we saw above.
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Figure 11. Diverse e-mail message features

2.1.3. Message information

There are two more useful options for configuring how the program displays

our messages. Both can be enabled and disabled from the View menu. The first

is in View > Message Display and allows us to select the message information

we wish to see. If you only want to view the message contents, it is best to

leave the default option, which is Normal View.

2.1.4. Threaded message view

The other useful option for enhancing viewing in this program is to group

replies to a message with the original for easier communication follow-up. To

turn this feature on or off, go to View > Threaded Message List.

Figure 12. A threaded e-mail message displayed with the full header
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2.1.5. Deleting messages

To delete an e-mail message, select it first by right-clicking on it. You now have

a number of options to delete it. The first is to click on the trash button in

the application's Main toolbar. Other alternatives are to use the Del key or to

right-click the message and select the Delete option.

Note that when we tell the program to delete a message, it is not actually

deleted; it is simply marked for deletion for when the folder is expunged.

Figure 13. E-mail message marked for deletion

To expunge the folder, go to the Folder menu and select the Expunge option

or press the key combination Ctrl+E. When we do so, a warning message will

pop up asking if we want to permanently delete the messages from the folder.

If you do not wish to see this message every time you expunge a mail folder,

mark the Do not ask me again option in the warning dialog box.

Figure 14. Warning dialog box shown before expunging a folder

Although this system gives us an extra level of protection so that we do not

permanently delete messages by accident, users who are used to other e-mail

management programs may find the procedure tedious because it adds anoth-
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er step to the process. If this is your case, you can hide the process using the

View > Hide Deleted Messages option. From now on, the deleted messages

will only appear in the trash, as occurs with other programs.

2.1.6. Restoring deleted messages

It is impossible to restore messages that were permanently deleted from a fold-

er when it was expunged. However, we can restore messages marked for dele-

tion by selecting the Edit > Undelete menu option or using the key combi-

nation�Ctrl+U.

This action will unmark the message for deletion and remove it from the trash.

2.1.7. Checking for new mail

To check for new messages, click on Send/Receive in the toolbar. If you have

not yet entered your e-mail account details, the wizard that launched when

you first opened Novell Evolution will appear again. The first time you down-

load e-mail or if you have not told the program to save your password, a dialog

box will appear prompting you to enter the password.

2.1.8. Folders

Novell Evolution saves e-mail and other program elements in folders to keep

them organised. We can take advantage of this feature to create our own e-

mail folders. The program has some pre-defined basic folders, such as Inbox,

Outbox or Trash, but you can create others to organise your e-mail better. For

instance, you could create a folder called "University" and save all messages

on this topic there. To create a new folder, go to the New Folder menu option.

The program will display a dialog box where you can enter the name and type

of folder and the desired location.
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Figure 15. New folder dialog box

The new folder is created when you click on OK and you can see it in the folder

tree. You will be able to use this folder just as you use the others. To move

messages to the new folder, simply drag them to it or use the Move button on

the Main toolbar. If you want to drag more than one message at a time, you

can use the same technique as Microsoft's Windows Explorer. Hold down the

Ctrl key as you click on messages to select them individually. Alternatively,

hold down the�Shiftkey as you do so to select a range of messages.

2.1.9. E-mail search

If you have a lot of messages in your e-mail program, you may have problems

when it comes to searching for a particular one. Even if you are organised and

have created a folder for each message topic, you will need to be able to use

Novell Evolution's search features.

To use the program's search facility, simply type in the word or phrase in the

text field just below the Main toolbar and then select the type of search. The

program offers a number of search options:

• Body�or�Subject�Contains

This option will search for the word or phrase you typed into the search field

in the subject and text of your e-mail messages.

• Body�Contains
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With this option, you only search for the text in the body of the messages,

not in the subject.

• Subject�Contains

This option will find the messages containing the search text in the subject.

It does not search in the message text.

• Body�Does�Not�Contain

Select this option to find messages that do not contain the word or phrase

in the message body. Messages containing the text in their subject will be

displayed so long as the text is not found in the body.

• Subject�Does�Not�Contain

This option is used to find a message whose subject does not contain the search

text.

• Sender�Contains

Use this search option to find messages whose sender contains the text string

or name indicated.

• Recipients�Contain

Select this option to search for messages whose recipients contain the specified

words or text.

Enter the text and search criteria and press the Enter key for the program to

display the messages it finds.

To view all of your messages again, select the Clear option from the search bar.

You can also perform an empty search, which will produce the same result as

the above operation.

Although we can search very quickly using this system, the available options

are somewhat limited. To perform more complex searches, we will need to

select the Advanced option from the list of search bar options. A new dialog

box will appear in which we can select the search criteria we have already seen.

Nonetheless, this is a much more flexible option because it allows us to search

for messages matching all or just one of our criteria. To launch the message

search, click on Search Now.
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Figure 16. Advanced search dialog box

2.1.10. Attachments and HTML

The program usually displays e-mail attachments at the end of the message,

except if the attachments form part of the format of a HTML message. In the

latter case, these elements (for example, graphics or sounds inserted in the

text) are displayed in the message and not as attachments.

Figure 17. An e-mail with attachments

An image does not have to be included as a message attachment for the pro-

gram to display it with the text. The image can also be a link to an image

located on a remote server. Novell Evolution can display this type of remote

image if you enable the View > Load images option inside the message.
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Figure 18. Tab for configuring the display of remote images

These images are not displayed by default because they are often used by spam-

mers to obtain statistics on the efficiency of the message and other data con-

cerning the privacy of the recipient. This option can be customised in:

Edit > Preferences... > Mail Preferences > HTML Mail

If you receive an e-mail with a text attachment, you can save it to disk or open

it directly with an application. To save the file to disk:

1) Click on the attachment button arrow at the bottom of the message.

2) Select the location where you would like to save the message.

3) Click on OK.

Figure 19. Saving an e-mail attachment to disk

The process for opening an attachment with an application is very similar to

the one above.
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1) Click on the attachment button arrow at the bottom of the message.

2) Select the program you wish to use to open the attachment.

This will launch the program you have chosen and open the attachment in it.

Figure 20. Opening an e-mail attachment with an application

2.1.11. Composing e-mail messages

You can compose a new e-mail message by selecting the Messages > New Mail

Message option or by clicking on the New button in the toolbar when you are

in the e-mail application. You will see that, although the appearance of the

button varies depending on the application you are using, you can always use

the arrow next to it to select the new element you wish to create.

After selecting this option, the new message composition window will open.
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Figure 21. New message composition window

The message composition process is very similar for all e-mail management

programs. A brief description of the steps is as follows: enter the address of the

person you wish to send the message to in the To: text field, then add a Subject

and finally enter the message text in the box at the bottom of the window.

When you have finished writing the message, click on the Send button.

2.1.12. Drafts

If you are writing a very long and complicated message or you simply wish to

pause for a while, you can save a draft of your message in a special drafts folder

and pick up where you left off at a later time, knowing that your data is safe.

To do this, simply select the File > Save Draft menu option in the message

composition window.

Another of the program's features is the possibility of saving messages as text

files. For this, simply go to File > Save As and select a name for the text file.

2.1.13. Working offline

The Novell Evolution program has a Working Offline mode for computers that

do not have a permanent Internet connection. You can work as you normal-

ly would in this mode but actions requiring an Internet connection will be

completed when you next connect to the Internet. E-mail messages are saved

in the Outbox folder.
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Go to the File > Work Offline menu to turn on this mode and to File > Work

Online to reconnect.

The availability of e-mail messages during offline mode will depend largely on

the communication protocol you use to read messages on the server. If you

use POP, all of your messages will be available because they are deleted from

the server and copied to a folder on your computer. However, if you use other

protocols, such as IMAP, the messages are stored on the server and you cannot

generally access them without a connection.

If you work with one of these protocols, you can force the program to keep

a local copy of these messages for permanent access to them, regardless of

whether you are connected to the mail server.

To do this, select the folder, right-click on it and select Properties. Then select

the Copy Folder Content Locally for Offline Operation option. Now, when

Novell Evolution connects, it will copy the contents of this folder to the user's

local computer.

Figure 22. Offline folder selection tab

2.2. Advanced composition features

Now that we have seen the basic operation of the program's e-mail facility, we

will now look at the more advanced aspects of message composition that we

have not yet described.

2.2.1. Attachments

The use of e-mail solely for the purpose of exchanging text messages is a now

thing of the past. It is increasingly common to send documents attached to

messages nowadays.

Novell Evolution makes this a very easy task. To create an attachment, go to

the text composition window and carry out the following steps:

1) Click on the Attach button in the toolbar.

2) Select the file or files to attach to the message.
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3) Click on OK.

Figure 23. Creating an e-mail attachment

When you return to the message composition window, you will see that the

files have been added to the composition window. If you have selected the

wrong file, you can remove the attachments by right-clicking on them and

selecting Remove.

You can opt to display message attachments in the View > Display Attach-

ments main menu option. It is always a good idea to keep this option checked

for your reference and to avoid mistakes.

In addition to the option we have just seen, the program offers a very quick

alternative for automatically creating mail attachments that requires us simply

to drag the attachments to the composition window. When we do this, we

need to be sure that we are dragging the actual file with its contents and not

a link to it. In case of doubt, check the size of the attached file to see whether

you have made a mistake.

2.2.2. Entering recipients

All e-mail management programs allow us to enter three different types of

message recipient:

• Top-level recipients (To:)

• Second-level recipients (CC:)

• Third-level or hidden recipients (BCC:)
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Grouping recipients into a specific level is ultimately a matter of personal

choice and there are no hard and fast rules on which to base our decision. We

generally use the first level when we have just one or only a few recipients and

we combine the first and second when there are many, taking into account

how useful the message will be to these people.

We generally use the second level to send copies of messages to people not di-

rectly interested in the subject. CC is the abbreviation of Carbon Copy, which

is the method that was used in the past to copy documents.

The third level is more complex. BCC means Blind Carbon Copy. It is used

in the same way as the second level but these recipients are hidden from the

other message recipients. It can be used to send messages to large groups of

people who do not know one another or where privacy is required. If you

cannot see this field in the composition window, you can enable it using the

View > BCC field menu option.

One final feature of Novell Evolution is the possibility of setting up a different

reply address to the message sender address. In this case, if the recipients send

replies, they will be sent to this address rather than the address from which

the message was sent. To enable this field, select the View > ReplyTo field

menu option and enter the address.

Figure 24. E-mail message with all recipient fields active

With this program, you can quickly enter the names of recipients in your

contact list. To do so, simply click on the recipient field you require and in the

dialog box that appears select the people you have entered in your contact list.
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2.2.3. Replying to e-mail messages

To reply to an e-mail message, click on the Reply button on the toolbar or

select and right-click the message and choose the option you wish. This pro-

vides greater flexibility because we are given more options, such as replying

to sender only, replying to a list or replying to all message recipients.

Note: the Reply to All option does not include those who were added in the

BCC field of the original message because we cannot see them and hence do

not know their e-mail addresses.

When you reply to a message, the composition screen opens with the To:

and Subject: fields automatically filled in by the program, although you can

change these details if you need to. The full text of the previous message is

also inserted in the new one so you can use the previous text as a reference

for your reply if need be.

Figure 25. Automatic e-mail reply

2.2.4. Use of HTML elements for composing messages

Like most modern e-mail management programs, Novell Evolution can be

used to compose e-mail messages in HTML format. However, this option is

not enabled by default for the reasons we will see below.

It is generally preferable not to send messages in this format because, in our

view, it has only one advantage and many disadvantages.
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• The advantage is simply a matter of aesthetics. These messages are much

more attractive: we can insert graphics, adopt styles and use a range of

fonts with their respective formats etc.

• The disadvantages are numerous: not everybody uses e-mail clients that

accept HTML messages; these messages are much bigger than text-only

messages, which can be a problem for those who read their personal e-mail

on PDAs with memory limits using a mobile GPRS connection; Internet

distribution lists do not accept these messages and lastly, many people

prefer to receive messages in plain text format.

In the light of this, we can see that it is generally a bad idea to send text in

HTML format to people we do not know, Internet mailing lists or for serious

communication. However, we can use it without problems for sending per-

sonal messages to friends or people who we know will not have difficulty re-

ceiving them.

To change the format of an e-mail message during composition, go to the For-

mat > HTML menu option to check or uncheck it, depending on whether you

wish to use this format to compose this message. You can change this prefer-

ence globally by going to the Edit > Preferences... > Composer Preferences

> General menu and selecting the Give HTML Format to Messages option.

However, as we have explained, we do not recommend setting this as the de-

fault format unless you are going to be using the program to send messages to

friends or acquaintances you know can receive these messages without prob-

lems.

Figure 26. Message sending format selection tab
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We will now look at the HTML composition options of Novell Evolution. Click

on the Main toolbar to open a new message composition window. Then go to

format to ensure that HTML format is enabled. If not, you will need to turn it

on to be able to use any of the composition features indicated below.

The HTML formatting tools are located on the toolbar in the space immedi-

ately above the part of the window where you type the body of the message

and in the Format and Insert menus. When you hover over a button, a short

description will pop up to give you a clear idea of each button's function.

Figure 27. HTML formatting toolbar in the composition window

We will now look at each of these actions, grouped into categories based on

their features:

• Headers�and�lists

The left-hand side of the toolbar contains a list from which we can select the

style of text we wish to write in. We use Normal as the default message text

and the Header 1 to Header 6 styles for varying preformatted header sizes,

from large to small. Other styles include lists allowing us to organise message

contents more effectively.
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Figure 28. Message formatted with headers and lists

• Text�style

The text style buttons (bold, underlined, italics and strike through) determine

the appearance of the letters of the text we enter. If we select a text and then

select a new style, this style will be applied to the text. If we have not previ-

ously selected any text, the style will be applied to the next text we type.

Figure 29. Message formatted with text styles
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• Alignment

To the left of the style buttons we saw in the previous section, there are three

paragraph alignment buttons which, like the others, will no doubt be familiar

to readers. The button to the far left aligns the text of the paragraph to the

left, the one in the middle, centres it and the one on the right aligns the text

to the right.

Figure 30. Message with aligned texts

• Indentation

The button with the arrow pointing left reduces the paragraph indentation

while the one with the arrow pointing right increases it.
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Figure 31. Message with indentations

• Colour�selection

On the far right of the formatting toolbar is the colour section tool. The colour

of the button indicates the text colour currently selected. If you choose a new

colour while you have text selected, this colour will automatically be applied

to the text. If not, the new colour will be applied to the next text you type

in. You can only change text colour with this option. To change the colour of

the page, right-click the message text box and select Page. A dialog box will

appear where you can select the background colour as well as other options.
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Figure 32. Message with different coloured texts

Other options for enhancing the format of the document using HTML can be

found in the Insert menu of the message composition window. Their features

are as follows:

• Links

The Link option of the Insert menu, also accessible from the toolbar, can be

used to insert a link associated with a text. If you simply wish to insert a link

to a website that might be of interest to your recipient, you do not need this

option. Just type the web address in the message body and the program will

automatically detect it and convert it into a link.

If you have already written the text, select it and then enable the function.

You will see how the text automatically appears in the text field associated

with the link.
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Figure 33. Message with link and text with link

• Images

To insert an image in the text, go to the Insert menu and select Image or click

on the toolbar button.

Figure 34. Image insertion dialog box

An image insertion dialog box will appear in which you can select the loca-

tion of the image you wish to insert in the message, together with different

formatting possibilities and the possibility of converting the inserted image

into a link.

• Rules
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Another message composition possibility is to insert horizontal lines in the

text to divide it into different sections. To insert a horizontal line, select the

option from the Insert menu or from the toolbar. The Rule dialog box will

appear. Here, you need to select the type of rule from the available options,

along with size, alignment and style. After completing your selection, click

on the Insert button.

Figure 35. Rule inserting dialog box

• Tables

Tables are a much cleaner and elegant way of dividing text into different sec-

tions. As with the other options, you can turn them on in the Insert menu or

from the toolbar. In the Table insertion dialog box you can select a number of

templates to give a twist to the tables you create. You can, of course, change

attributes too, such as the number of rows, columns and space between them.

After customising the table to suit your needs, click on Insert to add it to the

document.
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Figure 36. Table insertion dialog box

You can edit a table after inserting it in a message by right-clicking on it. If

you select the Table option, it will take you to a very similar dialog box to

the previous one, where you can modify the features of the table. To insert or

delete rows or columns, use the Insert table and Delete table options.

Figure 37. Message formatted with tables

• HTML�templates
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Besides being able to individually insert elements of messages formatted in

HTML, the program also comes with a number of templates containing pre-

designed elements that we can use to enhance the appearance of our messages

very easily and with professional results. To use a template for a message, go

to the Insert menu and select Template or simply click on this button on the

toolbar. The template insertion dialog box will appear, where you can select

the template you require from those available, together with its size and align-

ment. Then click on Insert to position the template at the current cursor po-

sition. To customise the templates, click on the texts or images and replace

them with the ones of your choice.

Figure 38. Message formatted with HTML templates

2.3. Additional features of the e-mail manager

Thus far, we have seen the main tools and options for e-mail use and we have

seen all of the program's most important composition features. However, to

complete this overview of the program, we have yet to see some other key

features, even though they may not be used regularly by all users. We will now

look briefly at these.

2.3.1. Receiving invitations by mail

As Novell Evolution is a personal information manager as well as an e-mail

manager, it can be used to create events in the calendar and e-mail them using

the mail management tool. The invitation is seen as an attachment in iCal

format.
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Figure 39. Invitation received as an e-mail message attachment

To reply to a request, click on the attachment button and select the View

online option to see all of the information in it. Once you have read all this

information, you have a number of options:

• Accept

Select this option if you are sure that you will attend the meeting. When you

click on OK, the meeting will be automatically entered in your calendar.

• Tentatively�accept

This option indicates that you will probably attend the meeting but are not

100% sure. When you click on OK, the appointment will be entered in your

calendar but it will be marked as tentative.

• Decline

Select this option if you cannot attend the meeting. The meeting will not be

automatically added to your calendar but a reply will be sent to the event host

if the RSVP option was selected.

• RSVP

When this option is turned on, as recommended, a reply is sent to the event

organiser.
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Figure 40. Accepting invitations dialog box

We will see how to send these invitations later on when we look at the features

of the program's calendar.

2.3.2. Folder subscription system

If you use the IMAP protocol to connect to your mail server, one very impor-

tant feature is the possibility of subscribing only to certain folders to check

whether they have mail. There will generally only be one, two or three server

folders that we wish to check for new mail because this protocol operates re-

motely, meaning that these operations take up a considerable amount of time

and resources. The server can also contain empty folders and there is no point

in checking these for new mail.

We will now see how to subscribe to selected folders.

1) Go to the Folders > Subscriptions menu option.

2) Select the e-mail account that you wish to change your subscriptions for.

3) Select the folders you wish to subscribe to by clicking on them. Some

servers using the IMAP protocol can also display folders that are not e-mail

folders. In this case, ignore them and do not subscribe to them.

4) Once you have selected the folders using the above criteria, click on Sub-

scribe to add them to the list of subscribed folders.

5) Close the window.
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Figure 41. Remote folder subscription tab

2.3.3. Encrypting e-mail messages

Although the aim here is not to provide a detailed description of the complex

topic of encryption, we will need to deal with some concepts if we are to un-

derstand how this process works in relation to the features of Novell Evolution.

Encrypting is a technique that encodes messages so that only their recipients

can read them. Although a third-party could intercept the message before it

reaches the recipient, the contents will be illegible to this person.

Novell Evolution uses the GPG program to encrypt and decrypt messages.

The GPG program uses two types of key: public and private. With this tech-

nique, we can give out our public key to anybody who wishes to receive en-

crypted messages and we can also upload it to a public key server on the In-

ternet for public access to it. In contrast, a private key must be kept very safe

and you must never allow anybody access to it.

This dual key system is very secure but it is not very straightforward to use, be-

cause it requires us to carry out different actions depending on our intentions.

• Encrypting�an�entire�message�so�that�it�can�only�be�read�by�the�recip-

ient

To send an encrypted message to somebody, we need to encrypt the message

using the recipient's public key. Thus, to receive encrypted messages, we need

to make sure that the person who wants to send us a message has our public

key.
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• Write�the�message�in�normal�text�and�attach�an�encrypted�signature

so�that�everybody�can�read�the�message�and�the�recipient�can�use�the

encrypted�signature�to�confirm�its�authenticity.

To sign messages, we have to do the opposite. Encrypt the signature with our

private key so that the message recipient can use our public key to confirm

the authenticity of the signature and the message.

We can tell the program to always encrypt outgoing messages. To do this, go

to the Edit > Preferences...> Mail Accounts menu and select the account you

wish to use to always send encrypted messages from and then click on Edit. In

the mail account configuration screen that appears, click on the Security tab.

Then check the Always Sign Outgoing Messages When Using This Account

option.

Figure 42. Mail account security tab

Basic use of the GNU Privacy Guard (GPG) program

We have already seen that we need two encryption keys (one public and one

private) to digitally sign a message. We will now see step by step how we can

obtain these with the GPG program.

1) Open a terminal and type in "gpg -- abans era –genkey".
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2) When you are prompted for the encryption algorithm, select the one that

comes by default with the DSA and ElGamal program.

3) It is now time to select the key length. The longer the key, the more diffi-

cult it is for third parties to decrypt the message. The default option, 1,024

bits, is more than enough for today's needs.

4) You must now decide whether you want your keys to expire and when.

5) The next step is to enter your details: name, e-mail address and a com-

ment. The comment can be any information about you or the details you

have entered that you consider it necessary to add. For example, you could

point out that these are your personal keys, if you plan to create addition-

al professional keys. It is important to enter this information correctly be-

cause it will be used for your electronic signature.

6) You should then enter a password. It is very important not to lose this

because the keys would become invalid and you would be unable to read

coded messages sent to you by others. It is also a good idea to use a dif-

ferent key to any another used for the system to make it very difficult for

others to find out.

7) Once you have completed this step, the program will generate the keys.

Depending on the size of key chosen, the process can take a while. GPG

uses different computer status variables to generate random numbers, so

it is a good idea to move your mouse or launch a program while the keys

are being generated as this will create a better quality key.

To confirm that the process was successful, you can view your key information

using the command: gpg --listkeys as shown below:
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Figure 43. Terminal with the list of keys generated

While it generates the keys, the GPG program also creates a list of public and

private keys. These lists are found in different files in the user folder on the

~/.gnupg/ path. The public key file is called pubring.gpg and can be sent to

the people we want to have our public key so that they can send us encrypted

messages.

If you want your keys to be generally available, you can upload them to a

public key server. This means that anybody can access your public key and

send you encrypted messages or confirm your signature without contacting

you for the key. To do this, you need to continue inside the terminal window.

Firstly, you must obtain your key ID. The easiest way to do this is to type

the gpg -- abans era –listkeys command again and copy the eight-character

string after 1024D in the line beginning pub. In the above screenshot, this

is: 7A1DC5F7.

Once you have the key ID, enter the command: gpg -- abans era –sendkeys

–keyserver wwwkeys.pgp.net 7A1DC5F7. Enter the key password when re-

quested.

Before leaving this basic introduction to GPG, we will look at how to obtain

and import public keys from others in order to send them encrypted messages.

Although all operations are automatically performed by Novell Evolution, we

have to manually import the recipient's public key into our list.

The command for this operation, also entered from a terminal window, is:

gpg -- abans era –revkeys -- abans era –keyserver wwwkeys.pgp.net pass
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, replacing pass with the ID of our recipient. We will need to type in our pass-

word again before the key is automatically imported to our key list. Now, when

we send this person a message, Novell Evolution will allow us to encrypt it.

To import a key sent by e-mail, save it to disk as text and then use the com-

mand gpg file_name, where file_name is the path to the file that we saved to

disk with the key.

2.3.4. Encrypting in Evolution

Once you have your public and private keys, you can use Evolution to encrypt

entire messages or simply to sign them. We will now see the steps required

for this.

To enable encryption of an e-mail account, go to the Edit > Preferences menu

option, select the mail account you wish to use and click on Edit. In the Se-

curity tab, type in your key ID. Remember that you will need to enter the

gpg -- abans era –listkeys command to find out your key ID, as we saw in the

previous section. Once you have entered the key, the program will be ready

to use it.

Figure 44. Mail account security tab

Signing�a�message
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To sign a message, place the cursor in the composition window and select the

Security > Sign with PGP menu option. If the key was installed correctly, the

program will prompt you for your password. Enter it and click on OK. If all

goes well, the message will be signed.

Encrypting�a�message

The procedure for encrypting messages is very similar to the one used for sign-

ing messages that we just saw, but this time we select the Security > Encrypt

with PGP option.

Decrypting�a�message

To read an encrypted message, you will first need to decrypt it. As the sender

will have used your public key to send the message, you will need to type in

your password to view it. The program will prompt you for your password

when you try to view the message. Enter it and you will be able to view the

message correctly.

2.3.5. Message filters

Filters are used to classify messages received into different folders based on

predefined rules. We can have several filters running at the same time, which

means that a message can be copied to different folders.

To make full use of their possibilities, we need to know when these filters are

active. As we saw in other cases, the runtime depends on the type of protocol

we use to communicate with the mail server.

If we use POP (Post Office Protocol) and download mail for local use, the filters

will be applied whenever we check for new mail because this is when the

messages are downloaded from the server.

If we use IMAP (Internet Message Access Protocol) and work remotely, the

filters will be applied when we open the inbox folder on the server. If we

have a filter that moves messages from the server to a local folder, the e-mail

messages will only be available on the local computer where we read our mail

and not on the server.

The steps for creating a new mail filter are as follows:

1) In the main application menu, select the Edit > Message Filters menu to

open the filters dialog box.
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2) In the top part of the options dialog box, select whether you want the

filter to be incoming or outgoing. In most cases, you will choose incoming.

Click on the Add button.

3) You will now need a name for the filter. This should be something con-

nected to what it does so that you can identify what it does quickly. This

will be very important if you have a lot of filters running at the same time.

One rule that can be very useful is to use the name of the folder where the

filtered messages will be sent as the name of the filter.

4) For each filtering criterion, the first thing to do is to select the parts of the

message that the filter should analyse. Most of these parts are obvious but

some have certain nuances that we will now see:

• Sender: the sender's e-mail address.

• Recipients:�the recipients of the message.

• Subject: the subject line of the message.

• Specific�header: the filter can search in any part of the message header

that we tell it to search in. Type the header field in the first text box

and the text to search for in the second. Bear in mind that the program

will only search for the first instance. If the header contains two values

that are the same, filtering will only take into account the first one.

• Message�body: the actual body text.

• Expression: if you know Scheme programming language, you can use

this option to enter a search expression.

• Date�sent: messages are filtered by the date on which they were sent.

You must first choose the message condition (is, is not, is before, is

after) and then the date. The filter will compare the message date field

with the current system date and time or with a date specified in the

calendar. Messages can even be filtered by a specific time interval, such

as messages from the previous week.

• Date�received: this field is used in the same way as the one above but

compares the date on which we received the message not the date on

which it was sent.

• Label: e-mails have a standard priority scale that goes from –3 to 3,

from least to most important. These values can be used to perform a

variety of actions. We can also change this priority using other crite-

ria (sender, date received etc.) and subsequently filter these messages

ourselves based on this priority.
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• Size�(kb): the size of the message in kilobytes.

• Status: Messages can be filtered by their status. This can be: Read,

Replied To, Important and Draft.

• Flagged: indicates whether the message is flagged.

• Attachments: tells us whether a file is attached to the message.

• Mailing�list: this filter is used to establish whether the message comes

from a mailing list and to act accordingly. We can check whether a

message has come from a mailing list using the values in its header.

• Regex�match: if you have a knowledge of "regex" or regular expres-

sions, you can specify search criteria.

• Source�account: if you have more than one account set up in the

program, this option can be useful for filtering if you wish to apply

different criteria to the different accounts.

• Pipe�to�program:�this odd and seemingly complex name is an option

for advanced users to apply a terminal window command to the text

of the received message and to apply the rules based on the value re-

turned by the command.

5) Once we have selected the criterion we wish to use to apply the filter, we

will need to specify the condition for applying it. If we wish to use more

than one criterion for the filter (for instance, to apply it to messages from

a specific e-mail account), click on the Add Criterion button and repeat

the above step.

6) In the section of the dialog box marked Then, indicate the action that the

program should take when it comes across a message that meets the set

requirements. The available options are:

• Move�to�Folder: when this option is selected, the program moves the

message to the folder we have specified.

• Copy�to�Folder: this option copies the message to the specified folder.

• Delete: the message is marked as deleted. Remember that the message

can be restored until the folder is expunged.

• Stop�Processing: we can select this action if a number of filters affect a

single message and the necessary actions have already been performed

and the other filters are not required.
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• Assign�Color: this marks the message with the chosen colour.

• Assign�Score: we can assign a score to the message based on its impor-

tance. In subsequent filtering, we can use the score to further classify

the message by priority.

• Set�Status: this action is used to add a status to the message.

• Unset�Status: this option is used to remove a message status.

• Beep: if a message meets the filter criteria, the computer beeps.

• Play�Sound: similar to the above option, this allows us to select our

own sound. For this feature, the computer must be configured correct-

ly to play sounds.

• Pipe�to�program: this is a very powerful option allowing us to per-

form any action with a terminal window command when we receive

a message, providing excellent flexibility. For example, if we have the

necessary privileges, we can send an e-mail message to our computer

from anywhere in the world ordering it to shut down.

7) After specifying all of the elements required to perform an action, we can

add new actions with the Add Action button and repeat the process we

have seen.

8) To complete the creation of the filter, click on OK.

Figure 45. Filter editing dialog box
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Creating a filter often becomes a complex task because we do not always take

account of all the possibilities that we can come across in our everyday work

when we are creating the filter. You can edit or delete filters you have created

in the dialog box brought up by the Edit > Filters menu option. To change the

settings of an existing filter, select the filter you wish to edit and then click on

Edit. This will take you back to the filter editing dialog box you saw when you

created the filter. In this screen, you can change the various options that were

already configured. To get rid of a filter, simply select it and click on Delete.

Figure 46. Dialog box for configuring mail filters.

2.3.6. vFolders

One of the more advanced ways of classifying e-mail messages in Novell Evo-

lution, which we don't find in many other programs, is vFolders. This is the

name for an advanced method of displaying messages that can be very useful

if we receive a lot of e-mail messages and want to keep them organised.
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A vFolder is actually a combination of elements that we have already seen. It

looks like a normal folder but is created in the same way as we might create

a mail filter. With these two elements, we create a powerful display tool for

messages that are actually in other folders but which we see grouped by a

selection criterion.

If the messages that reach our mail server meet the filtering requirements of

a given vFolder, they will automatically appear in it. And, if we delete the

message, it will also be deleted from its original location and any vFolders that

it might be in. Thus, we can work with vFolders as we would with any normal

mail folder.

The latest versions of Novell Evolution come with predefined vFolders to help

us to understand this concept better. If we go to the folder selector beneath

the toolbar and select the vFolders group, we will see three vFolders that have

already been created: Important mail, Unmatched and Unread mail. Of these

three, the one that could cause the most confusion at this time is the second,

Unmatched, which is the destination for messages that cannot be placed in

the other folders because they do not match the criteria of any vFolders. The

Unread mail vFolder contains all mail marked as unread, while Important mail

contains all messages marked as important.

We will now look at the steps to take to create a vFolder. You will see that the

process is very similar to the one used to create mail filters, which we saw in

the previous section.

1) Select the Searches > Edit Saved Searches menu option.

2) Click on Add.

3) Type a name for the vFolder in the Rule name field.

4) Then select the search criterion for the messages you wish to add to your

vFolder. The message parts that can be used are:

• Sender: the sender's e-mail address.

• Recipients:�the recipients of the message.

• Subject: the subject line of the message.

• Specific�header: the filter can search in any part of the message header

that we tell it to search in. Type the header field in the first text box and

the text to search for in the second. Bear in mind that the program will

only search for the first instance. If the header contains two values that

are the same, filtering will only take into account the first one.
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• Message�body: the actual body text.

• Expression: if you know Scheme programming language, you can use this

option to enter a search expression.

• Date�sent: messages are filtered by the date on which they were sent. You

must first choose the message condition (is, is not, is before, is after) and

then the date. The filter will compare the message date field with the cur-

rent system date and time or with a date specified in the calendar. Mes-

sages can even be filtered by a specific time interval, such as messages from

the previous week.

• Date�received: this field is used in the same way as the one above but

compares the date on which we received the message not the date on

which it was sent.

• Label: e-mails have a standard priority scale that goes from –3 to 3, from

least to most important. These values can be used to perform a variety of

actions. We can also change this priority using other criteria (sender, date

received etc.) and subsequently filter these messages ourselves based on

this priority.

• Size�(kb): The size of the message in kilobytes, including attachments.

• Status:�Messages can be filtered by their status. This can be: Read, Replied

To, Important and Draft.

• Flagged: indicates whether the message is flagged.

• Attachments:�tells us whether a file is attached to the message.

• Mailing� list: this filter is used to establish whether the message comes

from a mailing list and to act accordingly. We can check whether a message

has come from a mailing list using the values in its header.

Once you have selected your criterion and confirmed your options, choose

the folders where you want to search for messages that meet the specified

characteristics. The available options are:

• Specific�folders�only. Obviously you will need to type in the names of

the folders in this case.

• All�local�folders.
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• All�active�remote�folders. Remote folders are considered active when con-

nected to the remote mail server. If you are not connected, the vFolder

will not contain any messages.

• All�local�and�active�remote�folders..

Thus far we have looked at Novell Evolution's main features for e-mail. We

think that you will have enough information here to begin using the program

to meet your average e-mail needs. In addition to these features, we should

point out that Evolution is a very powerful, user-friendly program that far

outshines similar programs for GNU/Linux or any other operating system.
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3. Contact manager

This section will look at how to use the program's built-in contact manager,

which lets users carry out this task in a very intuitive way. To access the con-

tact management tool, simply click on the Contacts button on the vertical

shortcut bar. This will bring up a very easy to use interface.

As you can see, the toolbar is very straightforward compared to the one used

by the e-mail management feature. The buttons on this toolbar are as follows:

• The New button changes here from a new e-mail message to a new contact.

While we are working with contacts, this will be the default value. Click

on it to create a new contact card. Another very quick way of creating a

new contact is to double-click on a blank space in the list of contacts.

• We can use the arrow that appears behind the New button to select the List

of Contacts option, which will then allow us to create a list of individuals

grouped by common features, such as a list of classmates.

• The Send/Receive button is used to synchronise contact information over

networks, should you use this feature (more common in business).

• The toolbar printer button is used to print one or more cards. The printer

must be configured correctly in the system to use this option.

• The trash button is used to delete selected contacts immediately.

• The button with a stop sign is used to stop network data synchronising if

you are working on a network.
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Figure 47. Main contact manager window

The rest of the screen contains your contact information. To the right of the

main window, we can see a series of buttons ordered alphabetically that are

used to select the contacts beginning with this letter. If the window is too

small to fit all of the letters in, a vertical scroll bar will appear automatically.

3.1. Contact editor

The contact editor is the tool used to add new cards or to edit existing ones.

If you want to edit an existing card, simply double-click on it to open the

contact editor. The fastest way of creating a new card is to click on the New

toolbar button as we saw in the previous section.

You can also create a contact card while you are using the e-mail or calendar

manager. To do so, right-click an e-mail address or message and select the

Create Card for this Address or Create Card for this Sender options. These

options will also take you to the program's contact editor.

The contact editor screen has three tabs. The Contact tab contains basic infor-

mation, Personal Information is used to add more detailed information about

this contact and Mailing Address is used to synchronise information on the

availability or calendar of this person over the Internet if the contact makes

this information public. You are unlikely to use this program feature.
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Figure 48. General contact editor tab

The Contact tab has seven sections, each with an icon indicating the type of

information you can enter: face, telephone, envelope, globe, house, filing cab-

inet and a suitcase, which represent, respectively: name and company, tele-

phone numbers, e-mail address, website, postal address, contacts and cate-

gories.

We will now look at the fields with advanced features:

• Full�Name

The Full Name field is used by the user to directly enter a contact's full name.

However, you can also click on the button of the same name to bring up a

wizard in the form of a dialog box to enter this information.
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Figure 49. Full name entry dialog box

A general guide for entering values in this dialog box is:

• Title

Here, you can enter a title yourself or choose one of the preset menu titles.

• Name

Here, you enter the name of the person.

• 2nd�name

If the person has a second name, you can enter it here.

• Surname

Enter the contact's surname here. Cards are sorted by this value.

• Suffix

If our contact has a suffix to his or her name, you can enter it in this field.

You can also use one of the preset options.

Be careful entering the names of your contacts because the program uses these

names to sort the contacts and it will be the most common search method

if you have many contacts. The name is also used as an ID to save card data

internally. Hence, it is very important to be coherent in the way you enter the

data and to always use this same criterion.

• Multiple�field�values

The arrows in the form of upside-down triangles next to some fields can

be used to enter additional data on the contact. Although the program

will only display one of the types of data selected, they will all be saved to

the card and we will be able to access them in the same way.

The Details tab is very easy to use and contains the following fields:
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• Suitcase, for the person's professional information.

• Face, for personal information.

• Map�of�the�world, for other information.

Figure 50. Contact editor details tab

3.2. Searching for contacts

The program offers the same search functions for contacts as it does for e-mail

messages. We can also use the search bar in the top part of the window, under-

neath the toolbar. For quick searching, first choose the location for the type of

search you wish to perform in the first drop-down list in the search bar, enter

the text and click on Search Now. When you have finished with the cards you

searched for, click on Clear to return to the normal contact view.

For an advanced contact cards search, select the Advanced option in the search

bar box containing the list of criteria or use the Tools > Search for Contacts

menu option. Either of these two options will bring up the advanced search

dialog box. We saw a very similar window for creating vFolders and message

searching so you should have no problems with this one.
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Figure 51. Advanced search dialog box

3.3. Contact groups

Organisation of the list of contacts is similar to that of the e-mail manager

in that we can use folders to organise it, although we cannot use vFolders.

Nonetheless, as we shall see, we can sort each contact card into different cate-

gories that we can create to suit our needs. We will now take a look at different

ways of organising cards using contact groups.

The easiest way to group contacts is with the use of folders, as we saw for

e-mail. Selecting contact cards as elements of one or more categories, however,

gives us greater flexibility. And thirdly, straightforward contact lists can be

used to send e-mail messages to the group of people in the list as if we were

sending a single e-mail message.

3.3.1. Folders

By default, all the contact cards we create are sent to a Contacts folder in our

local folders. As we saw in the e-mail manager, we can create a new folder

with the File > New > Folder menu option and locate it where we wish in

the folder tree. Obviously, you will need to make sure that you have created

a Contacts folder type, which will be the default option if you create it when

you are in the contact manager. To move a contact from one folder to another,

simply drag it as you would with an e-mail message. Note that you cannot

place a contact in two different folders.



GNUFDL • PID_00148478 63 Novell Evolution. E-mail manager and personal information manager

Figure 52. Creating new folders dialog box

3.3.2. Categories

Another way of grouping contacts is with the use of categories. We can place

each card in a specific category. For instance, you could put a classmate in

both the studies category and the friends category. To specify a category for

a new contact, open the contact editor (either by creating a new contact or

by double-clicking on an existing contact) and select it with the Categories

button in the bottom left of the window. This will open the categories editor

where you can select all the categories you would like for this contact or, if

necessary, create new ones.

Figure 53. Categories editor window

3.3.3. Lists of contacts

Lists of contacts are useful if we need to send an e-mail message to a group

of individuals as if they were just one person. The steps for creating a list of

contacts are:

1) Open the list creation dialog box using the New toolbar button or the File

> New > Contact List menu option.
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2) Enter a name for the list in the Contact List editor.

3) Enter the names or e-mail addresses of the contacts you wish to add or

simply drag them from the main window.

4) Choose whether to check the Hide Addresses When Sending Mail to This

List option. When this option is marked, the recipients of messages from

the list will not see the addresses of the other list contacts when they re-

ceive a message. It is best to keep this option checked, particularly if you

use long lists. This option has the same effect as using the BCC field for

recipient addresses in the e-mail program.

5) Once you have finished the list, click on Save and Close to save it. The

list will appear as another contact card and you can in fact use it as if it

were a normal card.

To send a message to the list, create a new e-mail message and enter the name

of the list you have created as the recipient. Another option would be to right-

click the list and select the Send Message to Contact option.
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4. Calendar

The last feature of the program that we will look at is the electronic agenda or

calendar. To access this, select Calendar from the vertical shortcut bar.

Figure 54. Overview of calendar management

The buttons to the far right of the toolbar can be used to configure the main

window calendar view. The program comes with a series of preconfigured op-

tions: Day, Work week, Week and Month, but you can customise these views

using the calendar in the top right of the window by selecting the days you

require. To select more than one day, hold down the left mouse button and

move the cursor over the days. The calendar view will automatically be up-

dated when you release the mouse button.

The Prev and Next toolbar buttons can be used to move back and forward

through the pages of the calendar. The scope of the movement will depend

on the selected view. The program moves from day to day in day view and

from week to week when we are in week view The Today button between the

two arrows takes us to today, as we might imagine.

To jump to a specific date, click on the Go to button and select it from the

calendar that pops up.

4.1. Creating appointments

As has been the case for most of the features we have seen, there are a number

of options for creating an appointment in the calendar. We can select the File

> New > Appointment menu option or click on the New toolbar button. A
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quicker and more intuitive option is to search for the time and date of the

appointment and click on the corresponding blank space in the calendar. If

you do this, you have two options. If you click once on the blank space, you

can enter the text summarising the appointment in the calendar. If you dou-

ble-click, the appointment editor dialog box will appear.

Figure 55. Appointment editor dialog box

Every appointment you create must have a start and end. If you did not bring

up the appointment editor in the calendar, you will need to manually enter

these values. You can also select the All Day option, in which case the ap-

pointment will appear in grey underneath the date. This will prevent conflicts

with other appointments. If you create an appointment at the same time as

another, the two appointments will appear one beside the other.

The program also supports time zone specification in the event that the cal-

endar is shared with other people in a different time zone to us. If this is the

case, it is important to specify your time zone correctly to avoid errors. The

steps for configuration of this feature are as follows:

1) Go to the Tools > Configuration...> Calendar and Tasks menu option.

2) In the General tab, go to the Time Zone section and click on the button

with a globe on it.

3) Click on your city or a city close by that is in the same time zone. Then

click on OK.

The Reminder tab can be used to configure a series of alarms to alert us of

appointments at a user-settable time before they begin. There are two types

of alarm:

• Display�a�message

A dialog box appears on screen with a reminder at the set time.

• Play�a�sound
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The system delivers a sound. Your computer must be configured correctly.

• Run�a�program

This option launches a program at the indicated time. You can enter the

name of the program in the text field or use the Search button to select it.

The Classification field is only used if your calendar is synchronised over a

network. The default category is Public, which means that it can be seen by

anybody with access to the network calendar. The Private category increases

the security level, which is maximum when Confidential is selected.

We are normally busy when we are in an appointment so the default value of

the Show Time As field is Busy. If a calendar is shared by several people, this

option can be useful for letting others know when you are free.

The program allows us to categorise appointments, which makes organisation

easier if we have a lot of them. To access these categories, click on the Appoint-

ments tab button. Inside the category selection dialog box, select the ones you

need by clicking on them. You can also create new categories and add them

to this list. In the selection dialog box, click on the Edit Master Category List

button and then on Click Here To Add A Category.

Categories can be used to group all of your appointments for similar activities.

To do this, enter them manually in the categories field of each appointment.

The Recurrence tab is used to define repeat appointments, which can range

from once a day to once every 100 years. This time range should be sufficient

for our needs. We can also choose a time or date for this event to stop recurring.

Recurrence is made more flexible by exceptions, which let us select individual

days on which the event will not recur.

Once you have finished entering all of this information, click on the disc but-

ton on the toolbar and close the editor dialog box. You can change all of the

data you have entered later on by clicking on the appointment in the calendar.

4.2. Sending invitations by mail

Novell Evolution has a quick and easy way of sending out invitations to people

who have to attend an appointment or meeting in which replies are managed

automatically.

When we create a group meeting, we can mark the people affected in sever-

al categories as attendees. When we save the details of the appointment, an

e-mail message will automatically be sent to each person with all of the infor-

mation about the event. The e-mail will give them the option of responding

to the invitation. If you simply wish to announce the event to certain peo-

ple and do not want to receive information from attendees, you can use the
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Actions> Forward as iCalendar option that appears when you right-click the

appointment. This will open a new e-mail message with the meeting informa-

tion attached but without the auto-reply message.

The steps for scheduling a meeting are:

1) Select an appointment created previously and right-click on it. Then select

the Schedule A Meeting option.

2) If you have more than one program identity, you will need to select the

correct one from the Organiser field.

3) Click on the space entitled Click Here To Add An Attendee and enter the

name and e-mail addresses of the people you wish to invite. You can also

select attendees from the cards in your list of contacts.

4) When we save a meeting, an e-mail is automatically sent to all attendees.

Meeting invitations are sent by e-mail as message attachments in iCal format.

To respond if the text message does not appear, click on this and select View

Attachment Inline. The recipient will then be able to view all the information

concerning the invitation and select the appropriate reply. The program offers

three preset options:

• Accept

• Tentatively�accept

• Decline

Figure 56. Invitation to a meeting sent by e-mail
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When you click on OK, a message is sent to the organiser with the response

you have selected. If you have agreed to participate, it will automatically be

added to your calendar. However, there is a slight problem with this. The event

can only have one organiser and any changes you make to it can be overwrit-

ten if the organiser updates the invitation. If you need to change something

in an invitation sent to you for any reason, it is best to contact your organiser

for him or her to make the relevant changes.

Figure 57. Response to an invitation received by e-mail

When you receive a reply, you must view it online in the e-mail viewer. To do

this, click on the attachment and select View Inline if the attachment is not

automatically displayed. Click on Accept at the end of the message to update

the list of attendees.
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5. Tasks

The tasks panel feature lets us save a list of tasks without assigning them to

a specific calendar date.

We can access the task panel from the calendar or from the shortcut on the

vertical bar. We can also access a task folder from the program's folder tree.

In the calendar application, this option is located in the bottom right of the

window but is much easier to access in Task View.

Figure 58. View of Novell Evolution's Task Manager

To create a new task, simply click on the space containing the text Click To Add

A Task and enter a name. Once you have typed in the name, press Enter for

the task to be added to the Task List. To configure more options, double-click

on it to bring up the Task Editor dialog box.
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Figure 59. Task Editor dialog box

This first screen contains a number of sections, which we will now look at

briefly:

• Summary:�description of the task that will appear in the To Do list.

• End�date: the date on which the task must be completed. This can be

entered in the text field or selected from the calendar.

• Start�date: the date on which you expect to begin to work on the task.

• Description: this field is used to add more detailed information on the

task than that offered in the summary. For instance, we can enter the

progress made with the task.

• Classification: if we are sharing the calendar on a network, this field in-

dicates the visibility of the task.

• Contacts: we can add contacts to the task to share it with others.

• Categories: if we have created a number of tasks, we can classify them

into different categories to help us organise them.

The Details tab can be used to set values such as the priority and progress of

the task. Lastly, the Assigned tab can be used to add contacts and their roles to

the task. After entering the necessary data, click on the Save And Close button

of the dialog box toolbar.
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Figure 60. Task editor details tab

To display or edit a task that you have created, double-click on it or select it

and then right-click on it and choose the Open option. Both of these options

will take you to the Task Editor we have just seen. To delete a selected task,

click on the Delete toolbar button. The task summary will be displayed with

strikethrough, as occurs with e-mail messages.

We can also organise task lists with the headers of the columns containing the

tasks. Click on these to choose the method and direction of sorting. You can

also add or remove columns.
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Summary

In this unit, we have seen how to install and configure Novell Evolution and

explained the key features that make it such an excellent group tool, including

its management of e-mail messages and its calendar.

Much of this unit has been concerned with the e-mail management program,

including how to create new e-mail accounts and users and how to compose

e-mail messages in HTML format.

Where possible, we have focused on the security of the program, as in the

possibility of sending and receiving encrypted messages through keys gener-

ated with the GPG program.
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